Can't update aur/ceph-libs 15.2.17-1 -> 16.2.7-1

Among other errors, it gives these file conflicts trying to update some hundred python/jdk-openjdk packages:

errore: impossibile eseguire l’operazione richiesta (file in conflitto)
python-rsa: /usr/bin/pyrsa-decrypt è già presente nel filesystem
python-rsa: /usr/bin/pyrsa-encrypt è già presente nel filesystem
python-rsa: /usr/bin/pyrsa-keygen è già presente nel filesystem
python-rsa: /usr/bin/pyrsa-priv2pub è già presente nel filesystem
python-rsa: /usr/bin/pyrsa-sign è già presente nel filesystem
python-rsa: /usr/bin/pyrsa-verify è già presente nel filesystem

and file not found for:

errore: il seguente pacchetto non è stato trovato: boost
errore: il seguente pacchetto non è stato trovato: nodejs
errore: il seguente pacchetto non è stato trovato: coffeescript
errore: il seguente pacchetto non è stato trovato: cunit
errore: il seguente pacchetto non è stato trovato: fcgi
errore: il seguente pacchetto non è stato trovato: gtest
errore: il seguente pacchetto non è stato trovato: gperf
errore: il seguente pacchetto non è stato trovato: java-runtime-common
errore: il seguente pacchetto non è stato trovato: libnet
errore: il seguente pacchetto non è stato trovato: jre-openjdk-headless
errore: il seguente pacchetto non è stato trovato: jre-openjdk
errore: il seguente pacchetto non è stato trovato: jre11-openjdk-headless
errore: il seguente pacchetto non è stato trovato: java-environment-common
errore: il seguente pacchetto non è stato trovato: jdk-openjdk
errore: il seguente pacchetto non è stato trovato: java-hamcrest
errore: il seguente pacchetto non è stato trovato: junit
errore: il seguente pacchetto non è stato trovato: leveldb
errore: il seguente pacchetto non è stato trovato: libcurl-compat
errore: il seguente pacchetto non è stato trovato: librabbitmq-c
errore: il seguente pacchetto non è stato trovato: python-lazy-object-proxy
errore: il seguente pacchetto non è stato trovato: python-wrapt
errore: il seguente pacchetto non è stato trovato: python-astroid
errore: il seguente pacchetto non è stato trovato: python-cheroot
errore: il seguente pacchetto non è stato trovato: python-tempora
errore: il seguente pacchetto non è stato trovato: python-portend
errore: il seguente pacchetto non è stato trovato: python-jaraco.collections
errore: il seguente pacchetto non è stato trovato: python-zc.lockfile
errore: il seguente pacchetto non è stato trovato: python-cherrypy
errore: il seguente pacchetto non è stato trovato: python-coverage
errore: il seguente pacchetto non è stato trovato: python-elasticsearch
errore: il seguente pacchetto non è stato trovato: python-werkzeug
errore: il seguente pacchetto non è stato trovato: python-itsdangerous
errore: il seguente pacchetto non è stato trovato: python-flask
errore: il seguente pacchetto non è stato trovato: python-aniso8601
errore: il seguente pacchetto non è stato trovato: python-flask-restful
errore: il seguente pacchetto non è stato trovato: python-cachetools
errore: il seguente pacchetto non è stato trovato: python-rsa
errore: il seguente pacchetto non è stato trovato: python-google-auth
errore: il seguente pacchetto non è stato trovato: python-httplib2
errore: il seguente pacchetto non è stato trovato: python-google-auth-httplib2
errore: il seguente pacchetto non è stato trovato: python-uritemplate
errore: il seguente pacchetto non è stato trovato: python-protobuf
errore: il seguente pacchetto non è stato trovato: python-googleapis-common-protos
errore: il seguente pacchetto non è stato trovato: python-google-api-core
errore: il seguente pacchetto non è stato trovato: python-google-api-python-client
errore: il seguente pacchetto non è stato trovato: python-grpcio
errore: il seguente pacchetto non è stato trovato: python-toml
errore: il seguente pacchetto non è stato trovato: python-isort
errore: il seguente pacchetto non è stato trovato: python-mccabe
errore: il seguente pacchetto non è stato trovato: python-isodate
errore: il seguente pacchetto non è stato trovato: python-pkgconfig
errore: il seguente pacchetto non è stato trovato: python-xmlsec
errore: il seguente pacchetto non è stato trovato: blas
errore: il seguente pacchetto non è stato trovato: cblas
errore: il seguente pacchetto non è stato trovato: lapack
errore: il seguente pacchetto non è stato trovato: python-numpy
errore: il seguente pacchetto non è stato trovato: python-pbr
errore: il seguente pacchetto non è stato trovato: python-webob
errore: il seguente pacchetto non è stato trovato: python-mako
errore: il seguente pacchetto non è stato trovato: python-waitress
errore: il seguente pacchetto non è stato trovato: python-webtest
errore: il seguente pacchetto non è stato trovato: python-logutils
errore: il seguente pacchetto non è stato trovato: python-pecan
errore: il seguente pacchetto non è stato trovato: python-pluggy
errore: il seguente pacchetto non è stato trovato: python-prometheus_client
errore: il seguente pacchetto non è stato trovato: python-iniconfig
errore: il seguente pacchetto non è stato trovato: python-apipkg
errore: il seguente pacchetto non è stato trovato: python-py
errore: il seguente pacchetto non è stato trovato: python-pyjwt
errore: il seguente pacchetto non è stato trovato: python-repoze.lru
errore: il seguente pacchetto non è stato trovato: python-routes
errore: il seguente pacchetto non è stato trovato: python-scipy
errore: il seguente pacchetto non è stato trovato: python-joblib
errore: il seguente pacchetto non è stato trovato: python-threadpoolctl
errore: il seguente pacchetto non è stato trovato: python-scikit-learn
errore: il seguente pacchetto non è stato trovato: python-babel
errore: il seguente pacchetto non è stato trovato: python-imagesize
errore: il seguente pacchetto non è stato trovato: python-snowballstemmer
errore: il seguente pacchetto non è stato trovato: python-sphinx-alabaster-theme
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-applehelp
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-devhelp
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-htmlhelp
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-jsmath
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-qthelp
errore: il seguente pacchetto non è stato trovato: python-sphinxcontrib-serializinghtml
errore: il seguente pacchetto non è stato trovato: python-sphinx
errore: il seguente pacchetto non è stato trovato: python-filelock
errore: il seguente pacchetto non è stato trovato: python-virtualenv
errore: il seguente pacchetto non è stato trovato: erlang-nox
errore: il seguente pacchetto non è stato trovato: socat
errore: il seguente pacchetto non è stato trovato: rabbitmq
errore: il seguente pacchetto non è stato trovato: debuginfod
errore: il seguente pacchetto non è stato trovato: valgrind
errore: il seguente pacchetto non è stato trovato: xmlstarlet
errore: il seguente pacchetto non è stato trovato: yaml-cpp
errore: il seguente pacchetto non è stato trovato: yasm
errore: il seguente pacchetto non è stato trovato: python-mock
errore: il seguente pacchetto non è stato trovato: python-nose
errore: il seguente pacchetto non è stato trovato: python-pycodestyle
errore: il seguente pacchetto non è stato trovato: python-dill
errore: il seguente pacchetto non è stato trovato: python-tomlkit
errore: il seguente pacchetto non è stato trovato: python-pylint
errore: il seguente pacchetto non è stato trovato: python-pytest
errore: il seguente pacchetto non è stato trovato: python-pytest-cov

In /etc/pacman.conf:
IgnorePkg = ceph-libs

obviously does its duty, but the problem persists.
I can give a more detailed log, any suggestion, please?

Thanks in advance, Piero

1 Like

Most probably you could remove ceph-libs as it was dropped from the repos. See:

Also:

Try

sudo pacman -Syyu

If that won’t work, refresh your mirrors an try the same again.

Thanks!

You are welcome!

If your issue is resolved, please mark the post that pointed to the solution as “solution”.

:enos_flag:

1 Like

Thanks is the solution? You should mark pebcak’s post as the solution not your own.

3 Likes

Screenshot from 2022-10-07 10-07-33

You are welcome @storm however that is not the post which solved the issue stated in the topic.

This one did:

Please mark the correct post as solution for other users who might have the same issue to find it more easily.

Thank you in advance!

1 Like

But I did mark it since the 1st time:
"

Solved by storm in post #3 ‘Thanks’
"
Thanks again, anyway

If you think “Thanks!” was the solution to:

Can’t update aur/ceph-libs 15.2.17-1 → 16.2.7-1

Then fine. Conventionally, the post that gave or pointed to the solution of the topic should be marked as such.

1 Like

Feeling dumber than the usual. What am I supposed to do now exactly?

Mark the post that solved your problem, as @pebcak

This one did:

[quote]
Most probably you could remove ceph-libs as it was dropped from the repos. See: Also: Try sudo pacman -Syyu If that won’t work, refresh your mirrors an try the same again.
[/quote] :wink:

1 Like

Hope it’s ok now

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.