Cant install new iso

For whatever reason, the live iso does not see my NIC or my internet connection {Yes it works fine} the old iso saw it and installed it just fine.

Any thoughts as to why

Need more input! For starters, the following would be helpful to know:

  1. wifi or not
  2. between sets of triple ` - inxi -Faz
  3. approximate (within 300/500 km) location
  4. any error messages seen

With that we can start at least guessing…

1 Like

I run a LAN cable directly from my router 20 feet away from it to the jack provided by the landlord and the ISO does not see it or the wifi.

the Error message is no internet available.
It works fine for every other ISO install

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether d4:5d:64:53:e9:95 brd ff:ff:ff:ff:ff:ff
3: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether d4:5d:64:53:e9:96 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.21/24 brd 192.168.1.255 scope global dynamic noprefixroute enp7s0
valid_lft 76035sec preferred_lft 76035sec
inet 192.168.1.16/24 brd 192.168.1.255 scope global secondary dynamic noprefixroute enp7s0
valid_lft 76035sec preferred_lft 76035sec
inet6 fe80::e887:2d7a:671e:3fa5/64 scope link noprefixroute
valid_lft forever preferred_lft forever
5: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether ce:0b:df:08:d9:20 brd ff:ff:ff:ff:ff:ff permaddr 4c:1d:96:6c:ab:47
[chuck@arch ~]$

Still need item #2 - the inxi result. Could be the driver for your ethernet is causing problems. In the live environment, if I recall correctly, there is a button for changing that driver (r8168/9) - have you tried that? More likely to get a good answer with good info though (even if you don’t think it relevant).

If i put it in the terminal this is all i get
[chuck@arch ~]$ -inxi -Faz
bash: -inxi: command not found

Button to change driver i will look into that.

Hello @NibblesMctwitch
It seems a number of people are having this issue and it needs to be investigated. I don’t understand why because i tested this ISO a lot. I just asked another user to try this and see if it makes any difference. Go to this link for the procedure.

The driver listed you have blacklisted on the ISO i was unable to change that file will try your suggestion

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller
Subsystem: ASUSTeK Computer Inc. Device 879b
Flags: bus master, fast devsel, latency 0, IRQ 24, IOMMU group 25
I/O ports at e000 [size=256]
Memory at fc710000 (64-bit, non-prefetchable) [size=64K]
Memory at fc720000 (64-bit, non-prefetchable) [size=16K]
Expansion ROM at fc700000 [disabled] [size=64K]
Capabilities:
Kernel driver in use: r8169
Kernel modules: r8169

It does show a module loaded for the RTL8125 2.5 GB Ethernet and as far as i know should be working as it was supposed to be supported now. So I’m not sure you have the same issue as the other user who has no ethernet or wifi.

no - before inxi command. It’s just inxi -Faz

Same here I don’t have ethernet or wifi and I tried your suggestion and when I put in sudo xed nothing ever came up I do not get a welcome screen either.
All I get is the bottom right network icon with a red x.

Honestly i don’t know what the issue could be. It doesn’t make sense. What is on the screen then? If there is no welcome? You have the desktop loaded? Did you try booting up the system without ethernet connected just to see if the desktop loads any different? Then plug the ethernet back in after checking for wifi first?

Edit:
Also If disconnected can you get into those files and change them?

Did you try usb tethering from smartphone?

Ok so when the ISO loads I have the desktop and menus it doesn’t matter if ethernet is plugged in or not it’s all the same I cant get root so can’t edit the files.

No i have not.

Keep getting command not found.on the inxi -Faz

Is inxi installed?

pacman -Qi inxi

Do you have two Ethernet ports on the system? If so try the other one. One shows down!

I would try usb tethering. Had similar issue on other distro, after successful installation with tethering. Internet connection where working normally.

ISO has no root password simply type sudo su in terminal and you are root, or use sudo xed to run editor as root…

And ISO has inxi installed… so may you are not using latest ISO?

1 Like

And as this is a troublesome realtek nic … i see users having issues like this it helps to do the following:
sudo su
sed -i /usr/lib/modprobe.d/r8168.conf -e 's|r8169|r8168|'
rmmod r8169
modprobe r8169

Seems that it is try using the blacklisted r8169 module but then fails on that because it is blacklisted.

reference:

1 Like