Cannot log in to new router

Hi there,

I’ll try to make it short,

I moved to another house, into a more rural area than before, so I spent a month without an internet provider. A month that felt like a year has passed xDD.

Before moving, I installed Linux Mint, the one based on Debian and not Ubuntu, out of curiosity. A couple days ago, I got a ‘Telcel’ router, I hate them, but is the only one that works out here, it has a simm card and connects to G4. So, when I tried to log in to that g4 thing, it fails to connect, it kept asking for the password.

So I installed EOS back with the latest ISO I had, endeavouros-2020.09.20-x86_64.iso; and same deal, it keeps asking for the password.

I am using my phone as a USB tether, and that is how I am posting this.

I found this poor guys post, with a similar issue, same Qualcomm Atheros QCA9377 Network Controller

But I can see the wifi in the list, just fails to accept the login.

I ran an inxi and neofetch

/sssso-                --------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: Inspiron 5570 
             `-/ossssssssssssso/.          Kernel: 5.9.11-arch2-1 
           `-/+sssssssssssssssso+:`        Uptime: 1 hour, 39 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 924 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.0.18 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: GNOME 3.38.1 
  `:////ssssssssssssssssssssssssssso+++.   WM: Mutter 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Adwaita 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: HighContrastInverse [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: Faenza [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: gnome-terminal 
                                           CPU: Intel i5-8250U (8) @ 1.600GHz 
                                           GPU: Intel UHD Graphics 620 
                                           GPU: AMD ATI Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile 
                                           Memory: 2577MiB / 7854MiB
System:    Host: Dellnabo Kernel: 5.9.11-arch2-1 x86_64 bits: 64 Desktop: GNOME 3.38.1 Distro: EndeavourOS 
Machine:   Type: Laptop System: Dell product: Inspiron 5570 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 09NFWR v: A00 serial: <superuser/root required> UEFI: Dell v: 1.2.3 date: 05/15/2019 
Battery:   ID-1: BAT0 charge: 38.4 Wh condition: 38.4/42.0 Wh (91%) 
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 700 MHz min/max: 400/1600 MHz Core speeds (MHz): 1: 701 2: 701 3: 727 4: 697 5: 745 6: 704 7: 758 8: 745 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
           Display: x11 server: X.org 1.20.10 driver: amdgpu,ati,intel unloaded: fbdev,modesetting,vesa 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.3 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.9.11-arch2-1 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
           IF: enp2s0 state: down mac:
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci 
           IF: wlan0 state: down mac:  
           Device-3: Qualcomm Atheros type: USB driver: btusb 
           IF-ID-1: enp0s20f0u3 state: unknown speed: N/A duplex: N/A mac:
Drives:    Local Storage: total: 2.29 TiB used: 161.24 GiB (6.9%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000PNP size: 476.94 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
Partition: ID-1: / size: 468.78 GiB used: 6.50 GiB (1.4%) fs: btrfs dev: /dev/nvme0n1p2 
           ID-2: /home size: 468.78 GiB used: 6.50 GiB (1.4%) fs: btrfs dev: /dev/nvme0n1p2 
Swap:      ID-1: swap-1 type: partition size: 7.67 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 39.0 C mobo: 35.0 C sodimm: 35.0 C gpu: amdgpu temp: 37.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 291 Uptime: 1h 38m Memory: 7.67 GiB used: 2.82 GiB (36.8%) Shell: Bash inxi: 3.1.09

I can see enp2s0 state down and wlan0 state down, I don’t know why nor how to get them back on.

That was longer than I intended, sorry.

Thanks.

There is a password to log onto the router. For telcel try user name root and password 1111

Edit: If this doesn’t work and you have a different password and or user name saved on the router settings you can restore the router to factory default. Press and hold the button on the bottom of the router for 20 seconds and it will reset. Then you can try again.

Try connecting via ethernet and reset the password just to make sure. Login is normally admin, and password should be on the sticker of your router or could also be admin. You could also try to reset the router and connect again.

It looks like your ethernet is Realtek and is loading the R8169 module. You may need the R8168 module which is a package you can download and install or put on a usb to install. The wifi is the Qualcomm Atheros QCA9377 which is problematic. So if you can hook up to ethernet that may be easier to get working to start with.

Need more info on the router:

Perhaps a picture of it and a model number from the unit?
image

Hello,

It is the white one, Alcatel linkhub HH41NH,

I bought a 12 meter LAN wire so I was able to go into 192.168.1.1; and I changed the SSID, and password, every other device in the house (LG smart TV and a few phones, and my older laptop) was able to log in, except this laptop.

Before I Installed EOS back, I installed a few distros, open suse leap 15.2 was able to log in, Ubuntu 20.10 live did not, neither Fedora 32.1.6 (I was trying to rule out that the hardware broke, not going away from EOS xD)

so, some distros work, some do not, I do not feel like it is about the atheros device, I have been on EOS for a while and only now has issues,

I am looking into the router config, but nothing seems to be out of place,

ok, as was writing this, I figured I would try to have the router with zero security (no password), and it still got ‘connecion failed’ message.
“Authentification required
password or encryption key are required to acces the wireless network”

Maybe the wifi module in EOS is broken? it is a fresh install, i do not mind installing again.

Laters.

If other devices can connect to it and that computer can when running other distros, then I think the issue is with the EOS set up, not the router itself. I would check around here for more info on your wifi, the Qualcomm Atheros QCA9377. A quick look shows the below, which is for another DE, but might be helpful.

Here is the user manual for Alcatel HH41NH

Alcatel_LINKHUB_User_Manual_English.pdf (1.1 MB)

2 Likes

3g or 4g makes no difference, you might find something useful here.

1 Like

You should hide MAC addresses in forums with option “z”:

inxi -Fz

If you search with the search words linux Atheros QCA9377 state down, you will find several things, e.g. this.

In any case it is important to use the correct ath10k firmware for the respective kernel (I wouldn’t be surprised if you take the LTS kernel 5.4 and it works).

You should solve this and not try older EndeavourOS or other Linux distributions.

1 Like

Oh boy, I did not think of that, thx.

Laters

Have you tried using the latest firmware. I’m not sure how to install exactly.

Edit: I would just download it from here and replace the ath10k folder in /usr/lib/firmware and unload the module and reload it.

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-20201118.tar.gz

All right,

I tried these options, but either they did not work or I am too newbie to pull it off,

So I went downtown and bought a little USB wifi and plugged it in, came up as “Realtek RTL 8192 CU” on my hardware list, and it works just fine.

I am still going to try to solve it, for the time being is a not-really-solution-but-it’s-okay thing.

However, I used it to re-install EOS, and now I have an issue of getting a black screen with a cursor when I reboot EOS.

There are several threads about it, so I am gonna leave it out of here.

I will fix it eventually, but now I have this other thing to look at, xD, fun times, at least I have internet access to work it. I’m still around.

Laters

1 Like