Laptop Does Not Connect To 2.4 GHz Wifi

So here is my problem
My laptop has Qualcomm Atheros QCA9377 Network Controller

lspci -k

Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
Subsystem: Lite-On Communications Inc Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

It only connects to 5GHz wifi networks . 2.4GHz networks are not even detected from the beginning i.e. from when I started using Ubuntu , all the way up to Endeavour . It connected to 2.4GHz wifi when Windows was running . I did search the internet but all of them are about not conneting to 5GHz and 2.4 works perfect , so I am lonely :confused: . I tried some of those solution in many distros without success . Now it’s time to try out something in Endeavour .

This reddit post 8 months old was found yesterday . His problem is just the opposite of mine as usual but the second post talks about a solution . And the OP confirms it works . Also it’s the same Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31) but uses Linux Mint .

As a total newbie I don’t know if it’s safe to try this out in Endeavour . So any experienced users ; should I try this solution ??

Edit: It is using the correct module.

What does this give you

dmesg | grep ath

Seems like this chip has issues. This is the latest i can find.

Edit2: 5.9.11-arch2-1 kernel just came out. See if any difference.

[16157.239479] ath: EEPROM regdomain: 0x833a
[16157.239482] ath: EEPROM indicates we should expect a country code
[16157.239486] ath: doing EEPROM country->regdmn map search
[16157.239491] ath: country maps to regdmn code: 0x37
[16157.239495] ath: Country alpha2 being used: GB
[16157.239497] ath: Regpair used: 0x37
[16157.239501] ath: regdomain 0x833a dynamically updated by country element

This is what I got when connected to 5GHz wifi . Otherwise nothing .

I will try that right now !

Edit : Nope ! 5.9.11-2-arch2-1 did not help . 2.4GHz wifi is still not visible

One more interesting fact is that when I turn on Hotsopt on my lap it only allows 2.4GHz band .
i.e. it connects only to 5GHz and shares only 2.4GHz :upside_down_face:

Have you tried disabling encrypted connection?

It has no effect . The network is not visible . But about an year ago when I started using Manjaro my phone would connect to my laptop’s hotspot only when security was disabled . But now it’s not a problem . So I hope one day this will magically get fixed by the arch devs

:woozy_face::woozy_face::woozy_face::woozy_face::woozy_face::woozy_face:

I’m talking about nohwcrypt=1 in module configuration

Edit:

sudo modprobe -rfv ath10k_pci
sudo modprobe -v ath10k_pci nohwcrypt=1

Ehm ! What exactly is that

I am a newbie :man_shrugging:

Remove the module ath10k_pci and then load it without hardware encryption.

Don’t I need hardware encryption ??

You can try this solution listed here.

Yes - trying the firmware listed in the Reddit post is relatively safe. The worst it might do is render your wifi card inoperable.

1 Like

But I will still have ethernet , rght ?

Edit : That solution did not work , so all I can do is wait