Cannot boot up after installation

Could you try fetching it again, this time with command

 sudo pacman -Sy inxi

Alpix just fixed a mirror certificate issue, so that might help.

yes, mirrors evos seems to be down

http://ix.io/2P1V

You seem to have UEFI system. But the disk is prepared with the dos partition table but it should be gpt. Maybe it is an old disk?

So, if possible, I suggest you reinstall EndeavourOS so that the partition table is gpt.
You can prepare the disk with gparted before installing. Gparted has a menu to create the partition table: Device --> Create Partition Table

Note that doing this will wipe everything from your disk. If you have anything worth keeping there, copy that stuff to another disk before doing anything else.

thank you. will do as per your instructions. is a new computer, so is as brand new disk. have not got it working yet, so nothing is on it.

will report back, and if get the same message again, revert with the info you need.

am grateful for your help

You might want to check the BIOS to make sure the boot settings are set to UEFI Only and not Legacy / BIOS which should be as Manuel mentioned your drive is set to DOS which would be for a legacy/BIOS boot and not GPT which is for UEFI. Hopefully this little explanation helps you understand what is happening and not just blindly typing commands.

1 Like

@nals

Sorry, at this point I actually find that hard to believe.

The error (see below) you posted in another (now locked) thread typically occurs when residue from former installations or installation attempts gets in the way.

error: device UUID xxxx" not found
mount: /new root cannot find VOID=xxx

Scanning through these threads, I see multiple attempts to get you to create a new GPT partition table. At this point (this is the ~160th post here) I simply don’t understand why you haven’t followed this easy suggestion up till now.
Same problem with your chroot-attempts. There seems to be a problem with following instructions.


tldr;
I greatly suspect everything you need to fix your issue has been addressed here!
Knowing how to chroot is a useful skill but shouldn’t be necessary when installing through calamares.

So, please, just “empty” the storage device you want to install to by creating a new GPT partition table and then do an “automatic” install with the EndeavourOS installer. Basically what you should have tried days ago.

2 Likes

@nals
As @2000 has said you just need to boot on the live ISO. Do not start the installer yet. Go to the start menu and launch gparted. You want to use device, create partition table. In the drop down menu you want to select GPT and click apply and create a new GPT partition. This will completely wipe out the disk. Then close gparted and start the installer and use erase disk and select hibernate with swap or swap to file. It’s your choice. Follow the prompts and select the online install and select the desktop you want to install and complete all the necessary steps required and then start the install process.

1 Like

rick,
did as per your instructions
gparted device partition table, gpt from the dropdown, apply
then installer, online version, erase disk option and xfce desktop.

still get the same eroor : cannot find UUID xxxx message

ran the various commands that manuel wants info on, but everything has

mktemp: failed to create file via template ‘/root/.config/eos-sendlog.XXXXX’: No such file or directory
mv: missing destination file operand after '/root/.config/eos-sendlog.txt'
Try 'mv --help' for more information.
/usr/bin/eos-sendlog: line 56: /root/.config/eos-sendlog.txt: No such file or directory
/usr/bin/eos-sendlog: line 57: /root/.config/eos-sendlog.txt: No such file or directory

install log

http://ix.io/2P6w

inxi -Mz

http://ix.io/2P6z

lsblk -fm | eos-sendlog

http://ix.io/2P6A

sudo fdisk -l | eos-sendlog

http://ix.io/2P6B

cat /etc/fstab | eos-sendlog

http://ix.io/2P6C

sudo cat /boot/grub/grub.cfg | eos-sendlog

http://ix.io/2P6D

Although it still has the wrong UUID at least maybe it installed in UEFI with GPT. Maybe now @manuel can make some sense of it. Give them time as they are quite busy also.

Hello @nals I am looking at the logs and it looks correct to me now. The disk is GPT and the partitions are correct. I also looked at the fstab & the command lsblk -fm. It looks like the same UUID to me. I don’t know about the rest of the grub file if there is something not right. Hopefully @manuel will get a chance to look at this or one of the others.

I also just want to make sure you have secure boot disabled in UEFI?

yes is disabled

What is the exact message when you boot up the computer now?

Starting Version 247.31-1-arch
Error: device /'UUID=8c5fbc84-d85d-46a7-8052-5cfebb882d2e' not found. skiping fsck
mount: /new root: cannot find UUID=8c5fbc84-d85d-46a7-8052-5cfebb882d2e.
you are now being dropped to an emergency shell.
sh: can't access tty: job control turned off
(rootfs /#_
1 Like

Are you able to do another arch-chroot into the system and see what this shows?

ls -l /dev/disk/by-uuid

I guess i would like to see if it shows the same UUID or something different.

ls -l /dev/disk/by-uuid

http://ix.io/2P7C

Okay so this confirms it’s the same UUID as far as i can see. :thinking:

This iine (the interesting part of command lsblk -fm):

nvme0n1p2 ext4 1.0 8c5fbc84-d85d-46a7-8052-5cfebb882d2e  884.2G 1% /mnt 953.6G

is strange.

It shows that after install almost 70GB is already used. EndeavourOS takes much less space.

So there is something wrong. I suspect the RST stuff, it looks like not being disabled.

When these laptops are new they have an Intel Rst driver installed and you can remove the driver but i wonder if there is some firmware on these drives that is the issue. In Windows things are different. Turning off Rst in Windows doesn’t affect anything other than removing the Raid status.

I had a thought that maybe we could bypass the uuid by using refind.

sudo pacman -S refind

refind-install

sudo cp /usr/share/endeavouros/EndeavourOS-icon.png /boot/efi/EFI/refind/icons/os_endeavourOS.png

Then reboot. What do you think?

Edit: Also requires going into UEFI and set the boot order to refind.

I don’t know much about RST, but I think using another bootloader might not help.
But doesn’t hurt to try I guess.

I just thought because it boots directly from the image the UUID becomes a non factor?