Cannot boot up after installation

It’s up to you. I mean it’s possible you could get it resolved. I guess it all depends on how bad you want to have Mint installed as a dual boot with EndeavourOS and how much effort you want to put into it. I’m not sure if you have any files on Mint that matter to you? I’d just like to see you get EndeavourOS installed and working.

This line is not correct. You have LTS kernel on the line, but you must use the non-LTS kernel instead (because that is most likely the only kernel you have installed now).

So the line must be:

initrd /boot/intel-ucode.img /boot/initramfs-linux.img

Please fix them on both places.

thank you manuel.

i have done a fresh endevourOS only install, and posted on a newly created thread, as this got too long,

still getting the ‘cannot find UUID’ errors

would appreicate if you would take a look and give me your inputs/instructions

thank you very much

nals

Did you create a new GUID Partition Table (GPT) as it was suggested above as a possible solution or you just reinstalled the system. If the latter please try the former.

https://gparted.org/display-doc.php?name=help-manual#gparted-create-partition-table

Important If you have several drives on your system, make sure to pick up the one you intend to manipulate from the drop-down menu at top right of Gparted’s window.

i used the erase disk option on the installer.

i understand your message to be get into gparted first and set up /boot/efi , /, and swap partitions. is that right ? or do you want me to set up partitions differently.

will try that tomorrow

thank you

nals

No, you just get into Gparted to create a new partiton table (GPT). Then you close Gparted and use the installer to install as you would normally. Let the installer do the partitioning for you, that is no manual partitioning.

1 Like

i am lost. i chose the erase disk and install option, which i take to be “Let the installer do the partitioning for you, that is no manual partitioning.”

if the installer is going to erase the disk and do its own thing, what does it matter what i did prior with gparted ?

i have done a reinstall with the ‘erase disk’ option and posted it as a new thread as this one was getting too long, will see how that evolves

thank you for your inputs

nals

Create a new GPT (GUID Partiton Table).
Please read the Wikipedia article for the difference between Partion Table and partitions.

thank you , will read the wikpiedia article

nals

this is what gparted shows. what do i need to edit/change please

sorry for all these newbie questions.

You don’t really need the flag legacy_boot on your system partition.

I am not sure if this is related to your issue. You could remove it by right clicking on the partition: manage flags and remove the tick on the box. Reboot and see if it resolves the issue.

If not create a new GPT in gparted: Devices: create partition table: GPT.

Close Gparted and launch the installer …

thank you. I too, though i have no clue, do not like the sound of 'legacy_boo’t on this new computer.

will do that tomorrow

thanks again

nals

@nals
Try what @pebcak suggested above to create a new GPT partition with gparted from the live ISO. Then you close gparted and run the installer. As he stated you don’t need to create partitions manually as the installer will do it. The point of using gparted and creating a new GPT partition is that it will remove all installed previously including all partitions and create unallocated space on the drive. Hopefully this clears up the UUID issue.

1 Like

thanks all for your inputs.

i followed @pebcak instructions and created a partition table with gparted first. i then installed with the erase disk selection.

on booting up, i still get the same
error: cannot find UUID xxxxxx" message

i guess the grub file needs some editing ?

nals

1 Like

@nals
Did you go into UEFI Bios and go to advanced (F7) and look under SATA Configuration and make sure that it is set to AHCI. This is the only thing that i can think of because this laptop from my understanding may have Intel RST software raid. If it is set to RST or Raid change to AHCI. It is getting the wrong UUID for a reason and may be hardware related. :thinking:

Edit: https://wiki.archlinux.org/index.php/ASUS_Zenbook_UX333/433/533

2 Likes

i did go to the bios, i did go to advance F7, but i could not find a SATA configuration there, can post a screenshot if that will help.

tks

nals

Look for something like this in advanced mode (F7) It is at the bottom SATA Configuration.

thanks rick.

you are right, it was set to intel RST, i changed it to AHCI and rebooted.

however it still ends up with the same error message of UUID device not found.

guess i am stuck
,

Well it’s not going to boot if the UUID is not correct. I think now at least if it’s set to AHCI you can rule out that causing it to get the wrong UUID. You would most likely have to chroot into the system from the live ISO again and correct the UUID. @manuel is better to go through that with you. I’m not very good at spotting what needs to be changed.

Edit: I don’t think your stuck. You just have to be prepared to work through it.

perhaps this helps to figure out the problem

[root@archiso /]# sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
done
[root@archiso /]#