Cannot boot into live environment

Hello Everybody,
I got a new laptop yesterday: MSI Creator Pro Z17. The first thing I did was download the latest Endeavour OS iso, but I’m having trouble running it. When I boot from the USB stick, I get 3 options: default, Nvidia, and fallback (nomodeset). If I pick either the default or Nvidia options, the screen goes black as soon as I hit the Enter key. If I select the fallback mode, I do see a kernel boot log, but then I end up with an error starting the X server as shown in the attached pic. Things fall apart so early in the process that I’m not sure what to check or what I can do to troubleshoot. Does anyone have any ideas? I appreciate any help I can get.

Thanks,
Dale
PXL_20220618_170200682

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

Hi Elloquin. I appreciate your response. However, I don’t get to the point where there is a working terminal that I can type a command into to display any more info. I don’t actually make it to a live environment. That’s what has me a little surprised and unsure of what to even try.

Read The Wiki…disable secure boot.

That was actually one of the first things I did. This problem occurs when Secure Boot is disabled. The only thing I can think of is this is somehow related to my Nvidia RTX A5500. It is a fairly new card.

And unfortunately, my BIOS does not have an option to disable the Nvidia and test with the Intel graphics only.

Just out of curiosity, do other live environments like Fedora or another Arch based distro boot on that machine.

We’re about to launch a new refresh release very soon and I’m wondering if it is the kernel on the Apollo ISO that makes it not boot.

If secureboot were enabled, it wouldn’t get that far. It wouldn’t even make it to the systemd-boot menu. It would just fail to boot completely.

It is almost definitely an issue with the nvidia graphics in some way since you are getting a black screen.

That is almost always GPU related in some way.

However, according to nvidia, your gpu should be supported by the drivers shipped with Apollo

1 Like

It’s a brand-new machine, could it be TPM preventing it to boot?

Hi Bryanpwo. Funny you should ask that and thank you for your reply. I actually tried a few other distros including Fedora 36 Cinnamon which had the same issue as well. Next, I tried the latest (20.3) Linux Mint and was able to actually install that without any special tricks. However, after upgrading the kernel in Linux Mint from (I think 5.4) to 5.15.0-33, I would have to use the nomodeset kernel parameter or I would get no display. I gave up on that as I need a newer kernel to recognize my wifi module, so I tried the latest (22.06.01) vanilla arch. I could get that to boot using nomodeset, but trying to install vanilla Arch is not a road I was excited to go down. This problem manifests with different distros, but if I could get it to work with Endeavour, that would be my preference.

Thanks,
Dale

1 Like

Read your manual…you linked it in your op.

@dalto
Just thinking out loud here the Apollo release doesn’t ship with the recent nvidia driver update, the update that was corrected upstream due to black screens on running systems, remember? (Two weeks ago, or something)

I’ll try resetting the TPM and see what happens.

Unfortunately, no difference after resetting the TPM.

I am not an nvidia expert but I think that started with 515. The ISO ships 510.60.02.

However, that probably is the issue that caused their Mint update problem.

@dalekuhn
Have you tried ibt=off as a kernel parameter to boot on the live ISO?

1 Like

Yeah, but there was a big issue affecting Nvidia with the recent Intel chips. That issue was resolved very recently.

The workaround for that is what @ricklinux posted above so if that works we will know for sure.

1 Like

Okay then I will shut up for now. :wink:

Thank you for your help Ricklinux. Just to make sure I’m doing this right, I selected one of the three boot options, press ‘e’ and add ‘ibt=off’ without quotes to the end of the string. The behavior for all 3 options is unchanged: default and Nvidia both just go to a black screen, and the fallback shows a kernel boot log followed by the error shown in the original post when trying to start the X server.