Btrfs Assistant 1.0 is coming, testers needed

Yes. That would basically destroy everything and start over.

The “change the mountpoint” version does not work:

sudo mount /Virtual
mount: /Virtual: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.

fstab:

cat /etc/fstab |grep irtual
UUID=178ba18b-3faa-4b38-b7e5-5b0f5d2f285c /Virtual       btrfs   subvol=/@virtual,defaults,noatime,compress=zstd 0 0

And although /virtual is unmounted I cannot rename it…

The mountpoint needs to exist. I thought you were already using it so I didn’t add that point.

You can just create it:

sudo mkdir /Virtual

A, okay, I thought I can rename the /virtual… Creating /Virtual and deleting /virtual did the trick. Man you are the best…

1 Like

One last question before I create the mirror: My current drive 1 has two partitions on it, 1000MB FAT32 for Grub, the Rest as BtrFS for EndevourOS. When I now remove the ext4 partitions on drive 2 will I create one BtrFS partition for the whole drive two? Or do I duplicate the whole partition scheme? I could then backup the grub partition regularly, and if drive1 fails, write this backup to grub partition on drive 2 and boot the machine up - at least in theory…

So, I just removed everything from device two and then just added it via:

sudo btrfs device add /dev/nvme1n1 /
sudo btrfs balance start -dconvert=raid1 -mconvert=raid1 /

And it worked… somehow?

lsblk -f
NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                                    [SWAP]
nvme0n1                                                                                  
├─nvme0n1p1 vfat   FAT32             BDEB-C54C                             997,5M     0% /boot/efi
└─nvme0n1p2 btrfs        endeavouros 178ba18b-3faa-4b38-b7e5-5b0f5d2f285c    1,5T    17% /var/log
                                                                                         /var/cache
                                                                                         /home
                                                                                         /Virtual
                                                                                         /
nvme1n1     btrfs        endeavouros 178ba18b-3faa-4b38-b7e5-5b0f5d2f285c                

Am I good?

Yeah, it is really easy.

You can verify and see more detail with:

sudo btrfs filesystem usage /

Well, I have this issue, which started right when I created the Raid1 (did the balance). Could be a seperate issue, most probably is, but nevertheless, it started when I had the raid up and running. So my question is: How to “unraid”?

You can remove a device just as easily as adding one, see here:

https://wiki.tnonline.net/w/Btrfs/Adding_and_removing_devices

Use btrfs device remove <device-or-devid> <mountpoint> to remove a device.

Be aware of the following limitations:

Limitations when removing devices

  • All of the data must fit on the remaining devices.
  • It is not possible to go below the minimum number of devices given the data or metadata profile used. For example on a 3 device RAID1 filesystem it is possible to remove 1 device but not 2.

See more about the limitations of different profiles on the Btrfs/Profiles page.

This is from the linked profiles page:

On a single disk filesystem the default is SINGLE profile for data and DUP for metadata chunks.

Prior to removing the device, you will have to convert the filesystem back to these defaults (because a single device cannot be RAID1).

sudo btrfs balance start -dconvert=single -mconvert=dup /

Then remove the device.

sudo btrfs device remove /dev/nvme1n1 /
1 Like

Worked like a charm. Aaaaand as expected, did not solve my problem…