Brother printer

problem with drivers for brother MFC-J497DW printer. This printer is not in the list. Is there a way to get this printer added with scanning?

yay -S brother-mfc-j497dw

1 Like

CUPS server error
There was an error during the cups operation: 'client-error-not-possible. I ran the install you posted and the printer model showed up, but I get this error when attempting to apply.

hello @kr34tor,
welcome to the purple universe :enos: :enos_flag: :rocketa_purple: :penguin_face:

what shows the following command

systemctl status cups.service

1 Like

kr34tor@AOL ~]$ systemctl status cups.service
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; disabled; preset: disabled)
Active: active (running) since Sat 2023-07-15 02:46:22 MST; 11h ago
TriggeredBy: ● cups.socket
Docs: man:cupsd(8)
Main PID: 17752 (cupsd)
Status: “Scheduler is running…”
Tasks: 5 (limit: 9399)
Memory: 110.2M
CPU: 1min 35.527s
CGroup: /system.slice/cups.service
├─17752 /usr/bin/cupsd -l
├─17755 /usr/lib/cups/notifier/dbus dbus://
├─17756 /usr/lib/cups/notifier/dbus dbus://
└─17768 /usr/lib/cups/notifier/dbus dbus://

Jul 15 02:46:21 AOL systemd[1]: Starting CUPS Scheduler…
Jul 15 02:46:22 AOL systemd[1]: Started CUPS Scheduler.
[kr34tor@AOL ~]$

I was able to add the printer directly through CUPS but it wont print. Says the job is complete, but nothing printed. I feel like I have something wrong in the printer settings. It is a wireless printer.

If it’s a wireless printer you need to set the settings for avahi and enable.

https://discovery.endeavouros.com/printers/printers/2021/03/

3 Likes

Thanks, I followed that link a couple days ago:
[kr34tor@AOL ~]$ systemctl status avahi-daemon
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; preset: disabled)
Active: active (running) since Sat 2023-07-15 00:54:15 MST; 14h ago
TriggeredBy: ● avahi-daemon.socket
Main PID: 507 (avahi-daemon)
Status: “avahi-daemon 0.8 starting up.”
Tasks: 2 (limit: 9399)
Memory: 1.6M
CPU: 2.895s
CGroup: /system.slice/avahi-daemon.service
├─507 “avahi-daemon: running [AOL.local]”
└─525 “avahi-daemon: chroot helper”

Jul 15 00:54:15 AOL avahi-daemon[507]: Registering new address record for ::1 on lo..
Jul 15 00:54:15 AOL avahi-daemon[507]: Registering new address record for 127.0.0.1 on lo.IPv4.
Jul 15 00:54:15 AOL systemd[1]: Started Avahi mDNS/DNS-SD Stack.
Jul 15 00:54:16 AOL avahi-daemon[507]: Server startup complete. Host name is AOL.local. Local service cookie is 31>
Jul 15 00:54:38 AOL avahi-daemon[507]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.5>
Jul 15 00:54:38 AOL avahi-daemon[507]: New relevant interface wlan0.IPv4 for mDNS.
Jul 15 00:54:38 AOL avahi-daemon[507]: Registering new address record for 192.168.5.21 on wlan0.IPv4.
Jul 15 00:54:38 AOL avahi-daemon[507]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::3f6>
Jul 15 00:54:38 AOL avahi-daemon[507]: New relevant interface wlan0.IPv6 for mDNS.
Jul 15 00:54:38 AOL avahi-daemon[507]: Registering new address record for fe80::3f67:2a9c:6683:7b22 on wlan0.
.
lines 1-23/23 (END)

1 Like

To help troubleshoot, do the following

sudo systemctl stop firewalld

See if it works with the firewall disabled. If it works, do the following.

Open up the firewall app by right clicking on the firewall icon, then ‘Edit firewall settings’
First thing is to set the rules to ‘Permanent’. It usually ‘Runtime’ by default.

image

Then select the ‘upnp-client’ under the Services Tab.

Next, click on ‘Options’ in the top panel, and click ‘Reload Firewalld’

Reboot the computer and check.

Pudge

1 Like

Did you set avahi?

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return]

yes, I also edited that file

hosts: mdns_minimal mymachines mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] files myhostname dns
networks: files

1 Like

Thank you Pudge. I just tried your suggestion, but it doesn’t physically print either way.

1 Like

How do you test printing?

After you test printing, get journal logs from the relevant time period, and other print-related messages.

@kr34tor
Did you select the printer using cups using localhost:631

EDit: You may not have selected the proper protocol such as ipp

1 Like

Good Point @ricklinux .

@kr34tor go to your printer, and using the LCD Display, set a static IP address in the printer.
As ricklinux pointed out. When setting up the printer, choose IPP

cups-server

In the next window, in the connection field, enter

ipp://192.168.0.178          ## adjust for your Static IP address you set in the printer.

Next window. FIll in the printer name, etc.

Next window. Click on Brother

Next window, click on

IPP Everywhere

ipp everywhere

Reboot and try with these settings.

Pudge

@kr34tor

I forgot you said this is a wireless printer. Since the printer is not on an ethernet connection, have you looked at this URL.

Pudge

petsam, to test I just tried to print a document. In CUPS print jobs show that it completed, but it never did anything.

ricklinux, yes I added the printer fro localhost:631 after trying to add from the printer settings gui and getting the CUPSD error from above. After installing the drivers there was a message to add the printer using lpd and host, so Im wondering if ipp is how I should be adding it like pudge mentions below. I am using it wireless which the message after driver install recommended, the lpd and host option; lpd://ipaddress/queue was the reccomendation.

Try this in terminal.

sudo rm -f /var/spool/cups/c*

Reboot or restart cups

This command removes the header files that are left over in the CUPS system. These files will remain if the job is aborted or otherwise didn’t print.

The header files of aborted print jobs collects in /var/spool/cups. If too many files collect there, then jobs will not be received by CUPS. You can check the log /var/log/cups/error_log file if “too many jobs” is listed as a reason for failure

I have a wireless Brother laser printer (not the same modell) and this helped me get it to work.

1 Like

I’m not 100% sure. I still consider a wireless printer to be on a network. I have brother printer but i use usb and it’s pretty simple.

Thanks boxer, I ran the command and comprehend your explanation. I checked the log file in /var and there are all kind of stuff that I dont know what to make of. still no printing and scanner is not found. when the printer was added CUPS gave a message that the drivers were depreciated and soon not be supported…

ricklinux, yes it is on my network and has a static ip set up in my router. I also have linux mint running on another drive and had lost the entire configuration and had to re-add there as well but it seems to work there. Ive never had this much trouble with a printer in linux.

New Brother wireless printers all can run driverless with cups, you do not even need to add the printer manually … if you enable cups-browsed service…
But you have to make sure local hostname resolution is working and the firewall let the protocols pathing…

ipp
ipp-client
mdns

these needs to be enabled…

look here:

2 Likes