Brother DCP-J105 drivers

Hi, guys!
In order to install my printer drivers in Linux I use to go to the Brother website and choose the .rpm or .deb package and follow the instructions using the command line, but I’m not quite sure which one to pick nor how to install them in EndeavourOS since this is my first time using an Arch-based distro.
Could you please give me a hand on this?


EDIT: I’ve just followed this guide for installing a .deb package. So, after installing the driver using yay, I’m not able to print since I’m stuck on “Getting printer information…”:

The drivers are in aur:

paru brother-dcpj105   --nouseask --sortby name
1 aur/brother-dcpj105 3.0.0-668 [+1 ~0.00]
    CUPS driver for Brother DCP-J105 printer
:: Packages to install (eg: 1 2 3, 1-3):

Just yay -S brother-dcpj105 will do it.

I did that, but now I’m stuck on “Getting printer information…” as you can see on the picture above.

Oops, sorry, was distracted, missed the edit :blush:

Looks like your printer is not talking to computer.
If you haven’t already done this:
$ pacman -Q | grep cups (to verify cups and cups.pdf are installed)
$ sudo systemctl enable cups.service
$ sudo systemctl start cups.service

Now go to your favorite browser and enter in the URL line

To see if communications with the cups server are OK.


If you get this screen, you can install the printer in the browser, or go back and try the GUI you were using.


1 Like

Thanks, Pudge!

[alejandro@alex-linux ~]$ pacman -Q | grep cups
cups 1:2.4.0-4
cups-filters 1.28.10-2
lib32-libcups 2.4.0-1
libcups 1:2.4.0-4
[alejandro@alex-linux ~]$ sudo systemctl enable cups.service
[sudo] password for alejandro: 
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.service.
Unit /usr/lib/systemd/system/cups.service is added as a dependency to a non-existent unit
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.socket.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/cups.path.
[alejandro@alex-linux ~]$ sudo systemctl start cups.service
[alejandro@alex-linux ~]$ 

I can see that printing page by typing localhost:631, however, if I press Ctrl+P, the popup window only shows an option to SAVE the printing as PDF. I have a wireless printer, though.
Is there a way to print a test page? I don’t see any printer application to do that.

If it was me i would remove the printer you have installed. Then install it from the AUR and see how that works.

yay -S brother-dpcj105

If the only option is to SAVE the document or image as PDF, then your printer is not properly installed.

At the above image, Click on “Administration” then “Manage Printers”
Should show a summary of your printer if it is properly installed. Click on Printer name.
Click on “Maintenance” should see “Print test page”.


If you don’t see your printer name listed as in the above image, then your printer is not installed.

I have never installed a Brother Printer to work on WiFi.
First I believe that you will have to prepare your wireless router to connect to the printer.

Then, at the printer, on my Brother printer there is a little white “WiFi” button. I pressed it and on the little LCD screen on the printer it brought up
“Setup WiFi? yes or no”
I pressed yes and it brought up
“Connecting WLAN” then it searched for a WiFi connection. Finally it timed out and said
“No Access Point”
So since I have not prepared the WiFi router, the printer was not able to connect to WiFi.

If there is any way possible to hook a LAN cable (ethernet) from the router to the printer I would try to get that working first. Then when you know the printer is working, see about setting up WiFi for it.
I wish I Could help you more on the WiFI part.


One last question. How is the computer you are trying to print from connected to the router or switch. Etherner or WiFi

I have been thinking about this. Maybe it is possible to go from the WiFi on your computer directly to the WiFi on the printer without anything in between? I don’t know as I don’t use WiFi.


1 Like

I had never been any WIFI printer problems with distros like Ubuntu, OpenSUSE or any other operating system before, in fact, this is the first time that I’m having one… and using an Arch-based distro. So, due to all I’ve read from you guys, I can’t believe there’s no solution to this issue with WIFI Brother printers. This Endeavour OS looks awesome and I like it very much, so far… however, not being able to print or scan anything is something that can make a big difference among other systems.

Have you looked at the post above?

OK, as far as I understand, I have to install that nss-mdns package and start avahi-daemon.service… then, edit the file /etc/nssw…But what file is that? I can only find a nsswitch.conf file. Is that? Sorry but I’m a newbie in Linux.

Edit: It’s in


OK, I edited that file adding those lines. What’s next?


[alejandro@alex-linux ~]$ avahi-browse --all --ignore-local --resolve --terminate
+ enp4s0 IPv4 Brother DCP-J105                              PDL Printer          local
+ enp4s0 IPv4 Brother DCP-J105                              UNIX Printer         local
+ enp4s0 IPv4 Brother DCP-J105                              Internet Printer     local
= enp4s0 IPv4 Brother DCP-J105                              PDL Printer          local
   hostname = [BRW142D272FCD3A.local]
   address = []
   port = [9100]
   txt = ["UUID=e3248000-80ce-11db-8000-142d272fcd3a" "TBCP=T" "Transparent=F" "Binary=T" "PaperCustom=T" "Scan=T" "Fax=F" "Duplex=F" "Copies=F" "Color=T" "usb_CMD=HBP,BRPJL,URF" "usb_MDL=DCP-J105" "usb_MFG=Brother" "priority=75" "adminurl=http://BRW142D272FCD3A.local./net/net/airprint.html" "product=(Brother DCP-J105)" "ty=Brother DCP-J105" "note=" "pdl=application/octet-stream,application/,image/urf,image/jpeg" "qtotal=1" "txtvers=1"]
= enp4s0 IPv4 Brother DCP-J105                              UNIX Printer         local
   hostname = [BRW142D272FCD3A.local]
   address = []
   port = [515]
   txt = ["UUID=e3248000-80ce-11db-8000-142d272fcd3a" "TBCP=F" "Transparent=T" "Binary=T" "PaperCustom=T" "Scan=T" "Fax=F" "Duplex=F" "Copies=F" "Color=T" "usb_CMD=HBP,BRPJL,URF" "usb_MDL=DCP-J105" "usb_MFG=Brother" "priority=50" "adminurl=http://BRW142D272FCD3A.local./net/net/airprint.html" "product=(Brother DCP-J105)" "ty=Brother DCP-J105" "note=" "rp=duerqxesz5090" "pdl=application/octet-stream,application/,image/urf,image/jpeg" "qtotal=1" "txtvers=1"]
= enp4s0 IPv4 Brother DCP-J105                              Internet Printer     local
   hostname = [BRW142D272FCD3A.local]
   address = []
   port = [631]
   txt = ["UUID=e3248000-80ce-11db-8000-142d272fcd3a" "URF=SRGB24,W8,CP1,IS1,MT1-8-11,OB9,PQ4-5,RS300,OFU0,V1.2" "TBCP=F" "Transparent=T" "Binary=T" "PaperCustom=T" "Scan=T" "Fax=F" "Duplex=F" "Copies=F" "Color=T" "usb_CMD=HBP,BRPJL,URF" "usb_MDL=DCP-J105" "usb_MFG=Brother" "priority=25" "adminurl=http://BRW142D272FCD3A.local./net/net/airprint.html" "product=(Brother DCP-J105)" "ty=Brother DCP-J105" "note=" "rp=ipp/print" "pdl=application/octet-stream,application/,image/urf,image/jpeg" "qtotal=1" "txtvers=1"]
+ enp4s0 IPv4 Brother DCP-J105                              _scanner._tcp        local
+ enp4s0 IPv4 Brother DCP-J105                              Web Site             local
= enp4s0 IPv4 Brother DCP-J105                              _scanner._tcp        local
   hostname = [BRW142D272FCD3A.local]
   address = []
   port = [54921]
   txt = ["flatbed=T" "feeder=F" "button=T" "mdl=DCP-J105" "mfg=Brother" "ty=Brother DCP-J105" "adminurl=telnet://BRW142D272FCD3A.local./" "note=" "txtvers=1"]
= enp4s0 IPv4 Brother DCP-J105                              Web Site             local
   hostname = [BRW142D272FCD3A.local]
   address = []
   port = [80]
   txt = []

You have to install

yay -S nss-mdns

Then start and enable the service

systemctl enable avahi-daemon.service
systemctl start avahi-daemon.service

Edit the above file in /etc/nsswitch.conf

hosts: mymachines mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] files myhostname dns

I think you have to substitute myhostname for yours. I’m not sure on mymachines? Whether that means the computer name?

Edit: Try it with just the hostname and see.


myhostname is alejandro && mymachines is alex-linux?

Not according to the printer output?

 hostname = [BRW142D272FCD3A.local]

Edit: I’m not sure.

Maybe you don’t need to change those just mdns_minimal [NOTFOUND=return] :man_shrugging:

Edit: You may also be able to add it using localhost:631 using manage printers and select a network printer since you have the ip address listed above.

It’s all right here in case you want to look it over.

Edit: Looks like you do need to substitute the host name.

Avahi provides local hostname resolution using a “*hostname*.local” naming scheme.

Edit2: I’m not sure if it automatically picks up the host name. :thinking:

Well you get any success with the info?
Edit: I have a Brother printer but is not wireless.