Brother mfc j430w wifi online not working

Does it need ipp://192.168.001/100?

Edit: The driver it lists first shows BrotherMFC-J430W-IPP Everywhere

for wifi printer it seems that it needs to wake up the printserver on the printer what needs to call it by socket ip and printserver port

socket://182.168.178.90:9100

as example

I did try but on the next page it give me this error

I think you have a typo there.

ipp://192.168.0.170 is all I have ever used. The 192.168.0.170 is the IP address of the printer.

Try entering your printer’s IP address in the URL line of a web browser. Should get something like this:

You should be able to talk to the printer. If you don’t get something like this then your network is not working properly. If you can’t access the printer, then I would suspect a firewall problem or something in the wireless modem is not set correctly.

Pudge

The OP say’s that is what his printer IP is and i already doubted that it is correct. Cups won’t see it if it’s not right.

Edit: That info is supposedly coming from the printer panel?

It doesn’t matter if the IP is the correct one if the network is not allowing the computer to talk to the printer as in post # 58. If there is a network problem, until that problem is solved it will not work. The next step is to see if @batmanxx can talk to the printer from a browser on his computer.

Well, me and the wife are off to get something to eat. Be back later.

Pudge

1 Like

IPP never worked here for wireless brother printer, i have used socket and cups driver on 3 different models wifi connected as the only working setup …

Talking about network issue it could be also a very common arch issue with hostname resolution:

Avahi provides local hostname resolution using a “hostname.local” naming scheme. To enable it, install the nss-mdns package and start avahi-daemon.service.

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns:

hosts: ... mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns ...

1 Like

ha ha just tested again with IPP driverless and it is also working here now :roll_eyes: :vulcan_salute:

But only after changing hostname resolution as from Archwiki… after adding
mdns_minimal [NOTFOUND=return] into host: line before resolve …
and restart avahi-daemon.service this needs no driver here also being installed…

1 Like

It seems this comes up every time you try a Brother printer in Arch. I was just about to post this solution yet again; it seems this line is essential in Arch based distros for some reason.

2 Likes

what ever I do it always seems to be a problem with cups what ever I choose it gives an error cups

Everbody thank you so much till now I will here from you tomorrow if finally will can resolve this issue

1 Like

added some more details here under Troubleshooting. :wink:

1 Like

Do not give up! printers can be a bit troublesome on initial setup, but if they run trouble is gone.
And brother printers are running well under Linux normally.

joekamprad Thanks !!! but are the correct commands line to install cups? I don’t have a great experience with linux. Everytime I tried: sudo systemctl enable org.cups.cupsd.service, to enable cups message saying cups does not exist !!! why ???

You should be using that to start cups, not

I had asked above why you keep using this command as it is incorrect. The proper commands are:

After you can check status of cups with.

systemctl status cups.service

@Batmanxx
Did you happen to get any further with the printer? Did you look at the wiki as it has been updated for printing. You may need to look at the section regarding installing and configuring avahi. Look at that and the troubleshooting below.

1 Like

Indeed, Absolutely necessary for my Brother MFC-9970CDW to work. Thank you

1 Like

Troubleshooting: Network printer not reachable:

It is a common issue that you can not get wifi printers to print, especially some Brother wifi printers.

It can be required to enable local hostname resolution for avahi to be able to connect to your network printer: