Brother mfc j430w wifi online not working

Schermata da 2021-06-22 19-03-35

Schermata da 2021-06-22 19-01-19

Schermata da 2021-06-22 19-00-55
Good evening I have this printer in wifi mode but everytime I load up the drivers for this printer and everything seems ok this message shows up: error del server cups as you can see I also downloaded the printer from the localhost 631 even if in libreoffice you see the printer showing it will not print anything at all please any help.

Did you look at the wiki and make sure cups is installed and enabled?

I did but everytime I tried to find that cups was installed it always tells me it doesn’t exist it there I way to check if put in the correct command line for cups? thank you

What does systemctl status cups.service show?

Edit: Post the output of

systemctl status cups.service

Schermata da 2021-06-22 20-02-52
This is what came out

Cups is running but if you are using a wireless printer it needs an IP address to so I’m not sure how you are trying to set it up.

I did here is my ip address but I just tried again and it gave me the same problem with cups please see image
Schermata da 2021-06-22 20-10-21
Schermata da 2021-06-22 20-09-54

How did you come up with that ip address?

It the same ip that comes out from my printer it has always worked even in the past when I tried with other distros from arch but the problems seems to be with cups correct ?

Verify the IP of the printer. Try disabling DHCP (if enabled) and set the IP as static.

You can install and use nmap to verify the printer ip. Here is a little video that shows how to install the printer with correct ip.

it is correct the ip address is subnet mask and gateway is I cant find no DHCP
i just included a image of printer it always gives me the problem with cups thank you

That’s a nice printer. Not sure what the cups issue is. Usually brother printers are one of the easiest to get working on Linux. I have one myself but it is connected to usb so it is easier.

I was watching the video when I copied the second command of line sudo systemctl enable org.cups.cupsd.service the message show up in the system saying cups not exist please see image
Schermata da 2021-06-22 20-32-13

Why is it saying cups does not exist ???

sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.service
systemctl status cups.service

Did you install cups via this command from the wiki?

sudo pacman -S cups cups-filters cups-pdf system-config-printer --needed

yes do you want me to install again ?

Did you also install?

sudo pacman -S ghostscript gsfonts foomatic-db-engine foomatic-db foomatic-db-ppds foomatic-db-nonfree foomatic-db-nonfree-ppds gutenprint foomatic-db-gutenprint-ppds --needed

yes i did
Schermata da 2021-06-22 20-42-09
Schermata da 2021-06-22 20-47-11
would like me to try again sudo systemctl enable org.cups.cupsd.service to see now if it works ?