Booting reached target Graphical Interface then continue blinking

When booting, it will reach “reached target Graphical Interface” then the screen will blink again, displaying the same result. I am unable to enter CTR+ALT+F2, it opens it for less than a second, then it blinks rendering the same target reached. This happens shortly after an upgrade, though don’t remember if it immediately from the first reboot. The laptop has an NVIDIA GPU. The previous related articles with the same issues don’t account for the unavailability of the terminal.

Hi there, welcome to the forum. There is already another thread with this subject open.

Please go to:

Hello, thanks for the reference, since you can’t access the terminal by CTR+ALT+F2, how did you run these commands in your post?

  1. I downloaded the ISO and created a bootable drive using Rufus.
  2. Then, at the Setup (usually F2) I disabled my “Secure Boot” (because I have a Dell System, otherwise it goes directly to BitLocker Recovery)
  3. Reboot, then F12 (Boot Menu), and selected the newly created USB drive
  4. Wait for it to start, then connect to my Wi-Fi
  5. I opened a terminal by pressing “Ctrl + Alt + T”
  6. Once inside, I executed the following lines:
    This first will show your drive distribution, you’re looking for the one with FSVER LABEL (Top title) as FAT32 ESP and the one as “ext4” which is your usual Linux system

sudo lsblk -f
sudo mount /dev/[your ext4 drive name] /mnt
sudo mount /dev/[your FAT32 ESP drive name] /mnt/boot/efi
sudo arch-chroot /mnt

After this you should be in your drive, also please refer to this post in case you need more help:

Once you’re in, the following will show you your user name by running:

ls /home

Once you’ve verified you’re logged in correctly, you can try running:

pacman -Qs nvidia

This will show you all the local packages installed in your system that start with “nvidia” such as: nvidia-dkms, nvidia-hook, nvidia-installer-common, nvidia-inst

You can remove each one by running:

pacman -R [package name]


pacman -R nvidia-inst

After you remove all NVidia dependencies, reboot, then go back to step 3 and chroot again to freshly install the “nvidia-inst” package, which automatically will detect your graphics card and install the correct driver.

Refer to this post for more:

I didn’t work for me but hopefully, you’ll be more lucky.

1 Like

Thanks for the detailed instructions, unfortunately, it didn’t work.

It would be best to first post your hardware output. You can do that form booting on the live ISO as lona s you have internet.

inxi -Faz | eos-sendlog

I’m daily spending time to research and look into it as it appears nobody else is stepping in, so hang in there and I’ll keep you posted, hopefully we can get it going soon!

Had the exact issue as descried by OP and this fixed it. I didn’t boot into the live iso the second time tho. I boot directly into the main OS and installed nvidia-inst and ran it which worked and fixed it as well. So thank you for your reply.

Here is how you mount your drive if you choose to encrypt it in case anyone stumbles over this post as well:

lsblk -f
sudo cryptsetup luksOpen /dev/nvme0n1p2 luks
sudo mount /dev/mapper/luks /mnt
arch-chroot /mnt

Thanks! I’ll give it a try later this afternoon.

Apologies for my late reply, the above command have outputted:
Kernel: 6.4.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
parameters: initrd=\arch\boot\intel-ucode.img
initrd=\arch\boot\x86_64\initramfs-linux.img archisobasedir=arch
archisolabel=EOS_202308 cow_spacesize=10G copytoram=n
nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes
Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
v: 4.18.0 vt: 1 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
Type: Laptop System: Acer product: Nitro AN515-54 v: V1.05
Mobo: CFL model: Octavia_CFS v: V1.05 serial:
UEFI: Insyde v: 1.05 date: 05/31/2019
ID-1: BAT1 charge: 4.6 Wh (10.1%) condition: 45.5/57.5 Wh (79.1%)
volts: 15.8 min: 15.4 model: LG PABAS0241231 type: Li-ion serial:
status: charging
Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF2
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1552 high: 2600 min/max: 800/4500 scaling:
driver: intel_pstate governor: powersave cores: 1: 2600 2: 2600 3: 2600
4: 800 5: 800 6: 800 7: 2600 8: 2600 9: 834 10: 800 11: 800 12: 800
bogomips: 62431
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Acer Incorporated ALI driver: nouveau v: kernel
alternate: nvidia_drm,nvidia non-free: 535.xx+
status: current (as of 2023-07) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1f91
class-ID: 0300 temp: 29.0 C
Device-3: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a060
class-ID: 0e02 serial:
Display: server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
loaded: modesetting alternate: fbdev,intel,nouveau,nv,vesa dri: iris,nouveau
gpu: i915 display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x21ed built: 2016 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
API: ALSA v: k6.4.8-arch1-1 status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
modules: wl bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlan0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 06:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp6s0 state: down mac:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4
chip-ID: 8087:0aaa class-ID: e001
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 1.02 TiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-21Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 1A02 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Sony model: Storage size: 111.79 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: fw-rev: 2210 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: N/A size: 10 GiB used: 49.4 MiB (0.5%) fs: overlay
source: ERR-102
Alert: No swap data was found.
System Temperatures: cpu: 40.0 C pch: 47.0 C mobo: N/A gpu: nouveau
temp: 30.0 C
Fan Speeds (RPM): N/A
Processes: 280 Uptime: 4m wakeups: 3 Memory: total: 16 GiB
available: 15.47 GiB used: 1.75 GiB (11.3%) Init: systemd v: 254
default: multi-user tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 900 libs: 220 tools: yay Shell: Bash v: 5.1.16
running-in: xfce4-terminal inxi: 3.3.28

Is your system still not working since 10 days? Are you able to get into a tty and run and update?

Unfortunately yes. I was able to chroot and update and upgrade the system.

From what I observed, during the boot, it shows [FAIL] in VMWARE-NETWORK, so I removed it from chroot. Also, when the screen is blinking, I can see every label is fine except one service [docker network something] so I deleted docker, and now it does blink in an empty screen with one dash (-) that refreshes every several seconds.

Is this happening in arch-chroot or you mean after you updated it then booted normally?

Edit: How can you get along not using it for 10 days?

The deleting part? Chroot.

Power testing my limits, and I am about to break.

Not sure i understand you. Is the blinking screen happening when you boot up normally on the computer? Are you able to get into a tty from there? I notice it is running on Intel graphics and you also have nvidia. It has noveau open source drivers installed for the nvidia. Did you ever install the nvidia drivers?

Yes, the blinking screen occurs when I boot into endouveros as my main OS. I can’t access the terminal from there since CTR+ALT+F2 will appear only for seconds before refreshing the frame and presenting the black screen again.

I did have them before the upgrade, but when the problem occurred, I deleted them following suggestions on the forms, but it didn’t work, so I installed them after I removed docker, thinking that the black screen appeared because I didn’t have Nvidia drivers anymore.

This image might be helpful, this is the current list of Nvidia packages that I installed

EDIT: I access arch-chroot from live ISO usb

EDIT 2: I tried to run without them, except one due to long trail dependence on it, I think it’s libvdpau

It doesn’t show nvidia as installed in the hardware info you posted. If you arch-chroot you could try the folowing.

This is to revert to nouveau first just to see if it does anything. Look at the output.

nvidia-inst -n

Then reboot into the system. If you still have the issue then arch-chroot again and reinstall nvidia


Then lets see if any different.

I can’t run nvidia-inst -n since I am running chroot with root privileges

I’m not sure on that. :thinking: So you can’t boot on the system and get into a tty f2 f3 f7 etc?

I think I only can do that if I CTR+ALT+F2, which in my case, I can’t :frowning: