Stuck on "Reached target Graphical Interface" after system update

I did a system update and now I can’t even boot on my system. My issue is not only that, but that it keeps refreshing every second, so I can’t access the tty. Yes, I have tried Ctrl + Alt + F2 (which is the one that works on my computer) but I can only see that for a split second, then the screen refreshes again.

I already did arch-chroot and reinstalled the Nvidia drivers (Quadro P620 is my graphics card) without any success either.

I’ve tried everything else I read on this forum regarding this same issue without any success. Any help is appreciated.

Have you tried waiting beyond the 90 second systemd grace time?

Sometimes after this time the error that blocks the system appears.

I haven’t, thanks for the recommendation. I’m gonna give that a try now.

Did try for 2 minutes without success

Can we get these logs, please?

journalctl -b -0 | eos-sendlog
inxi -Ga | eos-sendlog

Paste the links here.

I ran the first one and nothing came up.

The second one ran

inxi -G

I assume you’re running KDE. Can you run the below command and show the output as well, please?

systemctl status kdm.service

That is correct, I’m running KDE. I ran the command per your instructions but came back as:

“Running in chroot, ignoring command ‘status’”

It’s the only way I can access my system now, via the Live drive and arch-chroot

Can’t you use the tty by pressing Ctrl+Alt+F3? I think this error stops you from seeing the GUI but you can access the tty/terminal.

No, like I stated at the beginning of my post, the screen refreshes and I’m only able to see the tty for a fraction of a second.

I just saw that your system is a hybrid. And you have nouveau as the driver for Nvidia which might cause similar issues.

Try this.

  • Reboot.
  • When you come to grub press E.
  • Add this modprobe.blacklist=nouveau to th end.
  • Now continue.
  • You should get to the GUI.
  • Once there remove the nouveau drivers. Run sudo pacman -Rc xf86-video-nouveau.
  • Now reboot.

Now install Nvidia drivers. You can use this.

Go to go thunder and rain coming in.

Hello there, thanks for your support. However I’m still stuck, dunno if I’m doing something wrong but didn’t work.

Tried running the code you sent from arch-chroot with error: target not found: xf86-video-nougeau

Seems this is another error.

Can these be merged?

Some time ago it happened to me, I had to reinstall nvidia drivers (in my case yay -S nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings having a 660ti) and then I ran sudo dracut-rebuild

EDIT:
Didn’t notice that you can’t access terminal…

It might be possible, I contacted the user to refer to this post instead.

I attempted that yesterday from chroot, I ran

pacman -Qs nvidia

then deleted all nvidia stuff such as nvidia-dkms, nvidia-hook, nvidia-inst, nvidia-installer-common by running:

pacman -R [package]

then rebooted and did a fresh install of “nvidia-inst” without any success, so back to square one

Hi, did you ever get this fixed? Saw your post in the other thread but that solution to this error didn’t work for me.

Hi! Yes I got it solved. The issue I had was that my computer is Hybrid running Intel and NVidia, and I also had Optimus-Manager installed which was the root of all issues for me.

Use a Live ISO, then arch-chroot and run these commands:

pacman -R optimus-manager-q
pacman -R optimus-manager

Rebooted and voila!

Hopefully it works for you as well.

1 Like