Bluetooth not working. "No default controller available"

I followed the wiki page to enable and setup bluetooth. But after running bluetoothctl, this happens:

$ bluetoothctl
Agent registered
[bluetooth]# scan on
No default controller available

Bluetooth related commands:

System info and logs as found here:

There is no bluetooth driver installed.
Try the lts kernel and if that doesn’t work then there are some possible solutions in this thread:

Try the most simple one first:

cat /etc/modprobe.d/rtl8821ce.conf 
options rtl8821ce msi=1

There i a thread on this forum discussing the same issue see What kernel and driver to choose for Wifi realtek rtl8821ce?

1 Like

Thanks! I tried the LTS kernel (without success) then I tried all the options suggested in both threads, using both the LTS kernel and the latest:

  • installed driver from the AUR here
  • created /etc/modprobe.d/rtl8821ce.conf with inside options rtl8821ce msi=1 and blacklist rtw88_8821ce
  • these kernel parameters

But every single time I still get the original error message:

$ bluetoothctl
Agent registered
[bluetooth]# scan on
No default controller available

Anyway I saw someone posted the output of lspci -k so maybe it’s useful, here it is:

$ lspci -k -s 03:00.0
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
	DeviceName: WLAN
	Subsystem: Hewlett-Packard Company Device 831a
	Kernel driver in use: rtl8821ce
	Kernel modules: rtw88_8821ce, 8821ce

Now I know the issue is not the laptop itself, I’ve tried bluetooth on Windows 10 and it works.

What else can I do to tackle this problem? I feel like I’ve tried everything but I’m sure a lot of you here know way better than me :sunglasses:

Your BT adapter isn’t found. It’s not recognized in the logs you provided in your OP, neither.

This probably means, it’s either not there at all, it is broken, or - more likely - there is a hardware switch (possible Fn-key or other button, consult your PC manual) to turn the BT chip on / or off and that is turned off all the time. - You can rule this reasoning out, when it works under Windows.

If that isn’t the case, it might well be related to a chipset which is sharing WiFi and BT. In that case, it might help to disconnect all power (including battery) from the laptop for min. 30 seconds and reboot.

Yes, indeed there are some chips around like that, and don’t ask ME why:person_shrugging:

1 Like

I just wanted to ask if WiFi is working?

I gave this a go (open laptop and physically remove the battery for some time), unfortunately with no success. I really hoped it would make a difference but… no :man_shrugging:

Did you install any package for the Wifi or did it automatically work when you installed Endeavouros?

Yes, on Linux WiFi works and bluetooth doesn’t (both on EndeavorOS and on Linux Mint). And on Windows 10 both work (I quickly installed it on another partition just to check this, then removed it lmao)

I researched some more and I’m realizing so many people the exact same problem haha. The RTL8821CE chipset seems quite problematic.

Automatically worked

Yes it is problematic. Have you tried any of the packages that can be installed for that chip?

Yes, this one

Did you try blacklisting the rtw88 modules?

Does that mean creating a .conf file inside /etc/modprobe.d/? If so yes, btw things I’ve tried (that were previously suggested) are in the parent message to this one @ricklinux

Sorry i missed that above. Have you tried rtw88-dkms-git


I don’t think I have! I suppose I need to remove the other package rtl8821ce-dkms-git to use this, right?

I assume that would be the best.


It does show some blacklisting also. Maybe try it without at first.


Maybe look at the link after as it shows some info on that.

1 Like


I have an HP that uses the rtl8822ce and it works fine.

It shows for lsusb

Bus 001 Device 004: ID 0bda:b00c Realtek Semiconductor Corp. Bluetooth Radio

It shows this for bluetooth but i have it turned off on KDE.

  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends

Mine interestingly shows absolutely nothing regarding bluetooth on lsusb. Just these 4 entries

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04f3:0c00 Elan Microelectronics Corp. ELAN:ARM-M4
Bus 001 Device 002: ID 0408:5365 Quanta Computer, Inc. HP TrueVision HD Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Edit: same with rfkill

$ rfkill
 0 wlan phy0   unblocked unblocked

I tried with no blacklist and with just rtw88_8821ce in the blacklist, now I’ll try with the entire blacklist posted there.

Edit: tried complete blacklist as well