Blender closes when I add a Fluid Domain

Hi friends.

I don’t know how long this error has been active, since I haven’t used fluid simulation in Blender for months. But I needed to simulate fluids a few weeks ago and every time I click on Fluid - Domain, Blender closes:


I have run it from terminal and I get this:

[mylinux@eos ~]$ blender
Read prefs: "/home/mylinux/.config/blender/4.1/config/userpref.blend"
Fatal Python error: PyImport_AppendInittab: PyImport_AppendInittab() may not be called after Py_Initialize()
Python runtime state: initialized

Current thread 0x00007be320400000 (most recent call first):
  <no Python frame>

Thread 0x00007be35d4dc000 (most recent call first):
  <no Python frame>

Extension modules: _freestyle, bpy.props,,, bpy.utils.units, bpy.types, mathutils.geometry, mathutils.interpolate, mathutils.noise, mathutils, idprop, _cycles, bl_math (total: 13)
Aborted (core dumped)
[mylinux@eos ~]$

Does anyone know if this error could be caused by Blender, the Nvidia drivers, or EOS? I am a very noob user, so I still don’t know how to locate where an error is coming from.

(Maybe the bug is from Blender and I have to report this bug on the Blender forums or something, I don’t know).

Thanks in advance.


I forgot to mention that today I fixed a bug I had with the new version of Python, which re-compiled several programs etc. I’m not sure, but the word “Python” appears there, so it may be related to the “Python” programming program that was recently updated.

Can you explain exactly what you mean by this and how you fixed it?

1 Like

For the purposes of making things easier to find, it is usually better to post issues about specific software that aren’t specifically made for Linux in their respective forums.

However, it is possible that you just need to update your system and try again.

I also have this issue, by the way, but I won’t be updating until the weekend, so I can’t test if updating my system will fix it.

The first link from this web search seems to fix the issue with an update on both Mac and Windows.

Link: blender crashes when adding fluid domain

PS: I’m Not saying, “Don’t post this stuff here.” → Just saying it’s better when posted elsewhere.
Also, it’s better to do a web search or search a Blender-specific forum first.

1 Like

Yes sure sorry, I mean this, I think this may be related:

Thank you friend. Yes, don’t worry, you’re right! Next time I’ll ask on the Blender forums. But I thought it might be related to the Python udpate on EOS or something, but I see it’s not, because it seems like this also happened on Windows and Mac.

And thanks for the link, although I found that link yesterday trying to find a solution and I didn’t pay attention to it because it is from 4 years ago and I thought that the error now would be a different one, that’s why I was looking for results from 2024.

I updated last night and the error persists, I will update in a while and see if they fixed it.

Thanks again!

Well, I’m on Archcraft at the moment and I also have this issue, so it may be an Arch issue or Linux issue, not just EOS.

Or it may just be a Blender issue.

EDIT: It may be a Repo issue.
I just downloaded the archive for Blender 4.1.1 from Fluid domain works as expected.

So for now, you may want to download it from there, or maybe uninstall and reinstall Blender.

1 Like

Wait wait, I didn’t know EOS could run packages/apps outside of the Arch/Aur repository. I only know how to download packages from the terminal with yay.

When I was on Windows, I downloaded the portable version so I could simply delete the folder without having to uninstall it when a new version came out.

Am I supposed to download the portable version for Arch from the web or something? Sorry, I know this question must be very noob.

There are 2 versions of Linux listed, but I don’t know if it is compatible with Arch/Aur, although it has worked for you, so I guess so. Does this install on EOS as if I installed it through the terminal or something like that?

I’m going to look for a tutorial because it seems a little more difficult than installing it from yay.

Thank you friend!

It works the same way it works on Windows. It is a package for Linux, not Arch. Works just like a .exe or .msi file.

No tutorial needed. :sweat_smile:

So the Linux version with 285.3 MB is the one that will download an archived folder. Once you extract the archive, you have a full Blender version, just like you would on Windows, and you can delete it if you feel like without needing to uninstall anything.

Sometimes addons don’t work on new versions, so having an older version of Blender is necessary to use the addon. You can get the older version by clicking “previous version?”

Then click “Download Any Blender”

Then choose the version you need and select the correct one for your device.

1 Like

Omg, I didn’t know this existed! It’s a kind of portable multi-distro Blender!

I’ll try it tonight. But, a question, on Windows, when you run blender-portable from for example the “Downloads” folder, Blender-portable creates several configuration files in %APPDATA% and other folders like My Documents, etc.

Will this Blender-portable also create configuration files etc, on my EOS? I mean, like when I install it from the Arch repository.

And, the portable multi-distro Blender should have the same performance and compatibility as the version in the Arch repositories, right?

I ask this, because normally in other programs on other websites, they are separated by distro, something like: Debian/Fedora/Arch, etc.

Thanks again for the guide friend!

Yes, it will create separate directories for each Blender version in your base .config/blender folder.

Compatibility is always based on your system and app version, regardless of your OS. Blender was made with universal compatibility in mind from the start. It is not a Windows app — it’s just an app.

Lastly, though most (if not all) Linux distros implement a package manager, executable files (aka program files similar to .exe) have always existed. They are usually .sh files or files written in python.

1 Like

Lastly, though most (if not all) Linux distros implement a package manager, executable files (aka program files similar to .exe) have always existed. They are usually .sh files or files written in python.

In my limited experience I have found .run to be common among universal Linux installers too.


Thanks friend, this is really interesting. So this compressed file is compatible with Debian, Fedora, Arch, etc., that’s great!

By the way, I already reported the bug on the official Blender forum, in case this error happens to someone else:

Thank you very much for the tutorial friend! I already downloaded and unzipped the universal.tar.xz version.

By the way, I can’t see the extensions of each file like in Windows, so I don’t know which is a script or which is an executable.

What would then be the correct way to launch these “universal-apps”? With “blender-launcher”, or “blender”?

Because “blender.desktop” I think is a shortcut to paste it on the desktop (not sure, but it has an exclamation point for some reason).

As you are using dolphin just hover your mouse above the file on the bottom left you should see next to the name of the file in brackets the file type


Just double-clicking “blender” should launch it, and the “blender.desktop” file is for in case you’d like to place it in your start menu, your taskbar, or a shortcut file on your desktop.


For the “blender.desktop” file, if you right-click and go to properties, notice that the file points to “blender”, which means if you have Blender installed from the repos, it will launch that version. But that’s not what you would want. Instead, click “Browse…” then select the “blender” file in the folder. Then you should be able to place this “blender.desktop” file anywhere and launch the one from that folder.

And under the “Permissions” tab, you need to select “Is executable” to be able to run the “blender.desktop” file.


1 Like

Omg, thank you both so much, it worked!

I’m using the same version, 4.1.1, and this version does work correctly. I reported it here:

But they closed my report and opened this other report on the Arch repository forums:

You were both right and I think it’s a Blender compilation error in the Arch repositories, or something related to Python.

When Arch puts a program in its official repository, does it modify it or something? Because in the Blender report forum thread, they said it was modified.

I wonder, if it is not better to download the official version from the website, also with other programs?

I mean, should this be done with other programs like Mozilla Firefox, Lutris, etc? To avoid this kind of bugs (I don’t know if it’s something common).

I’ve noticed that rendering in Cycles works better with this version of Blender than with the Arch repositories version, and so far I haven’t had to use REISUB with Blender. I don’t know if it’s luck or my imagination.

TL;DR — Using the official repos is the recommended way since compiling from source takes forever, and finding apps packaged for Arch is uncommon.

Technically, yes. It is “better” to use the apps directly from the site or compile them from source.

However, not every app makes a version that can run on Arch — it is actually uncommon that they make a version that runs or Arch or even a version that runs on most Linux distros. The most common thing is something for Debian/Ubuntu-based distros. And recently, it has been common to see Flatpaks too.

When developers don’t make versions for Arch, then you have the option of compiling and building from the source code.

However, it can take some people a whole day or more to compile a new version of Firefox. So, unless you have the time to do this with all your apps, using your distro’s repositories is the fastest and recommended way.

PS: For serious Blender users, it is actually very common to use multiple Blender versions based on the add-ons they use. This is because the add-ons may not take some time to be updated and made to work in new versions of Blender, or the developer of the add-on has completely stopped the development of a great add-on.

1 Like

That is very interesting.

You mean, the Blender source code is universal, and if I compile it from my EOS, it will work on my EOS?

Yes, I’ve noticed that, I don’t know why almost everything is on Debian/Ubuntu. Although there are programs like JDownlaoder 2 that don’t exist in Debian/Ubuntu.

Yes it’s true. I’m a Linux noob and I downloaded the librewolf package instead of librewolf-bin and it started compiling, after 8 hours I had to cancel the installation (I didn’t even know what compiling meant). I would like to compile things myself, but they take forever, do you think if I had a powerful pc I could compile in minutes?

Yes, I have read the 3 open threads about issues in the Arch forum. Apparently the problem is that Arch discards older versions of Python, and this does not happen in Debian/Fedora.

So, a user of that thread created 2 days ago the blender-bin package in the AUR repository, with all the Python versions that the official Blender comes with (as you recommended, the best is to compile the source code yourself, but it’s very slow).

So the problem seems to be the way Arch compilation and dependencies work or something like that. I know 0 about the Linux world, so I may have actually misunderstood what I read.

Sorry, lots of text again and my English is bad!

No, that’s not why. It’s just the combination of Blender and Python. It’s the same on Windows. Blender updates semi-frequently, so sometimes add-on devs don’t have the time to recompile their add-on for a new Blender release. If a user loves the add-on and updates to a new version of Blender, they may not be able to use the add-on in their updated Blender. As such, the user downloads/keeps an older version of Blender to make sure they can continue using that add-on.

In the case of Arch, we are now using Python 3.12. Blender 4.1.1 uses Python 3.11. This is the actual issue. So, you should be able to install Python 3.11 and run the system installed Blender with no issue.

That would be:

yay -S python311

I did not recommend compiling from source. I said it is “technically better”, but it is recommended to use the official repos for your distro.

The reason Debian/Ubuntu packages are common is because that packaging format was/is king in the Linux world — at least in the eyes of app devs. So, sometimes if you check the build information for even Arch’s official packages, you’ll see it reference a .deb file or Ubuntu.

Regarding compiling from source: until you become very advanced in using Linux in general, I’d recommend pretending that such an option doesn’t exist.

This recommendation is specific to frequently updated packages, however — Firefox, Blender, Krita, etc. For packages like qimgv, fsearch, etc. that get updated like once or twice a year, you can practice compiling and updating from source with these.

1 Like

Oh, this resolved part of the doubts of the new thread I opened in the applications subforum, I see, then it was referring to the add-on, thank you!

So, wouldn’t it be best if Blender installed that package as a dependency, automatically?

Maybe they don’t do it because they didn’t know until now?

Thanks, I’ll install it tomorrow!

Oh, this is also very interesting. I would like Linux to have a universal repository, personally I don’t like that there are 3 large repositories separated into 3 “branches” like debian fedora and arch, it is a bit “chaotic” for me as a new user. Although I stick with EOS because it is my favorite because its commands are shorter and easier, it has the best community and it is the only one that works for me for gaming. But I have to admit that the Debian repository looks nice, although I think it updates more slowly.

Sometimes maintainers simply don’t remember to add the correct dependencies. Easy mistake when there is a big update that affects so many packages.

I’m actually having trouble installing it due to a failure to import the necessary keys. So, no rush — just continue using the portable version of Blender you downloaded.

FAR more slowly. I’m talking months to years.

I really couldn’t get it to install, so I instead downloaded it from the Python website, built it, then installed it. I can’t seem to get it to use the correct version of Python — not tech-savvy enough :disappointed_relieved:. So, don’t bother trying this. Just use the portable version until a fix is issued.

The fix in this case would be that someone from the Arch Linux team adopts the python311 package and maintains it until Blender starts using python 3.12, which according to their dev site will not be until next year (if I read that correctly).
→ This is actually not very likely, so prepare to continue using the portable package for a while.