Bios deep sleep windows strikes again

I was wondering, how do you deal with the deep sleep issue in bios?

Windows has apparently managed to introduce a new suspend mode similar to what happens on cellphones, meaning the computer drains more battery than conventual suspend (aka deep sleep S3) so it can retrieve emails and other things like that while in sleep/suspend mode.

What that means for Linux, that the computer drains battery while on suspend, and microsoft managed to lock in this stupid mode in bios on certain new computers.

I don’t have the option in bios to enable deep sleep S3 (Lenovo Yoga slim 7, intel). Apparently there is also a boot parameter that can be added to grub instead. Some infos on the arch wiki above.

Is that common on new laptops? What fix do you use for this? I never heard of this before. One more reason why I dislike everything Microsoft.

From the Archwiki site you refferenced:

Solution 1: Enabling S3 sleep on advanced BIOS

  • Turn off OneKeyBattery mode in BIOS setup, if it is enabled, and save the BIOS settings.
  • Power down the laptop.
  • Type, with the laptop powered off: F1 1 Q A Z F2 2 W S X F3 3 E D C F4 4 R F V F5 5 T G B F6 6 Y H N.

That’s crazy! Makes me wonder how much more of these key combinations there are with the laptop powered off.

I was wondering whether this was a joke or note. Pretty crazy.

So the combination unlocked S3 sleep in your BIOS?

What about this?

Edit: Not sure if this is just for laptop with AMD?

Edit: I would probably stick with the Arch wiki if it were me. :thinking:
Edit2: Looks like this was on an AMD

What does your laptop show?
Edit: Think you need sudo here.

dmesg | grep ACPI | grep supports

For sure, don’t think I will install a program from a stranger and modify my bios setup, too paranoid for that :rofl: I am running Intel btw.

I will try the key combination first and give some outputs when I am back on the computer. Thanks for the suggestions!

Does the command show anything?

sudo dmesg | grep ACPI | grep supports

I get the following:

$ sudo dmesg | grep ACPI | grep supports
[    0.180214] ACPI: PM: (supports S0 S3 S4 S5)

The key combo did not unlock anything in my bios unfortunately…

So it say’s it supports the following sleep modes.

(supports S0 S3 S4 S5)

There is another post about sleep states on a lenovo T14 also.

There is a second solution with acpi patching on the arch wiki link I posted in the first post, but I don’t understand the step Patch the decompiled DSDT table (dsdt.dsl). Use this patch for Linux <= 5.10 and this patch for Linux 5.14

edit: and probably don’t need this whole fix, since the output from my previous post indicates support of S3, I should be able to enable it in Grub somehow

edit 2: output of sudo cat /sys/power/mem_sleep gives me [s2idle] deep, meaning it is not currently using s3

I get the same output on my desktop but i don’t have it installed with hibernation and I haven’t set the settings to enable these modes in the UEFI Bios. It may work if i change them not sure? I don’t tend to use hibernation or suspend anyway.

I have a new lenovo Thinkbook but it doesn’t have EOS on it yet. Maybe it works or maybe it don’t either?

Maybe the kernel documentation can help you.

1 Like

Thanks for the link, I will check this out. For now I disabled two other strange settings in bios, one was USB always on and the other the possibility to charge external devices via USB c even during sleep mode. Might be that the battery will drain less and can use the advanced deep sleep. Really don’t get it why Microsoft implement d this in the first place.

I actually have those settings on. :wink:

I think probably the best solution for this type of system (at least for my case) is to setup suspend then hibernate when closing the lid for laptops. This way it doesn’t drain the battery overnight and can use that new sleep mode for a limited time and switches to hibernate.

I did not find another good way to switch back to the S3 sleep mode. Don’t know why manufacturers lock that option out of bios for the user for certain laptop model, that’s such a bummer.

The only options are bios patches, and to be honest I prefer not fiddling with that, could lead to potential failure and brick my whole system.

Honestly I just turn it off. I don’t see the need for suspend or hibernation. But i know what you are saying. These new laptops which i have a couple are designed around Windows and they have settings so when you close the lid it goes into a low power mode and as soon as you open the lid it is instantly at the desktop just like a chromebook. Eventually the battery goes dead when using this mode unless it’s charged up enough.

Edit: On my Lenovo i turn this setting off. It still goes into a sleep mode and shuts down the panel so if i close the lid and open it its still in the same mode. I have to press the power button or spacebar and it comes on. Don’t usually leave it in this mode as i shut it down. It’s just another power save technique they implement to save on battery while unattended.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.