Balena-etcher bug or not?

I wanted to try balena-etcher and it took a very long time to load. once installed it started and the window remained white even after restarting the system. so i installed and tested imagewriter which worked great. I don’t know if this is a bug but I wanted to report it.

Don’t use Balena Etcher, it utter rubbish.


Just FYI, I don’t know why but when using popsicle it takes a couple of minutes to write my iso to usb whereas imagewriter takes 5-10min. Although both are fine and never got a corrupted usb or problem with iso.


Popsicle is great. I typically use Ventoy, but when it does not work with a specific ISO, I use either dd or Popsicle.


Also discovered Ventoy a couple of weeks ago, awesome to load a couple of different ios on my usb stick!

1 Like

Yeah, Ventoy is fantastic in theory, but in practice, it often does not work. With some versions of EndeavourOS ISO in particular. It’s always hit and miss with Ventoy, unfortunately.

I like your style!
Screenshot from 2021-09-18 17-21-25

Posicle is great! I used to use etcher and never had any issues. But not lately so that could have changed. It is my choice on Windows though.

1 Like

I use Suse Image Writer for putting ISOs on usb. I just wish it let me do Windows ISOs for when i help microsoft folks.

oh dear god, 223mb for an image writer?

now im curious how big the suse one is?

EDIT: 237kb :metal:

I use Mintstick USB formater and USB image writer. They are small, fast, and never fail. Also, the plain old dd command works like a charm.


The BalenaEtcher Appimage is 89 MB
The debian package is 82 MB
And etcher-bin-1.5.122-1-x86_64.pkg.tar.zst is also only 89 MB.

etcher is an electron app and electron apps tend to be a little bigger than other apps.

I used etcher last week several times and it works just fine. I like the user interface :blush:

Hi @Kresimir
the installation of popsicle yay -S popsicle contains lots of errors and in the end does not work for me. I tried popsicle-git yay -S popsicle-git and it works fine

Re Etcher: It’s for people who don’t use lsblk to first check the connected drives. I was that person on one occasion, but I can reinstall Arch Linux in a few minutes so no harm done - really!

@davidw why are you assuming that Etcher is the only ISO image writer with a GUI? It’s a false dichotomy.


There are plenty of GUI image writers

Gnome Multi Writer
Suse Image Writer

just to name a couple

I have no issue with etcher. I have used it more than 500 times. I now use popsicle on linux but still use etcher on Windows if needed.

Suse Image Writer for me since about 2012 (approx). It’s always worked so I ain’t gonna change unless it stops working. I’ve got Etcher & Unetbootin on an old MacBook but I haven’t used those for years. Etcher does seem like massive bloat, it’s like Adobe for image writing! :grin:

I use etcher-bin and I have no issues with it. But as i say i switched to popsicle on Linux. Honestly i think I’ve used dd once or twice. :laughing:

There was a “thing” maybe about 4 or 5 years ago about Etcher sending telemetry back to it’s devs, rather more telemetry than seemed reasonable. I don’t know if that has changed. I guess a small amount like how the app is being used is ok, but any more would seem excessive for a simple image writer. Also why such a large size for a simple app?

If these issues are no longer relevant then I have no issue with it, and if it works for folk then fine.