Audio Interface: RME Fireface UFX 2

I have an audio interface RME Fireface UFX 2 and I can’t seem to get it working in any form. The very least I’d want to get a stereo output from it.

In the context of Music Production using endeavour OS, I have had some success using a MOTU 828 Mark 2 with Bitwig, having access to all inputs and outputs.

I am wondering if anyone in this forum uses any RME interfaces with EOS and are willing to share their experience and insight.

All the best!

I have UCX and i assume it works the same

First of all you need to set device in so-called CC (Class compliant) mode (see manual)…
And then use jack2 to have access to all of ins / outs, since it’s professional interface it’s a great idea anyway.

1 Like

I will let you know how that goes. Thank you!

On jack, if you haven’t worked with it before here my old instruction to give people idea on setup.

Just keep in mind - it was written with pulseaudio setup in mind, i have no time to rewrite it right now for pipewire, so for example if you install pulseaudio-jack i remember it have some conflict with pipewire, still better than nothing :wink:

Idea of routing everything through jack is still the same.

Common terms

buffer under-or-overrun, X stands for under or over. It’s a sign that your system did not process some buffers in time, so some data is missed. It is particularly true when you run at very low buffer size where the sound card should process incoming buffers very fast (overrun). Some chips cannot cope with small buffer sizes, so you have to increase the buffer length to ease the work done by the sound chip.

Realtime config quick scan

Run as:

perl ./

Use this script and all of it’s recommendations (except maybe CPU Governors & RT Kernel)

Route all audio through JACK

Here’s basic setup…

Install those packages:


Launch Cadence and do it’s most basic settings (to route all audio through JACK):

JACK Settings
[x] Auto-start JACK or LADISH at login

ALSA Audio
Alsa -> PulseAudio -> JACK (plugin)

[ ] Auto-start at login

[x] Realtime

[x] ALSA
    [x] Duplex Mode !
    Device/Interface - your audio card
    Sample rate - 44100 kHz
    Buffer size - 512
    Period/Buffer - 2

System settings - Audio
[x] JACK sink (PulseAudio JACK Sink)

Smaller buffer size - obviously smaller will be latency, but if you just listen and don’t create music - it should be safe starting value (although outcome heavily depends on Audio hardware, usually you should aim for as small value as possible, which doesn’t introduce crackles / xruns)

Inside Cadence there is Tools - Catia - here you can route anything to any connection like an octopus :slight_smile:

Now to use jack in program that supports it directly, you start for example VLC, go to Tools - Preferences - Audio - Output module and choose JACK audio output, this means that you will completely bypass pulseaudio and ALSA and use jack directly.

Now, close VLC and open any audio file with it see if there is a sound!

1 Like

Switching it to CC mode enabled it to show up on my system. From there I just patched the software output into playback_FL / playback_FR of the audio interface via Carla. I just wanted to be able to listen to music. I will stick to Windows for now for Music Production. I may come back to your instructions if need to be. Thank you very much! :slight_smile:

Please switch as soon as you can, Widnoze is malware! :rofl:

I’m sure you’d like to know some of that… |

It’s a bit outdated, but yes it’s all possible :upside_down_face:

Fireface is great device, and you’re doing some nice live stuff on YouTube, keep up the good party! :partying_face:

1 Like

I feel so as well about Windows.
If I could get Fusion360, Ableton Live, Rhino working reliably on Linux I would have done the full switch by now.

If you have any suggestions or know of any tips which could enable these pieces of software to work properly on Linux, I would deeply be grateful. I really do want to stop using Windows, but I need them for my work. I use Linux EOS for file management because everything is crystal clear. The interface on Windows freaks me out.

Definitely doable through wine, although it would be nice to have natie Linux version…

Big tick Rhino synth you mean?

Here’s my result on Renoise native Linux + wine + LinVST bridge, smooth as silk:

That doesn’t look too good :thinking:
Howeer, winehq is not set in stone, sometimes it’s database is wonky…so there’s only one way to find out :upside_down_face:

Reliability wise - once you find working combination of wine - it’s super reliable with one caveat.

  • You should always do portable wineprefix with specific portable wine version
    Linux gaming [Guide] will help you to find out pretty much how.

This will not only be reliable, but you can transfer such wineprefix to any other Linux system!
Say you’re insane person with more than 2000 VST plugins like i am…I have it all installed in portable wineprefix…No need to ever re-install it, just backup or transfer whole thing wherever you want.

Basically let’s say you have:
1 wine prefix with perfect configuration and wine version for Ableton Live
1 wine prefix with perfect configuration and wine version for Fusion360 (if you’ll be able to find working conditions)
1 wine prefix for all your vsts

1 Like

Any chance you know of a Wine Ableton Live with the current latest version as of now 11.3.4?

I was actually referring to, but this Renoise + wine + LinVST bridge looks very interesting! I shall try it soon, thank you.

Regarding Fusion 360 on Linux, the amount of hours I spent troubleshooting and trying to get it in working order probably adds up to a couple of days. Alas, I am using Windows for it.

1 Like

Nope, but if major version 11 works, all of it’s derivatives is very likely to work, they don’t change code too much

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.