Arc A750 and playing Halo Infinite

I am trying to get Halo Infinite working on my system.

Currently I have kernel 6.7.2.arch1-2, mesa 24.1.0, and proton-ge installed and updated.

The game starts up ( which it refused to do until I installed mesa 24.1.0 ), and starts the loading, but fails out before getting to the main menu. I have deleted the video’s as suggested a couple of places, but the error still happens with no video’s in the background.

With that, a couple of questions. Has anyone gotten this working on an Arc card before? Also, how can I install kernel 6.8-rc2 kernel in such a way so I can choose what kernel to startup?

1 Like

Have you already gone through the suggestions found here?

Halo Infinite has a Silver rating, which basically means it’s a 50/50 whether it will work on any system, regardless of what your specs are.

I hope you bought that game while using W1nd0w$ knowing it will work on that platform, as opposed to buying it while using Linux and hoping it will work.

No, I didn’t actually purchase it, the multiplayer is free. From what I can see, “most” people have it working, however, if I filter, no one has actually replied that has a Arc DG2 video card. Regardless, I have tried most of the tinker steps people have done, but none have resulted in any different results for me.

Well, like I said,

Also, did you filter by Arch Linux specifically? The reason I ask this is because you said “most” which is very much not the case.

Even filtering by Arch, working, working, didn’t provide any details but not working, working, bit of performance hit, working, performance issues, performance issues, working.

This is going 4+ months back. The game is working on systems, it appears that I need to purchase a Nvidia/AMD gfx card because my card isn’t well supported in Linux.

Maybe we are looking at two different things, because when I filtered for Arch, I scrolled through all the available pages and most of the comment highlights were RED, indicating a failure of the game to work.

Either way, just using the Silver rating is enough to be honest. And as you said, the multiplayer aspect is free, so you didn’t spend your money on something that may not work. I think you should think about this as well when it comes to purchasing hardware.

Meaning, if you plan on purchasing hardware (or anything for that matter) for something that is known to not work on random devices for any number of random reasons, please rethink that plan.

yeah Intel just started making dedicated graphic cards. Their drivers were neglected for almost a decade. Their cards also lack performance for the list price so they don’t sell that good either.
They have a lot to do.

if you really buy another card, go with AMD. They have the best Linux drivers for some years now and it does not look like that changes fast. With Nvidia you can also expect problems. Not in games though but in general system maintenance.
I have had several AMD cards in the past years and none had troubles on Linux - with Nvidia cards I constantly ran into issues, especially after kernel updates.

As an Nvidia user, I can say yes, Nvidia does give trouble with the general OS day-to-day tasks, but for games - it’s just awesome (point, blank period).

However, the issues I had were self-inflicted. They have all disappeared now, since I remembered that I made a change in my BIOS when I just got the device.

BUT, I’d still say this isn’t necessarily a device issue. It’s a game/software issue.

If the only suggestion is to go buy new hardware, please see yourself out of the thread.

Any other software suggestions welcome.

Although new Intel GPU is not ideal by any means just yet, but buying new GPU won’t help you solve this game’s problem…

People report best success with proton-experimental, try it.

P.S. And welcome aboard! :partying_face: :rocket:

I did not suggest that you buy anything. My suggestions are the complete opposite. But, either way, I will see myself out of the thread. :person_shrugging: :wave: :vulcan_salute: :v: :+1:

1 Like

here is the list I have tried.

  • proton-ge-custom
  • proton Experimental
  • proton 8.0-5
  • proton 7.0-6

I don’t see going back any further, if you think it is needed I will continue down the listing

Yeah unlikely it will change if you tried all those…
Anything in the log?

Which log and how do I see it? I start the game up using the “Start” button in Steam, but it is the same if I just run the executable from the game folder.

  1. Select game title on left panel

  2. Right :mouse: ButtonPropertiesSet launch options…

  3. Enter desired variables, separated by space and ended by %command%

  1. You want to create log file to check if everything fine or file a bug, use Environment variable:

    PROTON_LOG=1 %command%

    Log will be saved at location, where [appid] is your game id (look up steamdb if in doubt)


(c) Linux gaming [Guide]

1 Like

System information:
Wine build: wine-8.0
Platform: x86_64
Version: Windows 10
Host system: Linux
Host version: 6.7.2-arch1-2
12915.709:015c:0160:fixme:ver:GetCurrentPackageId (000000000011FEB0 0000000000000000): stub
12915.710:0164:0168:fixme:ver:GetCurrentPackageId (000000000021FEA0 0000000000000000): stub
12915.713:02b0:02b4:fixme:ver:GetCurrentPackageId (000000000021FEA0 0000000000000000): stub
12915.714:02b8:02bc:fixme:ver:GetCurrentPackageId (000000000021FEA0 0000000000000000): stub
12915.716:00dc:02c4:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.820:0030:02c8:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.820:0030:02cc:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.821:0030:02d0:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.821:0030:02d4:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.821:0030:02d8:warn:threadname:NtSetInformationThread Thread renamed to L"wine_threadpool_worker"
12915.822:0030:0034:fixme:ver:GetCurrentPackageId (000000000021FEA0 0000000000000000): stub
pid 10847 != 10844, skipping destruction (fork without exec?)

That is the last of it, anything else I should look for in the 300,000 + lines?

No idea, anything suspicious or useful.

12914.818:0134:0158:warn:seh:dispatch_exception backtrace: — Exception 0xc0000005.
12914.818:0134:0158:trace:seh:dispatch_exception code=c0000005 flags=0 addr=0000000141590A50 ip=141590a50
12914.818:0134:0158:trace:seh:dispatch_exception info[0]=0000000000000008
12914.818:0134:0158:trace:seh:dispatch_exception info[1]=0000000141590a50
12914.818:0134:0158:warn:seh:dispatch_exception EXCEPTION_ACCESS_VIOLATION exception (code=c0000005) raised

I keep seeing this, or variations of it.

This error message indicates that an application running on Wine has attempted to access memory that it is not allowed to access, resulting in a segmentation fault. The exact cause of this error can vary depending on the application and the system configuration. Some possible causes include outdated or incompatible graphics drivers, missing or corrupted system files, or issues with the application itself. To troubleshoot this error, users can try updating their system and graphics drivers, running the application in a different compatibility mode, or using a different version of Wine.

tl;dr - likely GPU drivers, not much you can do here except wait for when it’s improved…I’ve heard Arc is progressing quite fast. Or its game itself, then again you can only wait for newer wine / proton versions to see if they work for your system.

Which is why I asked the original question, how can I get the 6.8-rc2 kernel running? That kernel is supposed to have support for my video card.