Anyone else uses LTS kernel instead?

Hmm, you have to have the Welcome package installed.
Doesn’t work without it.

I keep one LTS as backup and on my laptop that is often the one in use due to a bit flaky hardware support.

I have LTS and latest as backup and run the zen currently, but I sometimes have issues with latest (5.7 did not work for instance).

Same here, I have the LTS kernel only as backup if the ZEN kernel should fail for some reason.

I can’t see that akm has welcome as dependency.
:thinking:

1 Like

Same here, I use Zen and have LTS and mainline as backup.

Had a bit of an issue with the Zen 5.7.11 kernel, so actually rolled back to 5.7.10 and froze updates to it for a bit until .12 came out. Was so easy I didn’t even need to rely on the other two kernels as backup :joy:

1 Like

Haven’t you tried linux-zen 5.8.1? It works fine here.

Intel Core i5-8250U
Intel UHD Graphics 620 driver: i915
1 Like

Yeah I’ve since long-updated to 5.7.12 then 5.8.1 for both Zen and Mainline. It was just a wee problem at the time a few weeks back, but other than that I’ve had zero issues in Endeavour :smiley:

1 Like

I run the LTS normally and I always have something on back. Linux on one computer and Zen on the other. Both as backups until I fix my swap file to work on the newer kernels.

1 Like

Linux-zen, linux, and linux-lts at all times.

2 Likes

Yes, look.

$ akm
Sorry, package 'welcome' is not installed.
2 Likes

I have three kernels, linux, linus-zen, linux-lts. It’s a thinkpad with i5-8250U and the best experience is with linux-zen, but with different (older) hardware the lts might be as good.
Try and error, that’s how I conquer the linux world.

2 Likes

@manuel This might be a missing depends for akm?

2 Likes

Well, I’ll be damned!
I removed welcome and eos-update-notifier along with it and I get the same message as you running akm from the terminal.

But I don’t get the following then:
akm

welcome is not listed among akm’s dependencies!

:confused:

I use it as a backup. So I have two kernels installed: the Zen kernel as my default option and LTS as my backup. since 2019 I have not had to use it.

2 Likes

No.
Let me see…

OK, it shares part of the implementation. I’d need to reorganize the code to make it work without welcome.

3 Likes

akm doesn’t run without the file /usr/share/endeavouros/scripts/eos-script-lib-yad being present:

and that file is in the welcome package:

$ pacman -F eos-script-lib-yad
endeavouros/welcome 3.4.4-1
    usr/share/endeavouros/scripts/eos-script-lib-yad

so it looks like a missing dep, or it could be split to a separate “libs” package?

3 Likes

I’ve been thinking about doing that, but so far other stuff has become before that.
If that is important to you, I could start reorganizing the common code a bit.

3 Likes

Not to me, not at all. :wink:

Just looking for possible solutions.

1 Like

Welcome’s code actually is quite small, so no urgent reason for the work I think. And welcome can be disabled if someone doesn’t want to use it.

But a reasonable idea anyway to split the code at some point, makes it more modular.

4 Likes