Zoom on Endeavour OS?

Have to use zoom for work, including screen sharing. :roll_eyes: My experience was a mixed bag with ubuntu and fedora working pretty well.

Now I’m on EOS! On i3 wm it works but when I share my screen the whole screen becomes dark grey transparent, that makes no sense to me. I also have a cinnamon DE but there the top part is flickering for the viewers…

Wondering, does anyone have a good experience with zoom and screen sharing on EOS? on which DE and which package do you use AUR or direct download from zoom?

1 Like

I wonder if it’s compositor-related…

It seems to work fine under MATE. You might need to set some specific window rules for i3?

I use this one: https://aur.archlinux.org/packages/zoom

1 Like

Thanks for the reply! I the mean time I downloaded and installed following this website:

It’s really odd, now talking about i3 wm, I can share one window, that works great. However, if I open a second window from the same program in does not show. The only way is to share the whole desktop, but it appears dark grey transparent. One can recognize what’s below. I do not know much about compton? could that be the culprit? I just switched to i3 last weekend, total noob in this area, but would love to use it for work…

In cinnamon its tricky, may be my nividia card issue, last night did the update, have a hybrid card with intel and the driver broke because on some dependency. That’s a problem for another thread…

Also the PKGBUILDs from the AUR only download zoom_x86_64.pkg.tar.xz from zoom.us.

Which GPU is installed? Which driver do you use?

1 Like

The i3 wm EOS install is on my lenovo T490S, nothing fancy, its a Intel Corporation UHD Graphics 620 (Whiskey Lake). It’s probably a setting in i3 that can be changed.

The cinnamon EOS install is another story, see my post above, first have to fix the nvidia driver due to update last night… I guess before complaining about the flicker on screen share I should work on that issue :wink:

That is very likely, reading around the net. I installed i3 over xfce, and see that I have compton and picom installed.

1 Like

Just make sure you don’t have BOTH running at the same time. That could cause issues. I’ve personally had better luck with picom than compton.

FWIW, I use zoom (current version 5.4.54779.1115-1) regularly in my practice on EnOS running stock KDE. I’ve had no issues whatsoever.

I actually found the problem for zoom screen sharing on i3, doing some search it looks like the transparency configuration of the compositor. The good news, it can easily be fixed.

Summarizing, I would need to change the picom.conf file in /etc/xdg/

shadow-opacity = 0.0;

The bad news, I am stuck. in my i3 session I cant activate the picom compositor. It seems another compositor is running but can’t figure out which one and how to disable it. When I run the command picom I get

session_init FATAL ERROR Another composite manager is already running.

I installed the i3wm following the EOS wiki tutorial

I had an install of EOS with xfce and then installed i3 from scratch and run it in a separate session.

looks like I am close to a solution, just need to find a way to enable picom with the right setting.

1 Like

Good to know!

It’s been a while since I’ve configured i3 proper. . . BUT I’m almost positive your .config/i3/config file or the .Xsessions/ .xinit file has the compositor startup for you. You’ll have to swap out compton for picom in that line where you start it. I know I swapped it out the last time I did it. If you really can’t find it, I can go diving into my i3 config file and try and figure it out for you.

1 Like

I did the following already in .config under #transparency

exec —no-startup-id picom -cC

and commented out the xcompmgr

Good point, let me check these in more detail…

That should do it. Also, just to note, if you restart i3 you would want to change that to exec_always otherwise when you reload the config file, picom won’t automatically start again.

Both my wife (on her computer) and I (on mine) use Zoom from the AUR on the Xfce DE.

No problems whatsoever …


thanks for the feedback. I am just wondering do you guys mean just “using zoom” or do actual screen sharing? I need to show programs for workshops and open close windows, and is unfortunate that I have troubles. Do you use zoom or zoom-qt?

do you comment the xcompmgr line out also?

1 Like

yes I did, but still run into trouble like on the link I posted above “Compton to Picom and zoom glitches”.

Zoom essentially overlays a grey transparent screen on my desktop. I am just wondering whether I have another compositor running in my i3wm session from the standard EOS xfce install that needs to be disabled.

I see some users complaining that zoom currently is not working on Archlinux, and zoom themself say that they support zoom under GNOME+wayland and on X11 only as a fallback afaik.
On i3 I would try set all zoom windows floating, what could solve this issue as DE’s doing that too.

for_window [class="zoom" instance="zoom"] floating enable

where you need to find class and instance with xprop or similar:

WM_CLASS(STRING) = "zoom", "zoom"

1 Like

Thanks, I will try that!

I am not sure about this part. Should I add this to the i3/config file? Thanks!

no this is the output from xprop what is showing the strings for class and instance you have to put inside here (that line needs to go into i3 config file…
for_window [class="zoom" instance="zoom"] floating enable

sometimes it needs to have one with a capital letter or using another name for the class then the instance… for zoom it is zoom and zoom simple