Zoom 5.11 sharing screen on Gnome Wayland

Hello everyone!

Zoom has released it’s version 5.11 with support for screen sharing on Wayland! Unfortunately it’s not working on EndeavourOS since the application doesn’t recognize the system as an Arch Linux, although it supports it.

Screenshot from 2022-06-23 16-26-49

Any ideas for a workaround for that?

Thank you!

This is a long shot but edit /etc/os-release and replace EndeavourOS with Arch Linux. Not really sure if it would work but perhaps worth a try?

Edit:

Just converted my Arch Linux installation to Debian :sweat_smile:

Screenshot from 2022-06-23 21-54-33

So if Zoom also reads the same file to determine which operating system is running, then I guess it should work!

Now back to converting Debian back to Arch :smile:

2 Likes

Shouldn’t zoom be looking for packages and dependencies? This is the first time I see an app check requirements like that, laziness perhaps?

2 Likes

I mean, it’s nice to see Antergos being mentioned but they seem to have missed the whole of EndeavourOS!

2022-06-23_22-27

:thought_balloon:
:penguin:

5 Likes

I’m not sure how to mend this but screen sharing should work on your browser.

The standard solution for screen sharing on Wayland is xdg-desktop-portal. Installing these and following the README and FAQ should get screen sharing working at least in Chromium and etc;

In the FAQ it says for screen sharing in the native client in GNOME

You may want to experiment with something like gnome-dbus-emulation-wlr, but we do not directly support that project.

I have no idea if this works and I’m guessing it’s gonna be quite slow but perhaps give it a try?

1 Like

Only if you have your web-browser’s settings allowing for ZOOM in the first place, me thinks.

1 Like

Also try ID_LIKE=arch in /usr/lib/os-release

1 Like

I think that didn’t do the trick for me…

Screenshot from 2022-07-18 18-48-07
Screenshot from 2022-07-18 18-47-50

1 Like

I’m gonna test how it goes using the browser. But it’s not the ideal solution… :stuck_out_tongue:

1 Like

From your screenshots (rather than text output as text on a text-based forum), it doesn’t look like you rebooted for the change to take effect?

So I already had ID_LIKE=arch in mine, still had the issue with Zoom. Anyone have any luck changing NAME or PRETTY_NAME or both? Or is it looking for ID?

EDIT: fixed ID=LIKE typo

If that’s what you have, that’s incorrect, it should be ID_LIKE=arch.

See also https://wiki.archlinux.org/title/Zoom_Meetings#Wayland_screen_share

1 Like