Yay gives me prepare() failure error

Hi guys, I generally use pacman to install packages, but with it I cannot see AUR pkgs. So I started used yay.

If I try to install anything like:

yay -S prusa-slicer-git
==> Avvio di prepare() in corso...
patching file cmake/modules/FindOpenVDB.cmake
Hunk #1 FAILED at 326.
Hunk #2 succeeded at 419 (offset 21 lines).
Hunk #3 succeeded at 450 (offset 21 lines).
Hunk #4 succeeded at 467 (offset 21 lines).
Hunk #5 succeeded at 477 (offset 21 lines).
1 out of 5 hunks FAILED -- saving rejects to file cmake/modules/FindOpenVDB.cmake.rej
==> ERRORE: Si è verificato un errore in prepare().

this happen for most of AUR packages, with LTS kernel or not.

can be solved? I try to make a search but I didn’t get results
thank u in advance

This seems to be an issue with the specific AUR packages you are trying to install. In the case of prusa-slicer-git that you shared, there are multiple comments under the AUR page reporting the same issue with patches, and some possible solutions too. (I haven’t tried so cannot verify if they work)



Oh thank you, so it’s better if I always check aur website before install? btw it happens also for gimp. It’s the same issue?

Its good practice to always read the comments on the AUR page before trying to build a package as many times the answer is in the comments

cculpepper1214 commented on 2021-09-09 01:29

@Athemis , do you have an updated patch? I’m having trouble applying yours, it says it fails on the first hunk.

Athemis commented on 2021-08-06 15:56

@Salamandar The openexr3 patch doesn’t apply cleanly anymore. See here for an updated patch.

Salamandar commented on 2021-07-13 14:13

@Lukas1818 thanks for the patch, I pushed it after testing. Sorry for the rant also :slight_smile:

Lukas1818 commented on 2021-07-13 12:02


For what is worth, gimp can be installed from the official repos. But perhaps you prefer the development version from AUR?


So AUR it’s huge, but it contains also pkgs that doesn’t work, so the good practice is:

  • look at community package first
  • then look at aur

Yeah, first look for the official packages from the repositories (see /etc/pacman.conf for more).
If not found above, try AUR. Note that AUR packages are not officially supported.


You should read these topics: