Xfce fonts problem

Noticed that sometimes MPV/Firefox/Chromium fails to read some fonts.
Any tips how to fix it?

Thanks.

image

image

MPV debug:

using default font settings or changed fonts ?
As Noto Fonts should have iconic glyphs

Default, I didn’t change any settings related to appearance, maybe because I opted for the offline install and a font wasn’t installed based on the language?

image

Noto is a multilingual font, so you should be fine. try installing:
sudo pacman -S noto-fonts-emoji
or sudo pacman -S ttf-dejavu

2 Likes

Nice, ttf-dejavu was already installed, installed the noto-fonts-emoji and it fixed the problem :slight_smile:

image

Really thanks for the help

1 Like

Fixed in chromium but unfortunately MPV is still facing problems with sans-serif…

yes i see ttf-dejavu is installed p.d. but offline doe snot have the emoji one… because package is huge and ISO needs to be under 2GB :wink:

1 Like

the offline install was indeed pretty fast, like going to make a coffee and coming back, using a usb 3.0 pendrive, 2GB on the fly it was :slight_smile:

using pure mpv or the celluloid gui?

pure mpv

Maybe the video title, as it has an emoji in it as per image above, is incompatible with the titlebar somehow?

image

Chromium is getting correctly

Edit: All other videos are working, just not that one, which contains the emoji

titlebar is from XFCE4 (gtk) i see the same here:
2021-10-09_20-26

1 Like


In window manager settings is the titlebar font…

1 Like

2021-10-09_20-33
setting it to Noto Sans Regular is working here.

1 Like

hmm. let me change that

Changed but MPV seems to not read the window manager settings…

I’ll do something easier, I’ll just watch that specific youtuber through the chromium, and all the others through MPV as I’m used too… :slight_smile:

Edit: That youtuber loves to put emojis in the video titles… I’ll ask him please to stop in the video comments, do you think he is going to hear me? ehheheh

I use MPV due to the hardware decoder that works for my nvidia card, and also like to have the video to the bottom right of the screen, without border and always on top… created a few shortcurs like ALT + UP and ALT + DOWN to resize as desired…

Really thanks for your time and support on this, got Chromium and Firefox fixed by the way

Such error reports are always welcome because they help improve!

Do you logout and backing after changes? As XFCE4 is not loading all changes on the run.

oh, let me try to logout then opening MPV again, one sec

Edit: Same behavior unfortunately

2021-10-09_20-45
may related to the video file you where loading … this from a video of mine putting the glyph in the name…

1 Like

Sorry for the delay, I was having lunch.

Changed the font to: Source Code Pro Medium in Window Manager, and MPV now shows the title correctly =) thanks, really thanks

Using Noto Sans Regular remains showing that strange characters in the title, so I’ll keep using the Source Code Pro as my main Font from now on.

Still getting those messages in MPV debug even when using Source Code Pro Medium

I’ll search mpv.io website to see if I can fix it somehow through mpv.conf

Edit:

[osd/libass] fontselect: failed to find any fallback with glyph 0x1F4A5 for font: (Source Code Pro Medium, 400, 0)
[osd/libass] fontselect: failed to find any fallback with glyph 0x1F4A5 for font: (Source Code Pro Medium, 400, 0)

Edit2: Trying to work if different values in mpv.conf, but the error persists…
Since the problem seems to be only cosmetic, and only in debug window, I’ll ignore it…

image