Works fine until I install my Nvidia drivers

So I install Edeavour OS and it works fine, I update my system then I install the proprietary Nvidia-drivers using the nvidia-installer-dkms, I reboot then it just stops at a blank screen with a horizontal line, I tried to go to a tty and install the bumblebee version because I do have an intel graphics card alongside my Nvidia 1050 Mobile.

I tried looking into:
After Nvidia Installation System Wont Reboot

but it seems none of the information is of any help because it ended with the OP using the free drivers. Please note I am a complete noob when it comes to Arch and I would appreciate your patience and help. Thanks!

Edit: I also did the test first on both the regular and bumblebee install.

To get a working system back reset to open source drivers:
sudo nvidia-installer-dkms -n
Then check GPU:
lspci | grep VGA

1 Like

Thanks for the tip, but I’d really like to use the proprietary drivers as the open source one is a bit behind.

also, here’s the output of lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)

You can follow the steps in this article:

Will get back after trying. Thanks so much for your recommendation, I appreciate it!

1 Like

Didn’t work, black screen on first reboot. Keyboard input is locked as well.

Try this command:

   lspci -k | grep -PA3 'VGA|3D|Display'

Edited.

I would but I can’t switch to the tty, is there any other way to input that command?

Yes, boot with the USB installer drive.

Should I chroot into my system then?

Not for that command. But if you fix anything in the system, then you must arch-chroot.

Here is the output of the command you provided me:

[liveuser@eos-2020.05.08 ~]$ lspci -k | grep -PA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: ASUSTeK Computer Inc. HD Graphics 630
	Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
	Subsystem: ASUSTeK Computer Inc. GP107M [GeForce GTX 1050 Mobile]
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidia_drm, nvidia

OK, thanks. It seems to work with nouveau, so you can temporarily use the command @joekamprad advised:

  sudo nvidia-installer-dkms -n

You must do that in arch-chroot. Then reboot.

Then you can try other commands, like

  nvidia-installer-dkms -b -t    # just tests, doesn't change anything
  sudo nvidia-installer-dkms -b  # installs bumblebee

and if that fails, you know how to get back to nouveau.

Note that in folder /etc/X11/xorg.conf.d you may have X config files that may need to be removed first (or saved to another place).

Thanks for guiding me back to nouveau, the additional commands you provided were the ones I tried earlier, I get no error during the test but the result was as I said, a black screen with no access to tty

That might be caused by the Display Manager. Which Desktop Environment and Display Manager you have now?

I have SDDM running on KDE plasma

I tried going back to nouveau in chroot but the following error is shown:

2020-06-04 18:55:06 [ERROR]: Cannot remove conflicting package virtualgl: checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing virtualgl breaks dependency 'virtualgl' required by lib32-virtualgl

Right. I’m not sure if e.g. lightdm can be used with KDE, but that is worth a try.
In arch-chroot you can give commands:

sudo systemctl disable sddm.service
sudo systemctl enable lightdm.service

and reboot.
If that fails, similar (but opposite) commands bring back sddm.

You could at least temporarily uninstall that 32-bit lib.

I am a new user so I have a limit for how many Replies I can make, if I don’t reply right away, please don’t take it negatively, it just means I am out of replies

1 Like