Wired Ethernet: Connected to Io

The Networks applet in KDE Plasma has recently started showing a Wired Ethernet connection called “lo” which wasn’t appearing there before. I don’t have an Ethernet cable connected to my laptop, and have no idea what’s causing it. Anyone got any clues?

I can’t disconnect from it, and if I delete it using the network manager, it reactivates immediately and reappears in the list.

1 Like

Ah okay, yes that makes a lot of sense. I realised after hitting “send” that this was Lo rather than IO, and then it began to make sense to me that it was the loopback ie. The next question is rather obvious… how do I stop it from appearing? I don’t really care that it exists and kind of take it for granted that it’s there in the first place :smile:

Ahh…I don’t think you can, i just ignore it personally :man_shrugging:
But let’s see maybe someone else will come to enlighten us :upside_down_face:

The problem for me was I first noticed it yesterday when I had taken my laptop to a coffee shop and wanted to connect to a WiFi network that wasn’t my home one, which obviously happens automatically so I don’t pay much attention to it. Straight away when clicking the Network applet I thought “uh oh, that’s not right…” and got a little paranoid seeing as I was using my laptop in public :joy:

Things like this are really not user friendly in any way. It doesn’t seem like having the loopback appear in the list of connections is something that most people would want (surely it’s a minority that needed it?) and is likely to just confuse most users, especially those who don’t know or care that the loopback exists in the first place :man_facepalming:

1 Like

That’s the right instinct btw, public wi-fi by any definition is NOT safe idea, coz it’s very easy for hackers to sniff such traffic by just being connected to the same network…If you want to be safe, you can just share internet connection from your smartphone at any place

Yep, totally agree. That’s actually what I ended up doing in the end anyway as for some bizarre reason the WiFi was blocking my SSH connections :roll_eyes:

Oh you h4xXx0r were up to no good with SSH ain’t you?! :rofl:


Yeah, up to no good, pushing my code to GitHub :stuck_out_tongue_winking_eye:

You can try this:



Then reboot

(c) https://bbs.archlinux.org/viewtopic.php?pid=2084565#p2084565

But please do your research on networkmanager unmanaged first - i have no clue how this works and if such config disrupts normal operation of loopback somehow (which you wouldn’t want!).

:oncoming_police_car: :policeman:

OI sir! Hands behind you head, NOW!!!
Get away from the laptop, what you’re doing is a federal crime!!


I had the same!
I created the file with that line, rebooted and it’s gone!
It was funny to have this “lo”
Thanks @keybreak

I did not

I did it the lazy way. If things went wrong I would have deleted the file and rebooted!

Thanks for that. Looks like it works (and the loopback still works too) :tada:

Just curious and would like to hear from the experts here.
I checked the link

I read it has something to do with security!

IEEE 802.1X is an authentication method most commonly utilized by secure enterprise Wi-Fi networks.


Should I better revert to the previous situation where the “lo” was showing?

That looks to be unrelated. The bit that covers this change is the next section with the heading “Managing the loopback interface”. Setting it to unmanaged doesn’t seem to have changed anything other than to well, hide it and mean you can’t configure it in Network Manager (but then why would you even want to?) :smiley:

Thanks @dylanparry
You mean that having this “lo” or not having it makes no difference to my connection security? It is useful only for cable networks not wifi? Public network or at home (wifi only)?
mmm… I noticed the “io” is reading and giving me wifi signal strength. So it is not only cable!

I hope to understand in plain simple English what exactly it does? what enabling/disabling it does and does not!
Sorry for asking lots of questions.

You have always had the loopback interface (lo), but it wasn’t displayed in networkmanager unless you specifically created a profile for it. Now, with networkmanager 1.42, it is displayed by default. That’s all.


That’s all!
I thought it was something “added” to networking.
Thanks for clarifying!

To add to what @Stagger_Lee said, it’s literally just the loopback that allows you to use (IPv4), or ::1 (IPv6), or even localhost to refer to your own machine.

1 Like

I understand now much clearer!
When it comes to networks I just know very little! :person_shrugging:

The Networks widget will no longer unnecessarily show the loopback interface when using NetworkManager 1.42 (David Redondo, Plasma 5.27.1)