Windows tearing/artifacts during minimizing/maximizing window (GNOME)

Hello, I’m kinda new to linux, I’m not good at all that kernel modules and so on stuff.
I have a 1650 ti mobile (Laptop), everything works fine on my windows machine (dual-boot), but on the linux I’m having a lot of strange things.

During the “try endeavour” time on XFCE DE everything works fine, when I install the system (GNOME), everything works fine as well, but when I do nvidia-inst I get the tearings/artifacts. I’ve tried manjaro and got the same results… installing nvidia breaks the windows. Also tried ubuntu and still had that problem,

on the first photo you can see the issue on the left corner (during minimizing the window)
on the second photo when i maximize the window and i can see my background while maximizing (during maximizing the window)


Is this on Wayland or X11, or both?

It’s X11

when i was trying to record it on a video (gnome screencast) everything was showing up ok, even though for me it was clear i was having tearing/artifacts (or whatever that’s called)

ok, was gonna guess maybe its Wayland but have you attempted to use Wayland and reproduce the issue?

That doesnt look to be sreen tearing but looks to be artifacts of some sort

I tried to install Wayland, but didn’t actually find out how to do it on GNOME. Some people tell it’s default, but in settings->about I see I have X11, is there a proper way to install Wayland for gnome?

it should be there on default, youll need to enable it following the instructions here

You can also try forcing full composition pipeline to see if that fixes things

So I’ve been trying to follow the guide, but I’m already facing problems, I did:

sudo ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

Boot into arch and edit /etc/default/grub
Add kernel option to the line GRUB_CMDLINE_LINUX

! I try to:
Regenerate /boot/grub/grub.cfg:
grub-mkconfig -o /boot/grub/grub.cfg

and get:
usr/bin/grub-mkconfig: line 265: /boot/grub/ No such file or directory

when i check:
cd /boot
ls -la
I get:
drwxr-xr-x 1 root root 26 янв 22 21:36 .
drwxr-xr-x 1 root root 128 янв 22 21:33 …
-rw-r–r-- 1 root root 51200 дек 16 11:44 amd-ucode.img

and here is the lsblk command:
Screenshot from 2023-01-23 02-16-11

well are you using grub or systemd-boot? It looks like you have systemd-boot which will change things a bit.

You would have to edit /etc/kernel/cmdline and add nvidia-drm.modeset=1 to the command line there and reinstall your kernel would update the cmdline

Also i might try the forcing full composition pipeline first.

I’ve tried the full composition pipeline, didn’t change a thing (at least not I didn’t notice it), I will try to use the /etc/kernel/cmdline thing you told me, can you tell me how i reinstall my kernel afterwards please?

im assuming youre using the stock kernel so

sudo pacman -Syu linux linux-headers

make sure to add that to the end of the /etc/kernel/cmdline file, you only need to add nvidia-drm.modeset=1 to the end of the file not GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1" as that file is the list of cmdline options

also forgot to tell, but when I:
sudo pacman -S nvidia-inst

I can start the desktop (xstart or whatever it’s called) but the tearing/artifacts are still there
but if i do:
sudo pacman -S nvidia-settings (I love to change a few color settings)
I get a dark screen after boot (can’t startx)

Nvidia-inst should include the nvidia settings as part of the driver package afaik. If you only install nvidia-settings it doesnt include the drivers. If you have nvidia-inst try running nvidia-settings from terminal

EDIT: just checked, nvidia-inst includes nvidia-settings in the install process you dont need to install it separately its there already

sad, I’ve tried to add nvidia-drm.modeset=1 to /etc/kernel/cmdline, but it was already there, I thought maybe everything is fixed and tried to restart, system died, now I’m making a clean fresh install, afterwards I will nvidia-inst and tell you if I have nvidia-settings and artifacts (in 5min)

the strange part is the fact I did nvidia-inst and only after i did install nvidia-settings, if i’m not mistaken it shouldnt remove everything nvidia-inst, so why does installing nvidia-settings after nvidia-inst break everything? Also for me it’s strange what the system doesn’t have artifacts/tearing unless I do nvidia-inst (but since i want the drivers + nvidia settings i have no choice)

ok I need to know exactly what all youve done, you shouldnt need to reinstall and if youve done anything extra/removed any packages,etc.

You can always recover a system, just need to know whats happening

it’s not a problem, i even prefer having a clean fresh install, im installing linux over and over that weekend, so nothing new

I dont have nvidia so i cant test and tell you what happened, but best guess is some sort of conflict of a sort :man_shrugging:

Well id prefer to fix a problem than throw out the kitchen sink but its up to you :stuck_out_tongue: We can start fresh then and step through the process to get this figured out then

when youre back since it seems like a chunk of the wayland steps are done already try editing /etc/gdm/custom.conf and making sure WaylandEnable= is set to true and not commented out with a # and the front, remove the # if its there

Then from the login screen you should be able to click the cog wheel in the bottom right and have a selection of gnome or gnome on xorg if wayland is already enabled for the nvidia drivers

new install ready, will do nvidia-inst now