Windows programs compatibility on linux

Well, I’m not sure if it helps, but the program is this:
https://www.daviespublishing.com/dpProduct.aspx?ProductId=1490

Yeah it’s not tested by anyone in winehq appdb, so…There’s only way to know :slight_smile:
Most likely it won’t “just run”, you’d have to install some winetricks and stuff like that…

might work with wine, if not, try wine-staging, if that still doesn’t work, set up a virtual Windows-machine and run it in there, that’s guaranteed to work.

Well, I don’t have any windows machine so I guess setting up a virtual windows machine is impossible for me. But thanks for suggestions.

Not at all, at least I think it’s not. You only need it for that program, right? That should work without a key…

Not certain if it’s entirely legal tbh xD but you can download the iso from MS itself and just select “enter my key later” or something and then use it for 30 days with some restrictions I think so just for the program that would be enough wouldn’t it?

1 Like

:shushing_face:

I’ll admit to having a windows dependency … not only the fact that ‘the man’ forces me use windows to earn my paycheck, but I am a long time quicken user and quicken just doesn’t work well on Wine. I have virtualbox set up with a windows 10 guest os … all just so I can use quicken.

If you converted your lady friend from Windows does that mean she has a laptop that used to have windows on it? If so, you might be able to use the machine’s original license key to activate a windows 10 guest os on virtual box in order be fully legitimate. this is actually how my virtual machine is set up

1 Like

My lady friend had 2 laptops with windows, but she allowed me to wipe out both empty and now there are only EndeavourOS left on both…:joy:

1 Like

Probably not a problem, the keys might be stored in the Bios.

According to this site, you could just run this command in EOS to retrieve the key (if it’s stored in BIOS):

$ sudo strings /sys/firmware/acpi/tables/MSDM | tail -1

Maybe it works, maybe it doesn’t, I don’t know ^^

2 Likes

Nice. I will try it. But there are better things to do than mess with windows. I prefer to go fishing now…:relaxed:

4 Likes

Always nice to see when someone has their priorities straight! :fishing_pole_and_fish:

2 Likes

It works. I just tried it on an Asus RogStrix computer on which I had completely removed Windows and replaced it with EndeavourOS. There are no traces of Windows left whatsoever on this computer - except for the Windows key which is stored in the BIOS.

I really enjoy reading the various posts on this forum; I never know when I might pick up something which might be useful at some time. This information would be useful if a friend or relative needed to reinstall Windows on his/her machine and didn’t know the key (and somehow had completely lost it). Using this command via a live EnOS installation disc (or probably any live Linux disc), I could retrieve it for that person.

Thank you for this!

Lawrence

1 Like

Ok, I managed to retrieve the key. But where do I download that Windows iso and what tool do I use to put it on USB-drive?

when I am doing virtual machines, I generally put the iso in the same folder am going to keep the virtual machine files. you don’t need a USB drive, your virtualization software will let you mount the iso as cdrom on for the virtual machine.

PS - aren’t you supposed to be fishing?

I linked it above.

Or you could just search for something like “Download Win10 iso Microsoft” on the web. :wink: Microsoft makes them available. You don’t need USB, just install qemu/kvm as described in the Arch wiki: https://wiki.archlinux.org/title/QEMU make a new VM, select the downloaded ISO, it detects it automatically, rest should be fine unless you want more space/cores/ram, but you’ll see it all once you’re there.

Fish wasn’t biting so I came back to my computer… :sweat_smile:

Oh, I forgot: It’s very possible, likely even, that virtual emulation is disabled by default in the BIOS - it was on both my laptop and my desktop PC. If it is, you won’t be able to get kvm/qemu to run - so go into Bios and search for that option. Or tell me your motherboard/CPU and I’ll find out if it’s possible and if yes, how.

Your link just gave me this: https://www.microsoft.com/en-us/software-download/windows10

What do I do with that media creation tool which is exe package? Where is that ISO?

? I get to the iso over that link.

Screenshot-20210724174459-1145x903

There I just select the latest version and get presented a 32 and a 64 bit version of Windows 10.

See? Maybe you can just use my link.

Screenshot-20210724174834-916x686

Ps. You might want libvirt-package too for GUI for qemu/kvm.

Oh, now I get it. I was using Libre Wolf browser to open that link. It seems it prevented me to download such malware as Windows… :joy:

3 Likes