Windows erased Systemd-boot entries in UEFI

Image got from the LiveUSB:

From the LiveUSB, tried to arch-chroot and run:

But no joy.

I can’t boot into EnOS anymore, Linux Boot Manager missing from the UEFI.

I see no joy either. :scream_cat:

Edit: Neither Windows entry works? I see two there.

Windows entries are working. I’m now in Windows :face_vomiting:
The strange thing is that one of those entires sjhown in the picture is from EnOS systemd-boot.

Only the EnOS got erased somehow…

Windows - The ultimate malware… :rofl:

Sorry i misunderstood. So Windows erased the EnOS entry.

It seems so, not sure what happened because I didn’t update Windows…
I was playing Dota2 in Windows and then decided the boot to Linux and boom, entries are gone.

I have never tried this myself and I’m not sure if this is the proper way of handling this issue but you might want to look into to manually create an EFI boot entry for systemd-boot:

I guess this can be done from the Live environment.


Thanks @pebcak and @ricklinux.
@pebcak, that link helped a lot.

All I had to do was to boot into LiveUSB, and then:

# mount -o subvol=@ /dev/sdb2 /mnt
# mount /dev/sdb1 /mnt/efi
# arch-chroot /mnt
# bootctl install

And now, everything is working perfectly again…

$ efibootmgr 
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0000,0001
Boot0000* Windows Boot Manager	HD(1,GPT,2d718023-dd3e-4c48-824a-2fe3584dd9ab,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d0000006f000100000010000000040000007fff0400
Boot0001  Windows Boot Manager	HD(1,GPT,651f06c7-7762-c349-b386-5d6bcfadacc0,0x1000,0x1f4000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)0000424f
Boot0004* Linux Boot Manager	HD(1,GPT,651f06c7-7762-c349-b386-5d6bcfadacc0,0x1000,0x1f4000)/File(\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI)

Glad you got it resolved!


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.