Windows bootloader doesn't show

I have a laptop with 2 ssds, and the one has win11 and the other endeavourOS. But I was trying some things with EOS and by mistake I installed EOS on the windows ssd. After that, I installed windows 11 again on that ssd, but when I tried to boot and normally have both options (linux and windows11), I only had windows. Then I installed EOS on the ssd2 and now I tried to boot and systemdboot showed only the linux boot option. How can I fix it so that I will have the option to boot into windows and linux? The lsblk -f output is this:

NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda1      vfat   FAT32 EOS_202308  10EF-606D                                           
└─nvme1n1p1 ntfs                     5C28935828932FCE                                    
├─nvme0n1p1 vfat   FAT32             F740-2AEF                             730,1M    27% /efi
└─nvme0n1p2 ext4   1.0   endeavouros 79536822-5551-4841-a39e-fddcf5a5cfdc  425,6G     2% /

With a search with keywords “dual boot windows”, you can probably start your fix. Here’s a couple I got: