Windows and Endeavour Dualboot not working

today i attempted to do a dual boot with Windows 10 and EndeavourOS and after installing EndeavourOS successfully, after the restart it just booted to windows instead of GRUB, i tried going into BIOS to change it to the Linux boot manager but there wasn’t one there, just the Windows Boot Manager, i checked Disk Management and the endeavourOS partition is detected as a “EFI System Partition” I don’t know what im doing wrong as Ive done this before many times successfully.

Did you use manual partitioning or install alongside?

i tried both, they both got the same result

From the ISO, what does sudo efibootmgr show? Also, sudo parted -l

here let me boot into it again

sudo efibootmgr says “EFI Variables are not supported on this system.” and sudo parted -l says
Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sda: 15.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2595MB 2760MB 165MB primary fat16 esp

Model: ADATA LEGEND 700 (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp, no_automount
2 106MB 123MB 16.8MB Microsoft reserved partition msftres, no_automount
3 123MB 416GB 416GB ntfs Basic data partition msftdata
5 416GB 512GB 95.4GB ext4 endeavouros boot, esp
4 512GB 512GB 547MB ntfs hidden, diag, no_automount

That is the issue.

It means you are booting the ISO in legacy mode which means you are getting are not getting an EFI install.

You need to boot the ISO in EFI mode. Either disable legacy boot in the BIOS or bring up the BIOS boot menu and select the UEFI option to boot the ISO.

I havent seen a UEFI option to boot the iso, unless im just blind lol

Your BIOS should have some way to choose a boot device manually. It is typically a key combination you can press on boot or in the BIOS itself it will have a one-time boot option.

yes i know that, ive done that before but ive never seen a uefi option, ill check again now though

You can also, as has been mentioned, disable CSM/Legacy boot mode in the firmware settings.

Yes ill try that as i just booted the USB and there is no uefi option, ill disable Legacy now

Just a question, would it still be fine to disable CSM and Legacy Boot if i installed windows with those enabled?

From your disk layout, it appears windows is installed with EFI so it should be fine.

got it, thank you also just another question, should i just delete the endeavouros partition and extend my windows partition right now so when i go back to install endeavour again i dont have to do it later?

Just to confirm, in my bios i have “UEFI/Legacy Boot” as [UEFI Only] and CSM support on “No”, does this look right?

1 Like

Alright it booted perfectly fine, thought it wasnt booting because the windows logo wasnt there but the spinning circle was, do i remove the old endeavour partition now and try dualbooting it again?

No, just use the replace partition option in the installer

Alright thank you, ill let you know how it goes

First thing i noticed is that now SystemD is a bootloader option now, though i still go with grub for dualbooting right?