Wifi works in live environment, but not in install | Lenovo Ideapad MIIX 310-iCR (80sg)

In the EndeavourOS live environment I was able to connect to wifi with no issues. After installation to the 80sg was complete, I rebooted into my new system and found that wifi did not work anymore (no networks detected at all). When going back into the live environment to try and fix any issues with internet access, the wifi also no longer worked. This seems to happen with any Arch based distribution on this laptop. Wifi works just fine on Kubuntu (I’ve heard it also works on Xubuntu, so I assume all Ubuntu flavours work) and Fedora. The only way to get wifi to work in an installer again is to install one of those distributions. I’m not sure what my wifi module is and I have no good way to check since any command that could be useful does not return any results (lspci, rfkill, lsmod, nmcli, etc). The only way I can currently connect to the internet is by connecting to my phone via USB.

Try inxi, but a quick google suggests rtl8723bs, you could try to build on another computer and transfer and install from a usb drive. It is in AUR, other than that I am no use :smiley:

hardware info and other help to get started:

And welcome at the forum! :enos:

If wifi works on the Live Session of the ISO this looks like a kernel issue in the first place… so you could try LTS kernel to check this.

Hello, I have tried both the LTS kernel and normal kernel, both had the same problem.

Not sure if it is a kernel issue as the wifi also stops working after returning to the live environment.

Can you show the output booted on the live ISO.

inxi -Na

In the live ISO it says
Message: No PCI device found

Are you sure that WiFi is turned on? There should be an F key for WiFi and or airplane mode.

My function keys do not have functions like that, since on this laptop they are the number keys, where Fn is used to select the function functionality. Pretty sure it is turned on as I have done nothing to turn it off.

Well the hardware doesn’t show up. So it’s either off or there is another reason why it’s not showing. How about the following.


Edit: If it is RTL8723BS

There is firmware for it in the AUR. I’m just not sure if that is all that is needed to make it work or if that is only for the Bluetooth on the chip?


Edit3: There is a driver for the WiFi in the AUR but not sure it works.


The kernel should already include the driver. The AUR package was last updated in 2017, I doubt it still works and I would like a longterm solution anyway. lspci and lsusb do not show anything related to networking. My theory is that something Arch and Arch based distributions (I’ve also tried Manjaro) are doing during the install is disabling the device, since once Fedora or Ubuntu are installed it starts working again.

It is probably worth noting that bluetooth (I think it is part of the same device) shows up in the rfkill list with
Soft blocked: No
Hard blocked: No

could be it loads the wrong firmware on archbased?
you could check if it shows on boot:
journalctl -b -0 | grep firmware

But the device seems to hard fail to initializing it while booting or it is getting deactivated in another way…

You do have secure boot disabled on the laptop?

Edit: I think it has something to do with the firmware not loading and possibly secure boot on some distros.

Edit2: You can check dmesg when it works on live ISO and also when it doesn’t work on installed? Maybe it gives a hint.

Edit3: Have you tried removing the module and loading it again

sudo modprobe -r r8723bs
sudo modprobe r8723bs
1 Like
 Spectre V2 : Enabling Restricted Speculation for firmware calls
Feb 13 06:53:52 80sg systemd[1]: Store a System Token in an EFI Variable was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/LoaderFeatures-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Feb 13 06:53:53 80sg systemd[1]: TPM2 PCR Barrier (Initialization) was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Feb 13 06:53:53 -80sg systemd[1]: TPM2 PCR Barrier (User) was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
Feb 13 06:53:53 80sg kernel: atomisp-isp2 0000:00:03.0: Direct firmware load for shisp_2401a0_v21.bin failed with error -2
Feb 13 06:53:53 80sg kernel: atomisp-isp2 0000:00:03.0: atomisp: Error -2 while requesting firmware shisp_2401a0_v21.bin
Feb 13 06:53:55 80sg NetworkManager[444]: <info>  [1676224435.8421] manager[0x561582cec090]: monitoring kernel firmware directory '/lib/firmware'.
Feb 13 06:53:56 80sg systemd[1]: Startup finished in 6.040s (firmware) + 10.055s (loader) + 1.647s (kernel) + 3.830s (initrd) + 7.173s (userspace) = 28.748s.

Removing and loading the module didn’t seem to do anything. I have already disabled secure boot, the BIOS is quite basic and so there isn’t much I can do there. If I wanted to see it working on the live iso again I would need to install kubuntu/xubuntu or fedora onto the system.

From what i have read it seems that the firmware is there but it’s not loading it therefore it won’t find the device. That’s just my perception from what i read. I could be wrong. :man_shrugging:

I have contacted Lenovo to see what they know about it. My guess is that something is disabling hardware when it detects an OS that it is not expecting? Hopefully they don’t dismiss it as Linux not being supported or whatever.

Lenovo said that there should be nothing preventing the use of alternate OSes, which makes sense. So it must be something related to Arch/Endeavour.

Feb 13 06:53:53 80sg systemd[1]: TPM2 PCR Barrier (Initialization) was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).

Have you tried turning off TPM in UEFI Bios.