Wifi card not registered after boot

Usually around 20-30% of the time, my wifi card is not found, rebooting usually fixes it but its getting annoying now

inxi -Naz output

Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2725 class-ID: 0280

Are you dual booting with Windows? You need to make sure the Fast Start Up feature in Windows under power management is disabled if you are.

yep its disabled, problem still shows up

Have you tried disabling power management for the wifi card in /etc/modprobe.d/wifi.conf


options iwlwifi power_save=0 

Did not work, also another interesting i found is that i can not restart or shut down through software, if i type reboot in the terminal, it mentions something about a sleep or shutdown operation already in progress. So i have to shutdown by pressing and holding the power button

I guess you already checked the Windows settings. :man_facepalming:

Edit: You should set up the Magic SySRq Key

Maybe try the following

sudo pacman -S linux-firmware
sudo modprobe -r iwlwifi && sudo modprobe iwlwifi


Try this: nmcli network on

Linux-firmware is upto date so it just reinstalls
Modprobe does not work because iwlwifi is in use

Need more information. Post the urls

inxi -Faz | eos-sendlog

Edit: Also

sudo dmesg | eos-sendlog

journalctl -b -0 | eos-sendlog


Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2725
class-ID: 0280

The output shows that the proper module is loaded for the WiFi? Is it working?

[    4.681063] Intel(R) Wireless WiFi driver for Linux
[    4.681340] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002)
 4.724077] iwlwifi 0000:03:00.0: api flags index 2 larger than supported by driver
[    4.724118] iwlwifi 0000:03:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    4.724609] iwlwifi 0000:03:00.0: loaded firmware version 74.fe17486e.0 ty-a0-gf-a0-74.ucode op_mode iwlmvm

It’s loading the firmware.

Nothing stands out. It should be working. :man_shrugging:

By the way, i dont think i can do logs while offline, so i got these by restarting several times to get the card working again

Maybe it’s something to do with the Gnome desktop causing the issue?

Have you investigated why this is happening?

I am not sure if I read the journal correctly that you have provided, but it starts a shutdown sequence and a minute later it starts the gnome tracker:

Jun 25 18:40:29 gamingmachine systemd[820]: Reached target Shutdown.
Jun 25 18:41:39 gamingmachine systemd[1265]: Starting Tracker metadata extractor...

This is really weird. I would try to understand why this shutdown sequence is being started. It can well be the root cause for a deactivated wifi.

[ 0.000000] Linux version 6.3.9-zen1-1-zen
i would suggest to bail out kernel regression by booting into main kernel or LTS

Did you tried nmcli network on as I told you above? I had the same problem more than one time…

I am having the same issue. Has anyone found a solution yet?

Output of inxi -Fz:

  Kernel: 6.8.9-arch1-2 arch: x86_64 bits: 64
  Desktop: LXDE v: 0.10.1 Distro: EndeavourOS
  Type: Portable System: Dell product: Inspiron 3542 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0KHNVP v: A12 serial: <superuser required> BIOS: Dell
    v: A12 date: 05/13/2016
  ID-1: BAT0 charge: 22.1 Wh (94.4%) condition: 23.4/41.4 Wh (56.4%)
  Info: dual core model: Intel Core i3-4005U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 865 min/max: 800/1700 cores: 1: 798 2: 798 3: 880 4: 984
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
  Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting unloaded: vesa dri: crocus gpu: i915 resolution:
    1: 1366x768~60Hz 2: N/A
  API: EGL v: 1.5 drivers: crocus,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
    renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
  API: ALSA v: k6.8.9-arch1-2 status: kernel-api
  Server-1: PipeWire v: 1.0.6 status: active
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    driver: ath9k
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  IF: enp7s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 465.76 GiB used: 75.9 GiB (16.3%)
  ID-1: /dev/sda vendor: Toshiba model: MK5059GSXP size: 465.76 GiB
  ID-1: / size: 457.38 GiB used: 75.9 GiB (16.6%) fs: ext4 dev: /dev/sda1
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 51.0 C mobo: 49.0 C
  Fan Speeds (rpm): cpu: 2386
  Memory: total: 4 GiB available: 3.73 GiB used: 2.1 GiB (56.2%)
  Processes: 162 Uptime: 9m Shell: Bash inxi: 3.3.34