Wi-Fi card does not get detected

Same issue as Wi-Fi card not registered after boot.

Usually around 20-30% of the time, my wifi card is not found, rebooting usually fixes it.

My situation requires multiple reboots (>3) and a forced shut down (pressing and holding the power button) to resolve the issue. Sometimes, the situation escalates to the point where the system is rebooted more than five times, with a minimum of 2-3 forced shutdowns, followed by multiple reboots until the issue resolves.

What I have tried:

  1. Disabling power management for the Wi-Fi card in /etc/modprobe.d/wifi.conf.
    options ath9k power_save=0 
  2. Increasing the grub timeout to 10s.
  3. Restarting iwd.service after boot.
  4. Running nmcli network on.
  5. Manually restarting NetworkManager.service.
    sudo systemctl start NetworkManager.service
  6. Manually restarting iwd.service.
    sudo systemctl start iwd.service

Output of inxi -Fz:

  Kernel: 6.8.9-arch1-2 arch: x86_64 bits: 64
  Desktop: LXDE v: 0.10.1 Distro: EndeavourOS
  Type: Portable System: Dell product: Inspiron 3542 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0KHNVP v: A12 serial: <superuser required> BIOS: Dell
    v: A12 date: 05/13/2016
  ID-1: BAT0 charge: 22.1 Wh (94.4%) condition: 23.4/41.4 Wh (56.4%)
  Info: dual core model: Intel Core i3-4005U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 865 min/max: 800/1700 cores: 1: 798 2: 798 3: 880 4: 984
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
  Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting unloaded: vesa dri: crocus gpu: i915 resolution:
    1: 1366x768~60Hz 2: N/A
  API: EGL v: 1.5 drivers: crocus,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
    renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
  API: ALSA v: k6.8.9-arch1-2 status: kernel-api
  Server-1: PipeWire v: 1.0.6 status: active
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    driver: ath9k
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  IF: enp7s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros AR9462 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 465.76 GiB used: 75.9 GiB (16.3%)
  ID-1: /dev/sda vendor: Toshiba model: MK5059GSXP size: 465.76 GiB
  ID-1: / size: 457.38 GiB used: 75.9 GiB (16.6%) fs: ext4 dev: /dev/sda1
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 51.0 C mobo: 49.0 C
  Fan Speeds (rpm): cpu: 2386
  Memory: total: 4 GiB available: 3.73 GiB used: 2.1 GiB (56.2%)
  Processes: 162 Uptime: 9m Shell: Bash inxi: 3.3.34

Logs URL:

Note: The wifi is working properly in the current boot and all the logs are gathered from the same boot.

  1. inxi -Faz | eos-sendlog: https://0x0.st/XZuB.txt.
  2. sudo dmesg | eos-sendlog: https://0x0.st/XZut.txt.
  3. journalctl -b -0 | eos-sendlog: https://0x0.st/XZuv.txt.
    The issue was on previous boot, so for that:
  4. journalctl -b -1 | eos-sendlog: https://0x0.st/XZuw.txt.
    Logs from May 19 - present
  5. journalctl -k -b all | eos-sendlog: https://0x0.st/XZSW.txt.

Have you tried

sudo modprobe -r btusb
sudo modprobe btusb

No. The wifi is working properly in the current boot, so I will have to wait to test this solution.

It didn’t work.

Sometimes my card will stop working. Similar driver / family. It has something to do with race conditions and was never fully investigated / fixed.

My fix_wifi script goes like this:

sudo rmmod ath10k_pci && sudo modprobe ath10k_pci

So for you it will be just ath9k instead of ath10k_pci


Other possible troubleshoot steps:

  1. Try wpa_supplicant instead of iwd


Bro - you collected a lot of logs, but most of them are useless. Ex. we need dmesg from time, when WifFi does not work.

sudo rmmod ath10k_pci && sudo modprobe ath10k_pci
So for you it will be just ath9k instead of ath10k_pci

Will try this.

Other possible troubleshoot steps:

  1. Try wpa_supplicant instead of iwd

Tried this, didn’t work out.