Wifi card disabled on waking from suspend

Following my travails last week trying to solve a perplexing WIFI problem ( Wifi interface no longer shows) the problem recurred yet again today. The same fix I applied last time has worked yet again (disabling the WIFI adapter and re-enabling it), and I can use WIFI now - but I wonder why this problem occurs at all in the first place?

As on the previous occasions, it occurred when the laptop woke from suspend. The problem also does not seem to affect my external RALINK wifi adapter, and does not occur when I boot from a live USB. If anyone has any suggestions at all that can help me find a permanent solution to this issue, I would appreciate it.

Did you try to update your Bios yet?

Thanks for the suggestion - I haven’t, largely because I thought that this was a recipe for bricking your computer but I’ll look into it now. This computer is over two years old now though and I’ve only had this problem for the past week so it didn’t occur to me that the BIOS might be the culprit.

If I remember right, you had to disable / re-enable your wifi in Bios, to make it work again, temporarily.
Your computer doesn’t have a hardware-switch (or Fn key) to toggle Wifi on / off, does it?

1 Like

It does but this does not do anything to fix the problem when it occurs - that was the first thing I tried.

Here is the timeline

  1. Problem first occurs when waking from suspend
  2. Problem persists after reboot
  3. Problem disappears when booting from live USB
  4. Problem “fixed” by reinstalling OS, only to reoccur again an hour later after starting from suspend
  5. WIFI appeared enabled in BIOS, but disabling and re-enabling the wifi adapter nevertheless “fixed” the problem
  6. Problem seemed fixed for a week until I woke the laptop again from suspend. Rebooting did not fix it but disabling and re-enabling the adapter did.

Also suspending the laptop does not always cause the issue but it only has occurred when waking from suspend.

…and did you find an update for your Bios?

I will do some more reading into how to update the BIOS safely and look into doing it this week. Do you think the problem is BIOS related, even though it occurs only when the laptop wakes from suspend?

Also note: I haven’t updated the BIOS since I bought this PC in 2020.

I would like to help you with the process of updating the Bios. Normally it is not dangerous at all, if certain precautions are taken. Those are usually given in the manufacturer’s manual, or on their support-website, where you can download potential system-updates for software and Bios.

What computer are we talking about? Can you give make, model, etc.?

Also, a look into the manufacturer’s manual of your computer can save you a lot of other things to worry about… like hardware-switches for Wifi, e.g. (see above).

Reading up on your older thread again I found, you have no hardware-switch for Wifi, so disregard my repeated question about this.

It could well be the case, I think.

The F8 key is supposed to enable or disable WiFi. However, curiously I found just now that when I click FN-F8 it does quite efficiently disable WiFi but clicking it again does not re-enable it. When my WiFi adaptor stopped functioning I tried enabling it using Fn-F8 but it did nothing, hence I thought it was not the issue.

My UEFI BIOS version is 1.17 and according to this page the most recent version for my device is 1.20: https://pcsupport.lenovo.com/ie/en/products/LAPTOPS-AND-NETBOOKS/THINKPAD-EDGE-LAPTOPS/THINKPAD-E15-TYPE-20RD-20RE/20RD/20RDCTO1WW

I’m going to go to bed now but I’ll read up on updating the BIOS tomorrow.

There seems to be light at the end of the tunnel!


Please do so. It’s really almost a must-do. Your bricking worries are too rooted in the past. This is still a “new” machine, and new machines tend to need revised BIOS’ the most.

Also–if you’ve ever had Windows on this machine–Windows like to “capture” hardware peripherals and experience shows it sometimes takes a bit of effort to break Windows’ hold on them.


Months later, I ended up finally flashing the bios as the WIFI started failing even when I was actively using the machine. It seems to have worked as I can enable and disable WIFI using the F8 key again.

I spoke too soon, despite the UEFI update the problem persists… Whenever my laptop wakes from sleep mode, wifi is unavailable and I need to disable/re-enable it from bios in order to get it to work again. Anyone have any suggestions how to find a proper fix for this?

Since both BT and WiFi are on the same chip, there may be various interferences, even some USB-devices sharing the same IRQ leading to failures.

Interesting. I have no USB device plugged in at the moment. Whatever the issue is, it would have to have occurred in the last few months or so, because I bought this laptop in March 2020 and the issue first cropped up about two years later. I guess I’d better start putting aside money for a new laptop, which would be a crying shame as this laptop otherwise works fine.

Would you suggest I disable bluetooth when I am not using it and see if that improves stability?

It be worth a try.
Also, a web-search for your issue may provide some more insight.

  Device-1: Intel Comet Lake PCH-LP CNVi WiFi

A new computer is always a last resolve, whereas a new wifi-card (perhaps usb) might be an easier approach.

So I can confirm that the problem does NOT appear when I have bluetooth disabled. Moreover, I have narrowed down what I think is the problem - the computer will not sleep or hibernate with bluetooth enabled. However, under certain conditions (low power etc) it will be forced to suspend at which point the issue arises.

When I try to manually put the computer to sleep/hibernate with bluetooth enabled the screen freezes for a few moments. It seems that other users have problems with bluetooth interrupting the sleep, but I’ve seen no solution.

I’ve rfkill block bluetooth and disabling bluetooth in KDE and the same issue arose - computer will not sleep or hibernate. The computer will only sleep/hibernate when it is disabled in the bios.

This is annoying because I actually use bluetooth quite a bit - bluetooth speakers, headphones, etc. etc. I’d love to find a solution that would let me enjoy my music and also not lose wifi but idk what to do.

What’s wrong with shutting down the 'puter when not in use in your case?