Wifi adapter RTL8821CE and black screen after reboot

Yesterday I got it running on Manjaro with the help of @ricklinux and @manuel. Now I want to use it with EndeavourOS. The problem here is that after installing EndeavourOS the screen stays black and I can’t start tty …

The system is installed as above, a reboot is pending and the install-log is on Github …

Are you able to get into TTY

Ctrl Alt F2

Edit Log in as root

Only from the live system.

Is can set to tty2 logged in as root (root@archiso)

after restart I cannot access the tty with ctrl alt f2

When you boot into the system when you get to the black screen can you not Ctrl Alt F2 to get into the TTY?

no … that is the problem …

Can you hit Ctrl Alt F2 before it gets to the black screen.

yes that worked. after the boot menu of endeavourous i was able to press ctrl alt f2 before it gets to the black screen.

at this point the steps from yesterday?

  • sudo pacman -Syu
  • sudo pacman -S base-devel
  • sudo pacman -S linux58-headers
  • yay -S rtl8821ce-dkms-git

or check something else first?

The base-devel should always be checked when installing on the online installer. Did you uncheck it on the install?

choose offline installation method. it can be that base-devel already exists. With manjaro: yay -S rtl8821ce-dkms-git ran into an error because something was missing from the base-devel package. I’ll see then …

Lets do what you did yesterday.

sudo pacman -S --needed sddm
sudo systemctl disable lightdm
sudo systemctl enable sddm
reboot

everything worked without problems. i write from the new system via wlan in the forum and use sddm …

individual steps:

Ctrl ALt F2 (tty2)
sudo pacman -Syu
yay -S rtl8821ce-dkms-git
sudo pacman -S --needed sddm
sudo systemctl disable lightdm
sudo systemctl enable sddm
reboot

backlight error:

[gr1mwalk3r@gr1mwalk3r-archlinux ~]$ systemctl --failed
UNIT LOAD ACTIVE SUB DESCRIPTION >
● systemd-backlight@backlight:acpi_video0.service loaded failed failed Load/Save Screen Backlight B>

I’m not sure why lightdm is not working correctly? It’s puzzling!

For the backlight error try the following kernel paramter in the grub boot line.

acpi_backlight=vendor

Also did you get the wireless installed?

yay -S rtl8821ce-dkms-git

1 Like
1 Like

Thank you all for the awesome support. Friendly community in its core. Confirmed … Incredible!

Have send a gift/ contribution of €42 on October 10th 2020.

Keep up the excellent work!

3 Likes

Great that is works now! :smile:

And thanks for the donation!
Donations will help us keep this rolling! :sweat_smile:

As @joekamprad already mentioned, this is not available in EndeavourOS nor Arch. We have:

  sudo pacman -S linux-headers

and if you wish to install another kernel, this should do it:

  sudo pacman -S linux-lts linux-lts-headers

Alternatively you can user the kernel manager program: akm.

can be the issue…

@Gr1mwalk3r
Now that you have eos installed you should use popsicle-git to create bootable usb. You can install it with:

yay -S popsicle-git

Edit:
Screenshot_20201010_155218

Thank you @manuel

It is recommended to use the LTS kernel?

I will do it in the future the way @ricklinux said: popsicle-git to create bootable usb …

Thanks for your answer …