Wifi adapter RTL8821CE and black screen after reboot

Hi …

I have a HP 255G7 with the WLAN module: RTL8821CE.

The following problem occurs. I am installing the rtl8821ce-dkms package together with the headers for Kernel 5.8.

sudo pacman -S linux58-headers
yay -S rtl8821ce-dkms

This goes so far without any problems …

But after a restart my screen remains black. The system won’t start anymore, no matter how often I try.

I am new to the Linux world and have no idea what I can do.

I have already reinstalled EndeavourOS twice (UEFI and MBR) and am now looking for help …

Thanks a lot

Try the rtl8821ce-dkms-git version

Nothing has changed. I can still access the tty and log in. The journalctl says something about:

lightdm.service: Failed with result and failed to start Light Display Manager.

I still don’t understand why the “Light Display Manager” doesn’t work after installing the rtl8821ce-dkms-git package

Edit: with the rtl8821ce-dkms i could not reach the tty after reboot. a small progress with the *dkms-git package

systemctl status --failed

Edit: Boot up and go into tty with ctrl f2

Log in as root and check

Should be: Boot up and go into tty with Ctrl Alt F2

systemctl --failed

lightdm.service loaded failed failed
systemd-backlight@backlight:acpi_video0.service loaded failed failed
systemd-backlight@backlight:amdgpu_b10.service loaded failed failed

Could you assist here to enable and start the two failed services. I’m at work right now and on mobile phone which is not handy.


You can try to enable and start lightdm.

systemctl enable lightdm.service

systemctl start lightdm

Edit: See if this works and then we can deal with the backlighting.

It worked!! After a restart the same problem.

Wlan also works with the *dkms-gti version

1 Like

So all is well and your problem solved?


It would be nice if this happens automatically after the reboot. lightdm.service failed after each restartI … still have to enter the two commands …

Welcome! :smile:

What is your DE?

I’m guessing some setting is not right with lightdm.
As a workaround, you could try if sddm works instead of lightdm:

sudo pacman -S --needed sddm
sudo systemctl disable lightdm
sudo systemctl enable sddm

XFCE :smiley:

I will try the sddm …

It would be helpful also if you can install inxi

yay -S inxi

Post this command

inxi -Fxxxa --no-host

Thanks to all of you for the great support.

Finally, i changed the “display manager” to sddm. Works fine …@manuel

Wlan is running and booting now without problems.

The problems with the backlight are problematic? At least not critical for tonight (Germany, 12:30 a.m.)

1 Like

The display manager for Xfce is normally lightdm. It’s obvious there was an issue with its installation and or configuration. Glad it’s up and running. If you can install inxi and post the command I gave you above it will helpful. There are two other backlight issues. I will let @manuel help you with the lightdm issue and maybe the others too but seeing the hardware info will help.

I still have to transfer the solution steps to my EndeavourOS.

I couldn’t get any further from the point: Boot up and go into tty with CTRL + ALT+ f2 and had to change the distribution to Manjaro before you answered. EndeavourOS stays black right after the first reboot and can’t be reached via tty. I prepared the stick with Rufus 3.11.1678 and the image: endeavouros-2020.09.20-x86_64 for tomorrow. The support here is really first class. It would be great if we could run EndeavourOS on the laptop. I simply like it more!

I think you’ll need to have it installed in order to fix any issue that you have. If you have trouble you can always boot on the live ISO and get on the forum and hopefully get advice. Then you would boot back into the installed system and make changes. Hopefully @manuel will be around to help with some of the more intricate things.

Edit: Once you get installed and is booting properly I think the backlighting issue might be resolved with the kernel parameter acpi_backlight=vendor added to the grub line and update grub.

  1. Start the Live/System with endeavouros-2020.09.20-x86_64.iso and UEFI/GPT from Rufus 3.11
  2. Update the Welcome APP from v3.4.35-1 to 3.4.36-1
  3. Start the Installer and choose offline installation method
  4. Location Europe/Berlin
  5. Erase disk, with Swap (no hibernate)
  6. Filesystem
    6a. new gpt partition table on /dev/sda
    6b. 300MB partition on /dev/sda with the filesystem fat32
    6c. flag 300MB fat32 as boot
    6d. create 230GB partition on /dev/sda with the filesystem ext4
    6e. create 9GB partition on /dev/sda with the filesystem linuxswap
    6f. Set up new fat32 partition with mount point /boot/efi
  7. Install EndeavourOS on new ext4 system partititon

I have not restarted yet and remain in the live system until further instructions follow.

Install-Log: https://github.com/Gr1mwalk3r/EOS-installation/blob/main/install-log

EndeavourOS or Manjaro ?