Why my wifi only works on instalation phase

The kernel of instalation interface is 5.17.1. If I click to set by default r8168 or r8169, it works anyway, but only on this instalation phase. When my Endeavour is complete to use, even if I change from r8168 to ~~~69 it doesn’t work. So I tried to change my kernel but I don’t know how to install this specific one. On 5.15 and 5.18 it doesn’t work simply and I’m trying it for hours. If my problem is not the kernel and not change 68 for 69 and vice versa, then what it is? Work like a charm on instalation phase with this kernel.

The drive that is missing is R8188eus, with S in the end. Where to find these?


Can you run the following command from terminal so we can know your hardware configuration:

inxi -Fxxc0z --no-host


Also check out the following thread:

1 Like

Kernel: 5.18.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 wm: kwin_x11 dm: SDDM
Distro: EndeavourOS base: Arch Linux

Info: quad core model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell
rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 3065 high: 3395 min/max: 800/3400 cores: 1: 2126
2: 3392 3: 3395 4: 3348 bogomips: 25550
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Gigabyte driver: i915 v: kernel arch: Gen5.75 ports:
active: HDMI-A-1 empty: VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0412

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8168 v: 8.050.03-NAPI pcie: speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: N/A bus-ID: 3-6.2:5 chip-ID: 0bda:8179
IF-ID-1: enp0s20u6u4 state: unknown speed: -1 duplex: half mac:

I tried LTS Kernel and installed 8188eu-dkms; no success, even though i tested all my kernels. Still, nothing.

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: N/A

1 Like

I was checking the Arch forum and it looks like the newest driver might be broken for the Realtek RTL8188EUS.



Then why it works normally on the instalation phase? That’s weird.

My guess is the install setup used an older driver. Then when the install starts downloading and setting up the OS it upgrades to the latest.


Whats the best way to downgrade the wifi driver since its from the AUR?

1 Like

Is there a way to change my kernel to that used on the install setup (5.17.1)? If so, can you teach me so I could try it? Sorry for bothering. Waiting @pebcak help!

If I am not mistaken, you could change the pkgver= in the PKGBUILD to point to another version.
However, in this case I don’t know which version it should be. I can’t see in the Github page. I guess you could just uninstall 8188eu-dkms for the kernel module to be used instead.

Also, in the Arch Forum post you linked to, the OP seems to have solved the issue by installing 8188eu-dkms-git.


I would not downgrade your kernel yet. I mainly use laptops so i tend to use the latest LTS with a patched driver.

Last week I installed a TP-Link Archer T3U USB wifi on my wifes laptop. The latest stable kernel powered the usb wifi but at very low speeds. So I switched her to the LTS kernel and patched driver. Now shes all happy.

This is the documentation i am reading:


I tend to be in the Arch wiki allot.


1 Like

I simply tried 8188eu-dkms-git and it worked. This is my third day attempting to fix this issues on Arch distros, haha. Thanks you both, i’m very happy now.


It takes patience and research to iron out wrinkles. I tend to come to the forums here so i can get pointed in the right direction. Glad your all fixed.I find it rewarding when i get to learn.


Glad you got it resolved!
Credit where credit is due, you might want to consider to mark @kagetora13’s post pointing to the Arch Forums’ post as the solution.

Also, welcome to EnOS’ community @pierrelatour!

:enos_flag: :handshake:t5:


Thanks man. Were one team here. :smile:


The driver should rtl8188eu … currently.

r8188eu is a USB driver for RTL8188EU devices. It’s going to be replaced by rtl8xxxu.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.