Why is endeavour os not using btrfs hook in mkinitcpio?

I checked the mkinitcpio config file after installation and there’s something crc32-intel but not btrfs hook.
Why is that so?
Also i installed with btrfs, swap with hibernate and full disk encryption.
The system boots and works, has anyone else tried that as well and is it fool proof?

For this sort of thread it would be useful for you to say why including the btrfs hook by default might be useful.

Otherwise, there would be any number of threads asking “why is such-and-such the default?” for every possible combination of software and settings (“Why ix Xfce the default?”, “Why is linux the default kernel?”, etc. etc. etc.).

That’s not surprising:

okay, i didn’t know that. What about enabling swap with hibernate with btrfs file system and encryption. Does that work okay?

In what context?

I meant in the installation context. Selecting erase disk, btrfs, swap with hibernate and selecting encryption.
Is that combination implemented correctly in calamares installer of endeavour os. As, I installed using those.

What makes you think that it might not be correctly implemented if the system is functioning properly?

1 Like

Well, it’s just a lot of stuff to do.

This appears to be a continuation of this thread:

This makes me wonder whether you actually have a problem with an EnOS installation or are looking for theoretical issues that don’t exist.

1 Like

It doesn’t matter which option or flavour you choose, they all offer the same powerful jumpstart to begin your exciting journey towards your own destination in computing. All options have the basics like sound, network, graphics, Yay, a terminal operated AUR helper and the browser Firefox already onboard. This is the perfect start in creating your own personal computing experience, custom-made by you.

If you like to roll up your sleeves and go on an adventure, then you might want to give us a try. EndeavourOS isn’t an expressway to a predefined destination in computing, it is all about the journey towards your own destination

https://endeavouros.com/

Good luck on your endeavour!

:wave:t5:

1 Like

Well, I was just asking if anybody else here has tried that combination. Nevertheless, thanks.

To answer the topic question.

Because there is no installer which can accomodate for every single possible configuration option.

Personally I have a love-to-hate relationship with btrfs as it requires to much maintenance.

It is like jogging - it isn’t fun - have you ever seen a laughing jogger?

watch out

image

1 Like

I’ve installed it in that manner several times during testing.

Everything appeared to be working correctly. Albeit this is not how my everyday computer is setup, so I can not verify the long term results of my computer in that direction (I use ext4).

1 Like

So if you are not having any particular issue with your installation and this is not a help request, please consider editing your first post and move the thread to #lounge. Thanks!

PS. If you want, I could do it for you.

You already asked that in the other thread, and the answer about how to find out whether it will work on your system was to try it and see.

An installer providing options that don’t work would be a pretty terrible piece of release engineering - why on Earth would something like that be included?

1 Like

What is the difference between adding “btrfs” to MODULES or to HOOKS?

Not sure what this had to do with this thread, but see the explanation from the relevant Arch wiki page https://wiki.archlinux.org/title/Mkinitcpio#Configuration: