Why I only have manual partitioning available?

I have 5 drives In my PC and I used dual boot to choose between Win10 and EOS:

  1. 500GB (nvme) => Windows 10 (old OS)
  2. 250GB => Endeavour OS (Main system)
  3. 120GB => Windows 10 drive mounted inside KVM
  4. 1TB (nvme) => formated in ext4 and used as main storage drive for EOS
  5. 1TB (hdd => formated in ntfs and used as main storage drive for windows

Recenty I had a hardware failure (PCU + GPU died) and for some reason after replacement I couldn’t boot into EOS anymore but I went directly into Windows. I wanted to move EOS to bigger drive anywas + remove second version of windows and this is a great opportunity to reinstall EOS on 1TB nvme drive.

I want to keep Windows 10 and install EOS on 1TB nvme drive and I don’t know yet what to do with other drives. However I wanted to install a fresh EOS and noticed that I can only choose Manual partitioning for some reason. When I installed EOS previously I remember that I had more option and I choosed automatic partition.

Is not a big deal, but I don’t want to set manual partitions because I’m happy with default partitioning. What is the reason that I don’t have that option ??

Does it show like so for all drives?
I see the current selected is in MBR partition scheme, but you are booted on EFI mode… What would need GPT scheme…


Plus, in case you do some stuff by mounting partitions in file-browser, it could be they are still mounted and that causes options to not show.

yes, all drives have only manual option. I admint that I don’t quite understand this MBR vs GPT scheme / EFI mode ect… :slight_smile:

I’ll try to boot differently. I use Venotoy to boot EOS

and all drivers are showing MBR?

Modern system using EFI (UEFI) (using a fat32 partition for the bootloader files) firmware/boot and the way you create partition scheme is GPT.

Old systems using BIOS and MBR to boot (Master Boot Record first space on the drive)

But if system supports EFI you should use that, in case windows in running in legacy CSM Bios mode (or other used instaleld OS) you can possible also set boot to only use legacy mode and install EndeavourOS in Bios mode too… But for this you need to boot the ISO in legacy Bios mode what would show Bios instead of EFI top left…

1 Like

Hey, thanx. I booted with second option I had available and now I see all options for partitioning on every drive.

There is another minor annoyment when trying to install it. For some reason when I’m typing anything anwhere sometimes a key becomes stuck and you write something like thissssssssssssssssssssssss

Same thing happened me on my previus install. After OS is installed works fine, apparently it’s a problem only on love boot.

l :heart_hands:ve boot :heart_eyes:

What is the system specs?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.