Why do I get black screen after upgrade to 555 nvidia-beta?

I was following this thread because I want to install 555 for wayland.

After removing nvidia and nvidia-utils and install nvidia-beta and nvidia-utils-beta, I restarted the PC and after login through sddm I boot into a black screen.

What is the problem here? How can I get 555 to work?

Note that I’m not looking to get black screen fix as I can remove the beta drive from live cd. I’m trying to get the beta working.

1 Like

After yesterdays Linux core package upgrade, nvidia beta driver package prevents my system from booting, problem was fixed after switching to nvidia stable. So i’ll guess Linux just don’t like nvidia-beta package atm.

Notes:

  1. The beta package is not suitable to all Nvidia cards.
  2. Currently the beta package has an older version number than the “standard” Arch package.

Edit: sorry, beta is not older, my bad.

That isn’t nice. I was trying Hyprland and like it out of the box compared to my current i3 setup. The flickering in most apps makes it unusable.

Maybe will have to wait for the 555 to release but how know when lol

I see that why it isn’t working for me.

For me the nvidia beta package with version 555.x worked the löast few days without problems and now the nvidia package from arch extra repo with version 550.x fixed the problem i had today with the beta package

Yeah, just noticed that and edited my previous post.

You could try using nvidia-beta-dkms instead of nvidia-beta.

Just make sure you have the headers installed for your kernel.

Thanks i will try that out now, will keep you updated

nvidia-beta-dkms package works without problems :smiley:

thanks for the advice

1 Like

I install nvidia-beta-dkms and still got the black screen after logging in :frowning_face:

Is there anything I need to aware of

Do you have the headers installed for your kernel?

What is it? Is it the linux-headers kernel?

Can you show the output of commands

pacman -Qs nvidia
pacman -Qs linux headers
inxi -Gza

Here’s the output from my system:

❯ pacman -Qs nvidia
local/egl-wayland 2:1.1.13-2
    EGLStream-based Wayland external platform
local/envycontrol 3.4.0-1
    CLI tool for Nvidia Optimus graphics mode switching on Linux
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 550.78-1
    NVIDIA NV-CONTROL X extension
local/nvidia 550.90.07-4
    NVIDIA drivers for linux
local/nvidia-hook 1.5-2
    pacman hook for nvidia
local/nvidia-inst 24-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-utils 550.90.07-3
    NVIDIA drivers utilities
local/nvtop 3.1.0-1
    GPUs process monitoring for AMD, Intel and NVIDIA
❯ pacman -Qs linux headers
local/linux-api-headers 6.8-1
    Kernel headers sanitized for use in userspace
local/linux-headers 6.9.6.arch1-1
    Headers and scripts for building modules for the Linux kernel
❯ inxi -Gza
Graphics:
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
    built: 2021-22+ ports: active: none empty: DP-2, DP-3, DP-4, DP-5
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0380
  Device-2: NVIDIA AD106M [GeForce RTX 4070 Max-Q / Mobile] vendor: ASUSTeK
    driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-06) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ ports: active: none
    off: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 0000:01:00.0 chip-ID: 10de:2860
    class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:7 chip-ID: 2b7e:b685
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
    compositor: Picom v: git-89c2c driver: X: loaded: modesetting,nvidia
    alternate: fbdev,intel,nouveau,nv,vesa dri: iris
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 144 s-size: 339x191mm (13.35x7.52")
    s-diag: 389mm (15.32")
  Monitor-1: not-matched mapped: DP-2 size-res: N/A modes: N/A
  Monitor-2: not-matched mapped: HDMI-0 pos: primary res: 1920x1080 dpi: 83
    size: 590x330mm (23.23x12.99") diag: 676mm (26.61") modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
    surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4070 Laptop
    GPU/PCIe/SSE2 memory: 7.81 GiB
  API: Vulkan v: 1.3.279 layers: 9 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 4070 Laptop GPU driver: nvidia v: 550.90.07
    device-ID: 10de:2860 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.2-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib

Looks like you can just uninstall package nvidia and install nvidia-dkms. And if you want to use the beta version, install nvidia-beta-dkms instead of nvidia-dkms.

And remember to reboot after doing the above.

Edit: replace also nvidia-utils with nvidia-utils-beta (when using beta stuff).

Hi there, It was Xrandr that didn’t output to the display on my monitor. I’m using the i3 with config from the Endeavouros and have enabled my screen to activate to 170hz.

Anytime, I try to do xrandr --rate 170 for my 2nd monitor it went black. I suspect it has something to do with Nvidia Optimus or something. When launching Hyprland, the second monitor is not powering at all but the mouse can still move into that screen from my laptop monitor.

At this point, I’m pretty lost. The mod key also suddenly stop working for i3, hyprland, and awesomewm after the beta driver installed.

I’m not sure what to look into anymore maybe I’ll give up altogether and wait for the official release. I still want that explicit sync to work because I want to use my favorite apps in wayland and hyprland.

Though, I tried to launch Steam games and it seems to open normally but in 60hz.

Try this

2 Likes

I second this. This saved me so much headache updating the nvidia drivers and even let me switch over to the dkms version after running a system update.

1 Like

Final update:

A normal installation of nvidia-beta and nvidia-utils-beta is enough to get things working (don’t forget to remove nvidia and nvidia-utils for the future reference. Also make sure to set in all monitors to 60hz in xrandr or whatever display you use and go up from there).

The blank screen I originally encountered was due to a problem with the 555 that could not output a higher refresh rate on my second display to more than 120hz. I have configured my xrandr to disable main monitor and set my 2nd one to 170hz. No way I could troubleshoot this until I launch awesomewm that I have installed that doesn’t launch xrandr script by default.

I will be sticking with 120hz until the release of 555.

I have no problem with app like Edge browser and Obsidian anymore after the update.