How to update to Nvidia 555 beta drivers

I am currently running Endeavour OS KDE with the 550.78 Nvidia drivers and a 4090. I would like to give the 555 beta driver a try and see how I like it and if it fixes the issues with Wayland. I see that it is available in the AUR, however, the install keeps failing. It says there is a conflict between nvidia-beta-utils and nvidia-utils. So I’m assuming I need to remove the exisitng 550.78 driver before installing the beta drivers. I’m fairly new to Endeavour so I’m not really sure how to do this.

1 Like

Only the one or the other, indeed.
The pack is always two packages:

  • nvidia
  • nvidia-utils

or

  • nvidia-beta
  • nvidia-utils-beta

it should ask to replace as far as i can see:

conflicts=('nvidia-utils' 'nvidia-libgl')

and in case there is also:
nvidia-settings-beta → https://aur.archlinux.org/packages/nvidia-settings-beta

You would have to uninstall nvidia drivers using pacman(yay) -Rdd command and then install beta drivers.

Installation fail because of dependencies, new package you are trying to install expects corresponding beta utils/kernel module. Which obviously is not yet there, on top of that those are dependencies for other packages.

As a side note the nvidia 555 drivers are available for Windows. I installed them to see how they work and will update on EndeavourOS when available.

1 Like

Thank you everyone. I will try that when I get home. Do I need to reboot after uninstalling drivers before installing the beta ones?

No. Simply reboot after installing the beta versions.

Thank you! I also had to run yay -Rdd nvidia-utils to get nvidia-beta to install, but then everything worked. However, now Steam won’t load. Doesn’t give me any kind of error message or anything. I click on Steam and nothing happens. I guess I’ll switch back to 550 drivers and wait for 555 to become official release instead of beta. I can use X11 until then.

Mistake is mine, I just assumed you will know what packages you have installed.

So to make it work you need to uninstall all packages that are part of 550 branch drivers, so it will be

  • nvidia (alternatives for this package are nvidia-dkms or nvidia-open-dkms)
  • nvidia-utils
  • lib32-nvidia-utils < it will be required by steam to even work.
  • nvidia-settings

You will have to uninstall all of those packages, and install beta versions.

If you have nvidia package installed then command to uninstall current branch will look like this:

yay -Rdd nvidia nvidia-utils lib32-nvidia-utils nvidia-settings

command to install beta packages will be

yay -S nvidia-beta nvidia-utils-beta lib32-nvidia-utils-beta nvidia-settings-beta

if you don’t want settings package installed then you can skip it.


One more note, you could list all packages you have installed, write it to text file and search said file for nvidia name. But you can also search official repo for nvidia packages with

pacman -Ss nvidia

it will mark packages you have installed

alternatively you can use

yay S nvidia

this will list all nvidia packages in repo + aur, mark which ones you have installed and their version.

Both commands will wait for you to specify packages you want install, not selecting any and pressing enter will end program without installing anything.


Also It is worth mentioning that pacman -Rdd should not be used lightly, it can break the system!

2 Likes

Do you feel any difference so far on 555 vs 550?

Great information thank you! I’ve messed around with Linux before, but it was all things like Mint or Ubuntu. I’ve never delved into the terminal. I switched to Endeavour because I wanted to be more bleeding edge and to learn more about the inner workings of my system. Everything you said makes sense. I will try some of that stuff.

What does the -Rdd command do versus -R that could break your system? And how does when know when you should or shouldn’t use -Rdd?

FYI that worked. I’m on the beta drivers and everything is working. Gonna try it out for a bit and see how it goes, but so far so good. Do I need to install the explicit sync kwin package?

Yes. The biggest difference is in Discord which stuttered a lot and I had to run it with xwayland at least for now, and because I was too lazy to actually make push to talk work on wayland.

As for games Guild Wars 2 which i often play had huge tearing problem, it is not the best optimised game so fps tanked during meta events or even when i had too many players on my screen. It is butter smooth now.

Cyberpunk was unplayable, and even if previous drivers somehow fixed the issue, tearing still occurred now and then. It runs fine now.

So far I have not had time to test anything else, but results are promising.

1 Like

I myself ditched Windows 2 years ago. Using terminal centric distro requires a lot of learning but it gets easier with time :wink: Before EOS i had some experience with linux but never to this extent.

-Rdd is used to remove packages that are required by other packages without removing dependent package itself. It can be dangerous and break the system that is why it is not advised. In this case though that was fastest and cleanest way of replacing some packages.

https://wiki.archlinux.org/title/Pacman section 1.2

Thank you!

And I broke my install somehow during all this. Lol! Guess I get to do some research and figure out how to fix it now!

What exactly did you break ? If not me someone might be able to help.

I already fixed it.

So I installed the beta drivers. Rebooted. Everything was fine. Installed the kwin-explicit-sync package, rebooted, everything was fine. Updated my system (don’t remember what files it updated), rebooted, and it would hang at the startup screen at the “reached graphical interface” part. Googled how to do a tty log in, removed the beta drivers and kwin-explicit-sync and rebooted and it was fine.

Decided to try the beta drivers again and ran into same problem. I’m not sure what was updated, but something in the update doesn’t play nice with the beta driver.

Sounds like nvidia kernel module issue. I think it happened to me before, and I think it was about that time when i have switched to dynamic kernel module support version of nvidia driver. Well since I am in “testing” mood my driver is nvidia-open-beta-dkms because nvidia already announced that they will switch to open gpu kernel modules. So since I am already running beta drivers, why not dive deeper?

Ha! Sounds good! Let me know what you find.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.