Welcome app not launching

Noticed Welcome app is not launching anymore on boot. Won’t launch from the terminal or from the menu. I see the Icon in the task bar for a moment with it circling the icon then closes. No error messages in the terminal. Just doesn’t launch. This is on Wayland with Nvidia and Kde. Tried enabling it. still nothing.

Edit: It is also not launching on X11.

Edi2: Update in the terminal works but not any of the other apps in the start menu.

On terminal, what does command

/bin/eos-welcome

say?

Works here Hyprland:

Does nothing. Same as if i try to launch it with eos-welcome from the terminal.

[ricklinux@asus-tuff ~]$ /bin/eos-welcome
[ricklinux@asus-tuff ~]$ 

Strange. Are welcome, yad, and eos-bash-shared properly installed?
Here it all works on KDE and wayland.

As far as i know. I did try reinstalling Welcome but no difference.

Edit
Should i try reinstalling some packages?

And did you reboot?

Edit: yes please, the ones I mentioned.

1 Like

I just tried and no difference.

Edit: The only one that launches is the eos-update

Edit2: Not sure even when it stopped working.

Edit3: It’s exactly the same on X11 or Wayland. This is my Intel with Nvidia machine on KDE.

Sorry, can’t reproduce the issue here. But I have no Nvidia available now.

What happens if you run just

  yad

?

Funny i see the eos-update-notifier right now.

[ricklinux@asus-tuff ~]$ yad
yad: error while loading shared libraries: libdav1d.so.6: cannot open shared object file: No such file or directory
[ricklinux@asus-tuff ~]$ 

pacman -Q yad

1 extra/dav1d 1.3.0-1 [0B 1.77MiB] [Installed]

I had reinstalled this also.

[ricklinux@asus-tuff ~]$ pacman -Q yad
yad 13.0-2.1
[ricklinux@asus-tuff ~]$ 

I have newer libdav1d.so.7

How do i get that to try?

dav1d 1.3.0-1

I have an older version?

Edit: I just checked.

[ricklinux@asus-tuff ~]$ pacman -Qi dav1d
Name            : dav1d
Version         : 1.3.0-1
Description     : AV1 cross-platform decoder focused on speed and correctness
Architecture    : x86_64
URL             : https://code.videolan.org/videolan/dav1d/
Licenses        : BSD
Groups          : None
Provides        : libdav1d.so=7-64
Depends On      : glibc
Optional Deps   : dav1d-doc: HTML documentation
Required By     : chromium  ffmpeg  ffmpeg4.4  libavif-git  libheif
Optional For    : vlc
Conflicts With  : None
Replaces        : None
Installed Size  : 1807.46 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 04 Oct 2023 11:21:55 AM
Install Date    : Sat 07 Oct 2023 08:36:32 AM
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[ricklinux@asus-tuff ~]$ 

May need to update Arch mirrors.

pacman -Q dav1d