Weird freezes/stuttering

Hello everyone,
if recently installed endeavourOS on my laptop, however I’m getting a lot of stuttering sometimes.
When I just have CLion, Firefox and a Terminal running everything works fine, however when I start doing stuff like installing games from Steam my entire laptop starts to stutter, and freeze. I can’t even get into a tty sometimes.
No clue how to debug this, I hope someone here has an idea.
Using the NVIDIA drivers, installed with nvidia-inst. (using an NVIDIA Quadro M2000M).
Everything is up-to-date, I’m using KDE Plasma.
I’ve had stuttering on other distros as well, but never even close to this.

1 Like

posting logs can help. do you have nvidia settings installed? If so do you also have Force Composition Pipeline checked? may also need to check Force Full Composition Pipleline as well.

I wasn’t sure which logs should I post exactly, since I have no clue what is causing it. The entirety of what sudo dmesg outputs?
I have nvidia-settings installed, I cannot find Force Composition Pipeline, maybe I’m just blind, where in nvidia-settings can I find it.

click the advanced button and it will show the option for Force Comosition Pipeline and Force Full Composition Pipeline.

Tried both, they seem to make it worse. I even had lag when having nothing open and trying to open a terminal.

Hopefully someone who uses KDE can give some better insight to what could be happening. I only use a WM so not sure what to tell you with KDE.
View and Post logs to get others to be able to pinpoint the possible issue. How old is the Laptop/Memory?

What is the hardware? Post the url

inxi -Faz | eos-sendlog
1 Like

I bought it second hand in 2020, not sure how old it is exactly, Boot screen says 2018.
I can try running memtest, it’s been quite a while since I last ran it.

you could try enable full composition pipeline for nvidia:

4. Enhancement avoid screen tearing

Have nvidia-settings installed and run it on login with tagging option FullCompositingPipeline to get better video quality, this works for a single display setup. If you have more, you need to add them to the command or option line, for this take a look at the arch-wiki page linked here.

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

You can add this to /etc/X11/xorg.conf.d/20-nvidia.conf like this:

Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"

Section "Screen"
        Identifier      "nvidia"
        Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"

In some cases like using Plasma and SDDM it can be that you need to set DPI settings on multi-display setups.

The easiest way around this is to set DPI in .Xresources to do so:

sudo nano ~/.Xrescources and add DPI settings.

Xft.dpi: 96

On KDE, this can be achieved by adding the following section to /etc/sddm.conf (create the file if it does not exist) :

ServerArguments=-nolisten tcp -dpi 96

Replace 96 by your desired DPI value.

There is also a PKGBUILD at AUR to build a simple auto starter for full-compositing-pipeline:

you can build and install:

yay -S nvidia-force-comp-pipeline nvidia-settings

It will check display setup and enable it automatically using nvidia-settings on login to the session.

1 Like

Xorg logs:
I had the laptop running for a while, I opened steam at [ 1418.155] which resulted in ridiculous lag spikes as before.

Already tried that (start of the thread), it made it worse.

Is this still true?
How old is the hard drive? Have you checked it?

Without Force Composition Pipeline that still works.
I don’t have any HDDs, my Linux SSD is around 6 months old. I haven’t checked it yet.


  Type: Laptop System: HP product: HP ZBook 15 G3 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 80D5 v: KBC Version 10.73 serial: <superuser required>
    UEFI: HP v: N81 Ver. 01.23 date: 01/30/2018

There is a newer Bios update for that laptop.

Edit: If i have the correct information it looks like the update is 2023. v 1.60 Revision A

Are you sure the BIOS is the issue here? I don’t like the idea of updating my BIOS, because I know I’m somehow going to manage to mess it up :sweat_smile:

I’m just telling you there is an update. I do know that sometimes doing these type of updates can cause failures although i never seem to have any issues. I don’t see any issue with the hardware other than this. I also don’t see why you should have any freezing other than it is coming from the game platform itself. I don’t think it should be a KDE problem.


Steam isn’t the only thing that causes the lag and freezes. It just happens that opening steam and starting a download is the easiest way for me to replicate it.
I guess I’ll update my BIOS anyways, it will at least have a bunch of security fixes.

1 Like

Seems to be fixed after this? Maybe my internet connection is just so slow that the lag isn’t noticable :man_shrugging:

Not sure i understand? Did you update the UEFI Bios already?