Lag when on on battery power

Related to my other topic ( Weird freezes/stuttering ) which was fixed. My laptop was always plugged in then, now on battery power it always lags, no matter whether I have anything open.
Using KDE and NVIDIA drivers installed with nvidia-inst. Let me know if you need any other info.
System info:
Xorg log file:

Info: model: Intel Core i7-6820HQ socket: U3E1 bits: 64 type: MT MCP
arch: Skylake-S gen: core 6 level: v3 note: check built: 2015
process: Intel 14nm family: 6 model-id: 0x5E (94) stepping: 3
microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3003 high: 3551 min/max: 800/3600 base/boost: 3200/8300
scaling: driver: intel_pstate governor: powersave volts: 1.2 V

Read through the following Wiki article and see if changing the governor to something like conservative, ondemand or performance could help:

Have you tried using the latest kernel instead of the lts?

Ok, I’ll try that

1 Like

No, but I can try that

It’s just a suggestion. I know you have updated the UEFI Bios so it wouldn’t hurt to try. I know it’s only a 6th gen processor but i don’t think that should be a problem. I’m not one of those linux users who believe in using an lts kernel unless necessary for a particular hardware reason.

Using the non lts kernel now, however the performance issues are back, even when plugged in.
It actually became worse, it even lags when just working with Dolphin + CLion… I have no clue why this is happening, I keep my system up to date, and don’t do anything crazy on it.
If nobody has any idea how I can fix or actually debug this I’ll unfortunately have to move back to some other linux distro, even though I like endeavouros a lot. Using it with these issues as a daily driver is just not possible.
Let me know if you need any other logs that I haven’t posted already.

Honestly i don’t understand why people have these issues either. I’m not a big laptop user and i have only a few laptops which i only install EndeavourOS. I don’t install or use any other power management packages only what is included other than using pstates on Ryzen.

I don’t have anything other than this laptop, and I don’t have the budget right now to buy a PC, so I’m stuck with it…
I guess the search for a distro which just works continues…
I’ve already tried Debian, Ubuntu, Arch, Manjaro, Pop_OS, and Fedora, I’m starting to run out of decently popular distros to try :see_no_evil:

If it acts this way on everything i would say it’s a hardware issue that probably can’t be fixed without replacing the motherboard.

I’d rather blame this on my GPU, instead of on the motherboard.
As a last ditch effort I just tried installing nouveau (with nvidia-inst --nouveau), now the login screen doesn’t even show… I can see sddm in htop, but it doesn’t show…

Managed to fix it, now that lag is gone. I guess it was a NVIDIA issue :confused: I’ll just stick to gaming on windows for now, and use Linux for coding.

That makes sense to me that it was nvidia. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.