Weird behaviour on active workspace after disabled screen

I use an extension for KDE that makes the windows tile like a tiling WM:

The problem only appears after the screen went blank, for example because I didn’t move my mouse, or because of hibernation. It doesn’t appear always, only sometimes.

The problem only affects the workspace that was active while the screen went black.

What happens:
The windows are not filling the whole screen, but instead there are gaps, like an additional (completely transparent) window. For example, one window is on the left side of the screen, one window is on the top right side of the screen, and nothing is on the bottom right side. It looks like this, where A is window1, B is window2, and [] is nothing.

A []

I’m able move windows to the blank space, but then the blank space is moved to another position (like a window). For example like this:

[] B
[] A

Sometimes the workspace also gets unresponsive. If I then close a specific (random?) window, plasma crashes, and the system goes back to normal.

What I tried to fix it:

  • log out and back in (this works)
  • restart plasmashell (doesn’t work): kquitapp5 plasmashell || killall plasmashell && kstart5 plasmashell
  • restart kwin with alt + f2 + kwin --replace (doesn’t work)
  • disable and enable the extension (results in the extension not working at all)
  • switch workspace (doesn’t work)


Have you tried kronhkite under kwin scripts. It works fine.

Yes, I tried it. But I always accidentally make windows float (by moving them with the mouse). If you know how to disable that, this would be an option for me, too.

Not sure off hand.