Weird behavior

I don’t know what kind of log I need to include but this is the situation I’m in.

Off of a fresh reboot, my system is laggy and slow…
What I mean is, programs start up promptly and all
but slow and laggy as in
-lots of screen tearing (when watching youtube or netflix)
-tons of cluttering? stuttering? when scrolling in web browsers

But!
All this goes away once I logout and log back in!

What could be causing this?

I can live with it but would be nice to iron out.

That will give a good start to debug your problem :slight_smile:

Specifically this will give us all info about your system:

inxi -Fxxc0z --no-host

You’ll need to install inxi first:

sudo pacman -S inxi

Also this will give you errors in journal, if there are some:

journalctl -p3 -xb

Video drivers most likely, we’ll need to see logs with commands above to give more details :upside_down_face:

1 Like

Here’s inxi -Fxx0z --no-host

➜ inxi -Fxxc0z --no-host
System:
Kernel: 5.9.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: i3 4.19 dm: LightDM Distro: EndeavourOS
Machine:
Type: Desktop Mobo: ASRock model: Z97M Anniversary serial:
UEFI: American Megatrends v: P2.20 date: 03/08/2018
Battery:
Device-1: hidpp_battery_0
model: Logitech G304 Lightspeed Wireless Gaming Mouse serial:
charge: 100% (should be ignored) status: Discharging
CPU:
Info: Dual Core model: Intel Pentium G3258 bits: 64 type: MCP
arch: Haswell rev: 3 L2 cache: 3 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12804
Speed: 4200 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4200
2: 4200
Graphics:
Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia
v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:1380
Display: x11 server: X.Org 1.20.10 compositor: picom driver: nvidia
resolution: 2560x1080~60Hz s-dpi: 112
OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 455.45.01 direct render: Yes
Audio:
Device-1: NVIDIA GM107 High Definition Audio [GeForce 940MX]
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbc
Device-2: Creative Labs EMU20k2 [Sound Blaster X-Fi Titanium Series]
driver: snd_ctxfi v: kernel bus ID: 04:00.0 chip ID: 1102:000b
Sound Server: ALSA v: k5.9.14-arch1-1
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 1.94 TiB used: 1.62 TiB (83.4%)
ID-1: /dev/sda vendor: Crucial model: CT128M550SSD1 size: 119.24 GiB
speed: 6.0 Gb/s serial:
ID-2: /dev/sdb vendor: Toshiba model: DT01ACA200 size: 1.82 TiB
speed: 6.0 Gb/s serial:
Partition:
ID-1: / size: 116.58 GiB used: 11.22 GiB (9.6%) fs: ext4
dev: /dev/sda2
ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat
dev: /dev/sda1
Swap:
Alert: No Swap data was found.
Sensors:
System Temperatures: cpu: 55.0 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:
Processes: 165 Uptime: 1h 21m Memory: 7.72 GiB used: 2.2 GiB (28.5%)
Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 956
Shell: fish v: 3.1.2 running in: xfce4-terminal inxi: 3.2.00>

and here’s journalctl -p3 -xb

➜ journalctl -p3 -xb
– Journal begins at Sat 2020-12-19 20:46:51 KST, ends at Mon 2020-12-21 01>
Dec 21 00:07:38 JDT lightdm[622]: gkr-pam: unable to locate daemon control >
Dec 21 00:10:46 JDT lightdm[1660]: gkr-pam: unable to locate daemon control>
lines 1-3/3 (END)>

did I post them correctly? Thanks in advance

1 Like

Yep, usually it’s better to put logs in code tags like that:

```
code
```

But it’s fine, let’s see what you got here…

It’s PC, with i3 and Nvidia card, proprietary drivers. nothing unusual so far…

Show that file please

cat "/etc/X11/xorg.conf.d/20-nvidia.conf"
1 Like
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
    Option		   "TripleBuffer" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

wow this one looks kinda messy :sweat_smile:

Huh…Well anyway, according to that metamodes setup you shouldn’t have tearing / stuttering with i3 :thinking:

@joekamprad @jonathon @Elloquin, ideas?

1 Like

yeah it’s kinda weird…
after a fresh reboot = tons of tearing and stuttering…
once I logout and log back in, everything’s smooth and snappy :thinking:

Perhaps that is the problem, but i’m not sure how to heal, need others:

What changes have you made to your picom.conf ?

1 Like

absolutely nothing…

could be that compositor (picom) is the issue, you could try enable vsync (disabled per default)
Or try
exec --no-startup-id xcompmgr -c
and comment:
# exec --no-startup-id picom -cC

2 Likes

had little issue with -cC so switched to -f

1 Like

Screentearing with NVIDIA’s proprietary drivers

Try this setting in picom.conf:

vsync = true;


Screen artifacts/screenshot issues

Try running Picom with:

–backend xrender

or add

backend = “xrender”;

to your picom.conf file.

See [5] for more information.

1 Like
   -f, --fading
       Fade windows in/out when opening/closing and when opacity changes, unless
       --no-fading-openclose is used.

i know

tried this after testing your second suggestions but no luck :sob:

tried all the suggestions but no success…
it’s just a minor annoyance so I guess I’ll just live with it :laughing:
thank you all for the input!

1 Like

added those lines but to no avail…
it’s really weird cuz everything’s fine after i do a simple logout and loggin back in :thinking:

Do you have a swap file?