Wayland on Gnome with Nvidia Card

I know there are a lot of Threads and Guides on this topic, but none of them work for me.

I have a clean install of EOS and a RTX 4080 GPU with the latest proprietary drivers installed (550.76)
Running Gnome 46 with GDM.

What I have tried so far:

  1. Checked in /etc/gdm/custom.conf that wayland is enabled

  2. Added nvidia-drm.modeset=1 to /etc/default/grub and ran grub-mkconfig -o /boot/grub/grub.cfg
    cat /sys/module/nvidia_drm/parameters/modeset returns Y as it should.

  3. Added the line add_drivers+=” nvidia nvidia-drm nvidia-modeset nvidia-uvm ” in /etc/dracut.conf.d/nvidia.conf. Then executed sudo dracut-rebuild. Source: https://discovery.endeavouros.com/nvidia/nvidia-optional-enhancements-and-troubleshooting/2021/03/

  4. nvidia-suspend.service, nvidia-hibernate.service and nvidia-resume.service are enabled.

  5. Uncomment the whole file /usr/lib/udev/rules.d/61-gdm.rules as proposed in this post: Up-to-date tutorial for enabling Wayland on Nvidia desktop?
    Did not work, therefore tried sudo ln -s /dev/null /etc/udev/rules.d/61-gdm.rules. Still no Wayland :frowning:

  6. kms-modifiers enabled gsettings set org.gnome.mutter experimental-features ‘[“kms-modifiers”]’

After all that Wayland is still not available, the gear icon on the GDM login screen gives me the Option for Gnome and Plasma(X11). After I log out and then open the gear icon I can choose between Gnome, Gnome on Xorg, Plasma and Plasma(X11). So Wayland is available after I logged in with X11 once.

But of course it would be way more convenient to have it available immediately and I have no idea what to try next. Any help would be very much appreciated.

Did you check your environment variables and all the other requirements at this article:
https://wiki.archlinux.org/title/wayland

?

  1. https://wiki.archlinux.org/title/GDM#Wayland_and_the_proprietary_NVIDIA_driver
  2. Restart gdm

I had no problems on an RTX3070, but I was using sddm. A cursory glance at what you said matches exactly what I did. Give sddm a try (as a test).

Hang on - are you definitely on grub? Default install is systemd-boot, so you need to modify:

/etc/kernel/cmdline

???

Thank you all for the replys.
@herr_marschall I set the environment variables but that didn’t change anything. The other requirements were already met.

@Cphusion already followed that wiki, did not work. But I’m not sure if the modules in the modprobe.d folder work when using dracut since that seems to change how the initramfs is generated. But I dont know a way to check that.

@xircon Yes I definitely have grub. I’m using a dual-boot system and always used grub for that and stuck with what I knew.
Sddm did work but I am now having other issues than with gdm. I could immediately select Gnome on Wayland but after typing my password I got a black screen and was back at the login windows. The third attempt then worked and I was on Gnome using Wayland.
Also is there a difference between Gnome on Wayland and Gnome(Wayland)?

When I still had an Nvidia gpu, I used different module names because that’s how they loaded into the os. I added those to the dracut configuration, so these ones.
force_drivers+=" nvidia nvidia_modeset nvidia_uvm nvidia_drm "
https://wiki.archlinux.org/title/Dracut#Early_kernel_module_loading

tl;dr: Just used KDE instead of Gnome, worked instantly

Thank you all for your help.
I sadly wasn’t able to get Wayland to work out of the box - the best way being logging into an X11 Session, logging out and then back into Wayland.
Since I need Wayland for per-monitor fractional scaling, which is a pain to setup in X11, I just tried KDE Plasma and surprisingly everything 100% worked out of the box without any changes whatsoever.

Maybe I will try Gnome again with Gnome 47 or 48 and hope they improve the Wayland/Nvidia support, but for now I choose the easy way and just use KDE :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.