Wayland Not Working By Default On An Offline Install

A few weeks ago I borked my grub config after using grub customizer while messing with boot entries.
This prompted me to do a fresh offline install of endeavour os, however when I try to run wayland now , it just simply logs into a blank screen with three xterm terminals and x-shaped cursor .
I have all the dependencies for wayland fulfilled but it doesnt’t work . X11 works perfect.

Any idea ?

Idea 1: You need to give more details about your environment.
Idea 2: Is this with sddm or gdm? With KDE, XFCE or gnome?
Try it with gdm and gnome. KDE and XFCE might not be there yet.

1 Like

KDE , sddm , earlier worked like two months ago and now doesn’t . Gnome is crap.

is this on Nvidia?

In such a case I would create another user and test with this new user. If the problem is persistent then it is a system wide problem. If not then it is a problem with some settings of your user.


Default user created during install, admin privileges, don’t think this is related to users.

It may be very unlikely but: Did you remove any package where then also some dependent packages were removed?


you might want read " https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/ "

FWIW… Wayland works fine for me, running SwayWM on EOS.

As you @Hitman_Agent47 can tell from the help people would like to provide, your lack of installation related information leaves folks simply guessing. Fear not though, they will give up soon. :wink:

I don’t know why you had to use the online installer. Because the recent EOS ISO release comes with KDE as the default offline install environment. And I think it uses Wayland by default.

No . Just simply didn’t work out of the box , the first time I booted into my installation and ran it , it gave me the issue.

I used the online installer so my system is updated at startup and I can get setting it up right away

system logs: https://0x0.st/HIHY.txt

specs this is not logs :wink:

Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 dm: SDDM

this will be startx without setting up your .xinitrc this is default xorg minimal X system.

To run kde wayland session you only need to install one single package: plasma-wayland-session

With this installed you should be able to choose between Xorg and wayland session from DM (sddm)

Can you show the output of command

cat ~/.bash_profile

in the installed system?

Installed it already, doesn’t work still.


# ~/.bash_profile

[[ -f ~/.bashrc ]] && . ~/.bashrc

if [ -z "$DISPLAY" ] && [ -n "$XDG_VTNR" ] && [ "$XDG_VTNR" -eq 1 ]; then
  exec startx

Sorry , I don’t understand . I installed the package and choose wayland session from login but it doesn’t work at all